- Update to 0.9.1

- Lots of reinplacements and patches removed.
- Install the static lib, too
- Byebye divx4.h
- Use ${LN} -sf instead of ${LN} -s in post-install

PR:             50410
This commit is contained in:
Max Khon 2003-03-29 17:25:54 +00:00
parent 39c41ad247
commit c35272cf1b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=77692
6 changed files with 9 additions and 127 deletions

View File

@ -6,58 +6,24 @@
#
PORTNAME= xvid
PORTVERSION= 0.9.0
PORTREVISION= 1
PORTVERSION= 0.9.1
PORTEPOCH= 1
CATEGORIES= graphics
CATEGORIES= multimedia
MASTER_SITES= http://files.xvid.org/downloads/
DISTNAME= xvidcore-${PORTVERSION}
DISTNAME= ${PORTNAME}core-${PORTVERSION}
MAINTAINER= michaelnottebrock@gmx.net
COMMENT= An opensource MPEG-4 codec, based on OpenDivx
BUILD_DEPENDS= ${LOCALBASE}/bin/nasm:${PORTSDIR}/devel/nasm
ONLY_FOR_ARCHS= i386 sparc64
USE_AUTOCONF_VER= 253
USE_PERL5_BUILD=yes
HAS_CONFIGURE= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
CONFIGURE_WRKSRC= ${WRKDIR}
WRKSRC= ${WRKDIR}/${DISTNAME}/build/generic
# XXX - compatility header installed for mplayer-devel port's benefit
EXTRA_HEADER_FILES= divx4.h
post-install:
@ ${LN} -sf libxvidcore.so ${PREFIX}/lib/libxvidcore.so.0
# trick to detect existence of stdint.h
# amongst other things
pre-configure:
.for file in configure.in config.h.in
@ ${CP} ${FILESDIR}/${file} ${WRKDIR}
.endfor
post-patch:
.for file in Makefile.linuxx86 Makefile.sparc
${REINPLACE_CMD} -e 's|-lc||' ${WRKSRC}/$(file)
.endfor
do-install:
@ ${INSTALL_DATA} ${WRKSRC}/libxvidcore.so ${PREFIX}/lib/libxvidcore.so.0
@ ${LN} -s libxvidcore.so.0 ${PREFIX}/lib/libxvidcore.so
@ ${INSTALL_DATA} ${WRKSRC}/../../src/xvid.h ${PREFIX}/include
# XXX - compatility header installed for mplayer's benefit
.for header in ${EXTRA_HEADER_FILES}
@ ${INSTALL_DATA} ${WRKSRC}/../../src/${header} ${PREFIX}/include
.endfor
.include <bsd.port.pre.mk>
.if ${ARCH:L} == i386
MAKEFILE= Makefile.linuxx86
.elif ${ARCH:L} == sparc64
MAKEFILE= Makefile.sparc
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (xvidcore-0.9.0.tar.gz) = 8d0cd15a9d935ec46d3b67eddf188c4a
MD5 (xvidcore-0.9.1.tar.gz) = d4b4cb185f074082e17b36c24b277276

View File

@ -1,14 +0,0 @@
/* Define as 1 if you have sys/endian.h. */
#undef HAVE_SYS_ENDIAN_H
/* Define as 1 if you have sys/param.h. */
#undef HAVE_SYS_PARAM_H
/* Define as 1 if you have stdint.h. */
#undef HAVE_STDINT_H
/* Define as 1 if you have inttypes.h. */
#undef HAVE_INTTYPES_H
/* Define size of uintptr_t type. */
#undef SIZEOF_UINTPTR_T

View File

@ -1,12 +0,0 @@
dnl Process this file with autoconf to produce a configure header
AC_INIT(config.h.in)
dnl Check for and header files
AC_CHECK_HEADERS(sys/endian.h sys/param.h stdint.h inttypes.h)
dnl Check size of pointer for cache size
AC_CHECK_SIZEOF(uintptr_t)
AC_CONFIG_HEADER([config.h])
AC_OUTPUT(config.h)

View File

@ -1,58 +0,0 @@
--- ../../src/portab.h.orig Sat Nov 23 22:50:14 2002
+++ ../../src/portab.h Fri Jan 3 14:40:18 2003
@@ -83,6 +83,14 @@
* Types used in XviD sources
****************************************************************************/
+#if defined(HAVE_SYS_PARAM_H)
+#include <sys/param.h>
+#endif
+
+#if defined(__FreeBSD__) && __FreeBSD_version >= 470000 && defined(HAVE_SYS_ENDIAN_H)
+#include <sys/endian.h>
+#endif
+
/*----------------------------------------------------------------------------
| Standard Unix include file (sorry, we put all unix into "linux" case)
*---------------------------------------------------------------------------*/
@@ -90,8 +98,15 @@
#if defined(LINUX) || defined(BEOS) || defined(FREEBSD)
/* All (u)int(size)_t types are defined here */
-# include <inttypes.h>
+#include "../../config.h"
+
+#if defined(HAVE_STDINT_H)
+#include <stdint.h>
+#elif defined(HAVE_INTTYPES_H)
+#include <inttypes.h>
+#endif
+
/*----------------------------------------------------------------------------
| msvc (lacks such a header file)
*---------------------------------------------------------------------------*/
@@ -139,6 +154,9 @@
#elif defined(ARCH_IA64)
# define CACHE_LINE 32
# define ptr_t uint64_t
+#elif defined(__FreeBSD__)
+# define CACHE_LINE (SIZEOF_UINTPTR_T * 4)
+# define ptr_t uintptr_t
#else
# error Architecture not supported.
#endif
@@ -341,6 +359,13 @@
{
return 0;
}
+
+/*----------------------------------------------------------------------------
+ | FreeBSD specific macros/functions
+ *---------------------------------------------------------------------------*/
+# elif defined(__FreeBSD__) && __FreeBSD_version >= 470000 && defined(HAVE_SYS_ENDIAN_H)
+# define BSWAP(a) (be32toh(x))
+# error Missing EMMS() definition for this architecture.
/*----------------------------------------------------------------------------
| XviD + gcc unsupported Architecture

View File

@ -1,4 +1,4 @@
include/divx4.h
include/xvid.h
lib/libxvidcore.a
lib/libxvidcore.so
lib/libxvidcore.so.0