audio/sc3-plugins: Update to 3.9.0

Submitted by:	myself
Reported by:	portscout
Approved by:	tcberner (mentor)
Differential Revision:	https://reviews.freebsd.org/D14106
This commit is contained in:
Yuri Victorovich 2018-01-29 16:19:41 +00:00
parent 04c43d10af
commit c340b5c775
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=460315
3 changed files with 5 additions and 18 deletions

View File

@ -1,8 +1,8 @@
# $FreeBSD$
PORTNAME= sc3-plugins
DISTVERSION= 3.8.0
PORTREVISION= 1
DISTVERSIONPREFIX= Version-
DISTVERSION= 3.9.0
CATEGORIES= audio
MAINTAINER= yuri@FreeBSD.org
@ -25,7 +25,6 @@ OPTIONS_SUB= yes
USES= cmake:outsource localbase pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= supercollider
GH_TAGNAME= 5342a4a
GH_TUPLE= timblechmann:nova-simd:3140689:n/external_libraries/nova-simd
CMAKE_ARGS+= -DSYSTEM_STK:BOOL=ON
CMAKE_ARGS+= -DSC_PATH:STRING=${LOCALBASE}/include/SuperCollider/ # see https://github.com/supercollider/sc3-plugins/issues/170

View File

@ -1,5 +1,5 @@
TIMESTAMP = 1503361784
SHA256 (supercollider-sc3-plugins-3.8.0-5342a4a_GH0.tar.gz) = 09fa3e09828d1ace053a71527b89811704505bb0743d266e5c47a7ef70ae4183
SIZE (supercollider-sc3-plugins-3.8.0-5342a4a_GH0.tar.gz) = 3454858
TIMESTAMP = 1515960660
SHA256 (supercollider-sc3-plugins-Version-3.9.0_GH0.tar.gz) = b9f5cc6444c087671879b973bd281289dbe1faa66a5965d21e855f7639e4fc19
SIZE (supercollider-sc3-plugins-Version-3.9.0_GH0.tar.gz) = 3455817
SHA256 (timblechmann-nova-simd-3140689_GH0.tar.gz) = ba2d5e6d42208d85fae6eacad9f51f34e9b582c7f83cfdf2c71c8fb05f92eeda
SIZE (timblechmann-nova-simd-3140689_GH0.tar.gz) = 52899

View File

@ -1,12 +0,0 @@
--- source/StkInst/CMakeLists.txt.orig 2017-08-11 11:25:31 UTC
+++ source/StkInst/CMakeLists.txt
@@ -51,6 +51,9 @@ endif()
if(SUPERNOVA)
add_library(${PROJECT}_supernova MODULE ${PROJECT}.cpp ${STKSources})
+ if(SYSTEM_STK)
+ target_link_libraries(${PROJECT}_supernova ${STK_LIBRARY})
+ endif()
set_property(TARGET ${PROJECT}_supernova APPEND PROPERTY COMPILE_DEFINITIONS "SUPERNOVA")
include_directories(${SC_PATH}/external_libraries
${SC_PATH}/external_libraries/boost-lockfree