- Update to version 7.0 and unbreak

- Provide better port description

Approved by:	maintainer timeout
This commit is contained in:
Alexey Dokuchaev 2005-02-14 07:20:19 +00:00
parent ffa0059c40
commit c3405b7788
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=128751
7 changed files with 84 additions and 78 deletions

View File

@ -6,33 +6,36 @@
#
PORTNAME= tea
PORTVERSION= 2.0
PORTREVISION= 1
PORTVERSION= 7.0
CATEGORIES= editors
MASTER_SITES= http://tea.linux.kiev.ua/
DISTNAME= ${PORTNAME}
MAINTAINER= jylefort@brutele.be
COMMENT= A simple GTK+ text editor
COMMENT= A simple and powerful GTK+ text editor
.if defined(WITH_ASPELL)
LIB_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
.endif
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
BROKEN= Size mismatch
EXPIRATION_DATE= 2005-02-18
DEPRECATED= ${BROKEN}
USE_X_PREFIX= yes
USE_BZIP2= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
USE_GCC= 3.3
USE_GCC= 3.4
USE_GNOME= gtk20
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
pre-everything::
.if !defined(WITH_ASPELL)
@${ECHO_MSG} "Define WITH_ASPELL to build with aspell support"
.endif
post-patch:
@${REINPLACE_CMD} -e 's|/usr/share/doc/tea|${DOCSDIR}|g' \
${WRKSRC}/Makefile.in \
${WRKSRC}/src/tea_funx.c
@${REINPLACE_CMD} -e 's|/tea/doc/|/doc/tea/|' \
${WRKSRC}/src/tea_defs.h
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
MD5 (tea.tar.bz2) = c1065c65ec03d64c072b228fed86e9cd
SIZE (tea.tar.bz2) = 190976
MD5 (tea.tar.bz2) = 006bb8478983e3c21cd07b382da45555
SIZE (tea.tar.bz2) = 302743

View File

@ -0,0 +1,33 @@
--- Makefile.in.orig Sun Feb 13 10:59:41 2005
+++ Makefile.in Sun Feb 13 11:04:08 2005
@@ -18,6 +18,7 @@
top_srcdir = @top_srcdir@
VPATH = @srcdir@
pkgdatadir = $(datadir)/@PACKAGE@
+pkgdocsdir = $(datadir)/doc/@PACKAGE@
pkglibdir = $(libdir)/@PACKAGE@
pkgincludedir = $(includedir)/@PACKAGE@
top_builddir = .
@@ -542,16 +543,12 @@
install-data-local:
@$(NORMAL_INSTALL)
- $(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/doc; \
- cp -r $(srcdir)/doc $(DESTDIR)$(pkgdatadir); \
- cp $(srcdir)/FAQ $(DESTDIR)$(pkgdatadir)/doc; \
- cp $(srcdir)/AUTHORS $(DESTDIR)$(pkgdatadir)/doc; \
- cp $(srcdir)/ChangeLog $(DESTDIR)$(pkgdatadir)/doc; \
- cp $(srcdir)/README $(DESTDIR)$(pkgdatadir)/doc; \
- cp $(srcdir)/NEWS $(DESTDIR)$(pkgdatadir)/doc; \
- cp $(srcdir)/COPYING $(DESTDIR)$(pkgdatadir)/doc; \
- cp $(srcdir)/TODO $(DESTDIR)$(pkgdatadir)/doc; \
- cp $(srcdir)/BUGS $(DESTDIR)$(pkgdatadir)/doc; \
+ $(mkinstalldirs) $(DESTDIR)$(pkgdocsdir); \
+ cp -r $(srcdir)/doc/ $(DESTDIR)$(pkgdocsdir); \
+ cp $(srcdir)/AUTHORS $(DESTDIR)$(pkgdocsdir); \
+ cp $(srcdir)/ChangeLog $(DESTDIR)$(pkgdocsdir); \
+ cp $(srcdir)/NEWS $(DESTDIR)$(pkgdocsdir); \
+ cp $(srcdir)/TODO $(DESTDIR)$(pkgdocsdir); \
if test -d $(srcdir)/pixmaps; then \
$(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/pixmaps; \
for pixmap in $(srcdir)/pixmaps/*; do \

View File

@ -1,34 +0,0 @@
--- src/callbacks.c.orig Tue Jul 13 17:01:57 2004
+++ src/callbacks.c Tue Jul 13 17:05:25 2004
@@ -24,6 +24,7 @@
#include <gdk/gdk.h>
#include <gdk/gdkkeysyms.h>
+#include <sys/param.h>
#include <errno.h>
#include <sys/stat.h>
#include <glib.h>
@@ -1065,9 +1066,10 @@
if (get_page_fnav ())
{
+ char buf[MAXPATHLEN];
gchar *fn = (gchar*) g_malloc (2048);
- if (realpath ((gchar *) get_current_dir_name (), fn))
+ if (getcwd(buf, sizeof(buf)) && realpath (buf, fn))
set_fam_text (fn);
else
set_fam_text ("/");
@@ -3005,9 +3007,10 @@
if (get_page_fnav ())
{
+ char buf[MAXPATHLEN];
gchar *fn = (gchar*) g_malloc (2048);
- if (realpath ((gchar *) get_current_dir_name (), fn))
+ if (getcwd(buf, sizeof(buf)) && realpath (buf, fn))
set_fam_text (fn);
else
set_fam_text ("/");

View File

@ -1,25 +0,0 @@
--- src/tea_text_document.c.orig Tue Jul 13 17:05:42 2004
+++ src/tea_text_document.c Tue Jul 13 17:11:39 2004
@@ -36,6 +36,7 @@
#include <stdio.h>
#include <strings.h>
#include <unistd.h>
+#include <sys/param.h>
#include "tea_file_nav.h"
#include "tea_text_document.h"
@@ -1289,12 +1290,13 @@
t_note_page* page_create_new_filenav (void)
{
+ char buf[MAXPATHLEN];
t_note_page *page = (t_note_page *) g_malloc (sizeof (t_note_page));
page->hash_filelist = NULL;
gchar *fn = (gchar*) g_malloc (2048);
- if (realpath ((gchar *) get_current_dir_name (), fn))
+ if (getcwd(buf, sizeof(buf)) && realpath (buf, fn))
page->current_path = fn;
page->type = 1;

View File

@ -1,4 +1,20 @@
TEA is a simple GTK+ text editor.
TEA is powerful text editor for GNU/Linux and *BSD. It depends on GTK+2
only (and GNU aspell optionally). With an ultimate small size TEA provides
hundreds of functions. Some of the features include:
- Built-in file manager
- Spellchecker (using aspell)
- Tabbed layout engine
- Multiple encodings support
- Code snippets, sessions and templates support
- RTF-reader
- Miscellaneous HTML tools
- Preview in external browsers
- Bracket matching, syntax highlighting
- Bookmarks
- Drag'n'drop support (with text files and pictures)
- Built-in image viewer (PNG, JPEG, GIF, WBMP, BMP)
- Automatic text encoding detection for various languages
WWW: http://tea.linux.kiev.ua/

View File

@ -1,9 +1,22 @@
bin/tea
share/locale/de/LC_MESSAGES/tea.mo
share/locale/ja/LC_MESSAGES/tea.mo
share/locale/pl/LC_MESSAGES/tea.mo
share/locale/ru/LC_MESSAGES/tea.mo
share/locale/sr/LC_MESSAGES/tea.mo
share/locale/uk/LC_MESSAGES/tea.mo
%%DOCSDIR%%/doc/en/index.html
%%DOCSDIR%%/doc/ru/index.html
@dirrm %%DOCSDIR%%/doc/en
@dirrm %%DOCSDIR%%/doc/ru
@dirrm %%DOCSDIR%%/doc
%%DATADIR%%/pixmaps/lgm.png
%%DATADIR%%/pixmaps/tea_icon_v2.png
%%DATADIR%%/pixmaps/tea_logo.jpg
@dirrm %%DATADIR%%/pixmaps
@dirrm %%DATADIR%%
%%DOCSDIR%%/ru/index.html
%%DOCSDIR%%/en/index.html
%%DOCSDIR%%/tea_doc.css
%%DOCSDIR%%/AUTHORS
%%DOCSDIR%%/ChangeLog
%%DOCSDIR%%/NEWS
%%DOCSDIR%%/TODO
@dirrm %%DOCSDIR%%/ru
@dirrm %%DOCSDIR%%/en
@dirrm %%DOCSDIR%%