- Add LICENSE_FILE
- Simplify documentation installation - Disable precompiled headers to fix build with old gcc on -current kernel MFH: 2015Q2
This commit is contained in:
parent
63197463d0
commit
c3366746d2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=389217
@ -14,6 +14,7 @@ MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Interactive tool for creating random fractal planets and terrain
|
||||
|
||||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
|
||||
LIB_DEPENDS= libboost_program_options.so:${PORTSDIR}/devel/boost-libs
|
||||
@ -28,10 +29,9 @@ HAS_CONFIGURE= yes
|
||||
CONFIGURE_ENV= QTDIR="${QT_PREFIX}"
|
||||
CONFIGURE_ARGS= -spec ${QMAKESPEC}
|
||||
|
||||
PORTDOCS= *
|
||||
CXXFLAGS+= -include ${WRKSRC}/precompiled.h
|
||||
|
||||
DOCSRCDIR1= ${WRKSRC}
|
||||
DOC_FILES1= BUGS NEWS README THANKS ${PORTNAME}.css ${PORTNAME}.htm
|
||||
PORTDOCS= *
|
||||
|
||||
INSTALLS_ICONS= yes
|
||||
ICON_SIZES= 32x32 48x48 64x64 72x72 96x96
|
||||
@ -39,18 +39,11 @@ ICON_SIZES= 32x32 48x48 64x64 72x72 96x96
|
||||
DESKTOP_ENTRIES="Fracplanet" "" "${PORTNAME}" \
|
||||
"${PORTNAME}" "Graphics;" ""
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
OPTIONS_GROUP= DOXYGEN
|
||||
OPTIONS_GROUP_DOXYGEN= HTML LATEX
|
||||
OPTIONS_DEFINE= DOXYGEN DOCS
|
||||
|
||||
OPTIONS_DEFAULT= HTML
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
HTML_DESC= Install HTML Doxygen files
|
||||
LATEX_DESC= Install LaTeX Doxygen files
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${PORT_OPTIONS:MHTML} || ${PORT_OPTIONS:MLATEX}
|
||||
.if ${PORT_OPTIONS:MDOCS} && ${PORT_OPTIONS:MDOXYGEN}
|
||||
BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
|
||||
.endif
|
||||
|
||||
@ -65,6 +58,11 @@ post-patch:
|
||||
's|-lboost_program_options|-lboost_program_options -lGLU|' \
|
||||
${WRKSRC}/fracplanet.pro
|
||||
|
||||
.if ${PORT_OPTIONS:MDOCS} && ${PORT_OPTIONS:MDOXYGEN}
|
||||
post-build:
|
||||
cd ${WRKSRC} && doxygen .
|
||||
.endif
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
|
||||
${INSTALL_MAN} ${WRKSRC}/man/man1/${PORTNAME}.1 \
|
||||
@ -80,19 +78,11 @@ do-install:
|
||||
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${STAGEDIR}${DOCSDIR}
|
||||
cd ${WRKSRC} && ${INSTALL_DATA} BUGS NEWS README THANKS \
|
||||
fracplanet.css fracplanet.htm ${STAGEDIR}${DOCSDIR}
|
||||
. if ${PORT_OPTIONS:MDOXYGEN}
|
||||
@(cd ${WRKSRC} && ${COPYTREE_SHARE} "html latex" ${STAGEDIR}${DOCSDIR})
|
||||
. endif
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MHTML} || ${PORT_OPTIONS:MLATEX}
|
||||
@cd ${WRKSRC} && doxygen .
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MDOCS} && ${PORT_OPTIONS:MHTML}
|
||||
@(cd ${WRKSRC} && ${COPYTREE_SHARE} html ${STAGEDIR}${DOCSDIR})
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MDOCS} && ${PORT_OPTIONS:MLATEX}
|
||||
@(cd ${WRKSRC} && ${COPYTREE_SHARE} latex ${STAGEDIR}${DOCSDIR})
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.post.mk>
|
||||
|
11
graphics/fracplanet/files/patch-fracplanet.pro
Normal file
11
graphics/fracplanet/files/patch-fracplanet.pro
Normal file
@ -0,0 +1,11 @@
|
||||
--- fracplanet.pro.orig 2015-06-11 10:31:19 UTC
|
||||
+++ fracplanet.pro
|
||||
@@ -1,7 +1,7 @@
|
||||
TARGET = fracplanet
|
||||
TEMPLATE = app
|
||||
|
||||
-CONFIG+= qt stl precompile_header exceptions release # debug/release
|
||||
+CONFIG+= qt stl exceptions release # debug/release
|
||||
QT += opengl
|
||||
|
||||
PRECOMPILED_HEADER = precompiled.h
|
@ -1,5 +1,5 @@
|
||||
--- triangle_mesh_viewer_display.cpp.orig 2009-10-05 00:26:36.000000000 +0200
|
||||
+++ triangle_mesh_viewer_display.cpp 2013-10-03 00:25:53.000000000 +0200
|
||||
--- triangle_mesh_viewer_display.cpp.orig 2009-10-04 22:26:36 UTC
|
||||
+++ triangle_mesh_viewer_display.cpp
|
||||
@@ -24,6 +24,8 @@
|
||||
#include "matrix33.h"
|
||||
#include "triangle_mesh_viewer.h"
|
||||
|
Loading…
Reference in New Issue
Block a user