Rename nethack to nethack32 (w/ a repocopy) and define NO_LATEST_LINK, in

preparation for the forthcoming import of nethack34.
This commit is contained in:
Akinori MUSHA 2002-07-07 16:47:13 +00:00
parent 4c50297f63
commit c2d9f30449
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=62569
18 changed files with 3 additions and 567 deletions

View File

@ -259,7 +259,7 @@
SUBDIR += navi2ch-xemacs21-mule
SUBDIR += ndtpd
SUBDIR += ne
SUBDIR += nethack
SUBDIR += nethack32
SUBDIR += netscape-fonts
SUBDIR += netscape3.language
SUBDIR += netscape4-communicator

View File

@ -1,60 +0,0 @@
# New ports collection makefile for: nethack
# Date created: 13 February 1995
# Whom: asami
#
# $FreeBSD$
#
PORTNAME= nethack
PORTVERSION= 1.0.5.19970924
CATEGORIES= japanese games
MASTER_SITES= ftp://ftp.nethack.org/pub/nethack/nh322/src/ \
ftp://ftp.wtower.com/nethack/sources/
DISTNAME= ${PORTNAME}-3.2.2
PATCH_SITES= ftp://mitsuko.jaist.ac.jp/pub/nethack/
PATCHFILES= j${PORTNAME}-${PORTVERSION}.gz
MAINTAINER= max@FreeBSD.org
.include <bsd.port.pre.mk>
.if ${XFREE86_VERSION} == 4
BUILD_DEPENDS= bdftopcf:${PORTSDIR}/x11/XFree86-4-clients
RUN_DEPENDS= mkfontdir:${PORTSDIR}/x11/XFree86-4-clients
.endif
USE_XPM= yes
USE_GMAKE= yes
MAN6= dlb.6 dgn_comp.6 lev_comp.6 nethack.6 recover.6
pre-configure:
@cd ${WRKSRC}/sys/unix; ${SH} setup.sh
pre-install:
@cd ${WRKSRC}/doc; ${CHMOD} 644 *.6
@cd ${WRKSRC}/doc; ${MAKE} PREFIX=${PREFIX} manpages
post-install:
${INSTALL_DATA} ${WRKSRC}/win/X11/nh_icon.xpm ${PREFIX}/lib/jnethackdir
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/ja/nethack
${INSTALL_MAN} ${WRKSRC}/doc/jGuidebook.txt ${PREFIX}/share/doc/ja/nethack
${INSTALL_MAN} ${FILESDIR}/README ${PREFIX}/share/doc/ja/nethack
.for i in README.j ChangeLog.j INSTALL.j
${INSTALL_MAN} ${WRKSRC}/$i ${PREFIX}/share/doc/ja/nethack
.endfor
.endif
${MKDIR} ${PREFIX}/share/examples/ja/nethack
${INSTALL_DATA} ${WRKSRC}/win/X11/nethack.rc ${PREFIX}/share/examples/ja/nethack
${INSTALL_DATA} ${WRKSRC}/win/X11/JNetHack.ad ${PREFIX}/share/examples/ja/nethack
.for i in ibm nh10
${INSTALL_DATA} ${WRKSRC}/win/X11/$i.bdf ${PREFIX}/share/examples/ja/nethack
${X11BASE}/bin/bdftopcf ${PREFIX}/share/examples/ja/nethack/$i.bdf \
> ${PREFIX}/share/examples/ja/nethack/$i.pcf
${RM} ${PREFIX}/share/examples/ja/nethack/$i.bdf
${GZIP_CMD} ${PREFIX}/share/examples/ja/nethack/$i.pcf
.endfor
${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>

View File

@ -1,2 +0,0 @@
MD5 (nethack-3.2.2.tar.gz) = c85de4d14453b3a2d182d1dfc2ca04df
MD5 (jnethack-1.0.5.19970924.gz) = e4a89938096327f1ab40564559f74dd0

View File

@ -1,28 +0,0 @@
jnethack$B$N(BX$BHG$NM7$SJ}(B
$B2hLL$N9-$5$O!"(B1024 x 768$B0J>e$K$7$F$*$-$^$7$g$&!#(B
1. $B%j%=!<%9%U%!%$%k$r%3%T!<$7$^$9!#(B
% cd /usr/local/share/examples/ja/nethack
% xrdb -m JNetHack.ad
# cp JNetHack.ad /usr/X11R6/lib/X11/app-defaults/JNetHack
2. $B%U%)%s%H$r%3%T!<$7$^$9!#(B
# cp ibm.pcf.gz nh10.pcf.gz /usr/X11R6/lib/X11/fonts/misc
# mkfontdir /usr/X11R6/lib/X11/fonts/misc
3. ~/.Xresources$B$K@_Dj$rDI2C$7$^$9!#(B
xdm$B$r;H$C$F$$$k>l9g$O!"(B~/.Xdefaults$B$G$9!#(B
$B$3$N:n6H$r$9$k$H!"%?%$%kI=<($5$l$k$h$&$K$J$j$^$9!#(B
1280 x 1024$B0J>e$N9-$$2hLL$,$*4+$a$G$9!#(B
% echo "JNetHack.tile_file: x11tiles" >> ~/.Xresources
% xrdb -m ~/.Xresources
4. $B@_Dj40N;!"5/F0$7$^$9!#(B
% jnethack &
jnethack$B$K4X$9$k>pJs$O!"0J2<$N(BURL$B$r$4Mw2<$5$$!#(B
http://www.guru.gr.jp/~issei/jnethack/
- Seiichirou Hiraoka
flathill@FreeBSD.ORG

View File

@ -1,63 +0,0 @@
*** include/unixconf.h.orig Thu Aug 29 23:53:22 1996
--- include/unixconf.h Fri Aug 30 00:06:59 1996
***************
*** 31,37 ****
/* define any of the following that are appropriate */
/* #define SVR4 /* use in addition to SYSV for System V Release 4 */
! #define NETWORK /* if running on a networked system */
/* e.g. Suns sharing a playground through NFS */
#define SUNOS4 /* SunOS 4.x */
/* #define NEWSOS4 /* NEWS-OS 4.x */
--- 31,37 ----
/* define any of the following that are appropriate */
/* #define SVR4 /* use in addition to SYSV for System V Release 4 */
! /*#define NETWORK /* if running on a networked system */
/* e.g. Suns sharing a playground through NFS */
#define SUNOS4 /* SunOS 4.x */
/* #define NEWSOS4 /* NEWS-OS 4.x */
***************
*** 43,54 ****
/* #define AIX_31 /* In AIX 3.1 (IBM RS/6000) use BSD ioctl's to gain
* job control (note that AIX is SYSV otherwise)
* Also define this for AIX 3.2 */
! /* #define TEXTCOLOR /* Use System V r3.2 terminfo color support */
/* and/or ANSI color support on termcap systems */
/* and/or X11 color */
! /* #define POSIX_JOB_CONTROL /* use System V / POSIX job control
* (e.g., VSUSP) */
! /* #define POSIX_TYPES /* use POSIX types for system calls and termios */
/* define for many recent OS releases, including
* those with specific defines (since types are
* changing toward the standard from earlier chaos).
--- 43,54 ----
/* #define AIX_31 /* In AIX 3.1 (IBM RS/6000) use BSD ioctl's to gain
* job control (note that AIX is SYSV otherwise)
* Also define this for AIX 3.2 */
! #define TEXTCOLOR /* Use System V r3.2 terminfo color support */
/* and/or ANSI color support on termcap systems */
/* and/or X11 color */
! #define POSIX_JOB_CONTROL /* use System V / POSIX job control
* (e.g., VSUSP) */
! #define POSIX_TYPES /* use POSIX types for system calls and termios */
/* define for many recent OS releases, including
* those with specific defines (since types are
* changing toward the standard from earlier chaos).
***************
*** 126,132 ****
* A stat system call is done on the mailbox every MAILCKFREQ moves.
*/
! #define MAIL /* Deliver mail during the game */
/* The Andrew Message System does mail a little differently from normal
* UNIX. Mail is deposited in the user's own directory in ~/Mailbox
--- 126,132 ----
* A stat system call is done on the mailbox every MAILCKFREQ moves.
*/
! /* #define MAIL /* Deliver mail during the game */
/* The Andrew Message System does mail a little differently from normal
* UNIX. Mail is deposited in the user's own directory in ~/Mailbox

View File

@ -1,80 +0,0 @@
*** include/config.h.orig Thu Aug 29 23:53:20 1996
--- include/config.h Fri Aug 30 00:14:46 1996
***************
*** 210,216 ****
* Some combinations make no sense. See the installation document.
*/
#define TTY_GRAPHICS /* good old tty based graphics */
! /* #define X11_GRAPHICS /* X11 interface */
/*
** added by issei, Tue May 24 11:55:10 JST 1994
--- 210,216 ----
* Some combinations make no sense. See the installation document.
*/
#define TTY_GRAPHICS /* good old tty based graphics */
! #define X11_GRAPHICS /* X11 interface */
/*
** added by issei, Tue May 24 11:55:10 JST 1994
***************
*** 267,273 ****
* would allow:
* xpmtoppm <x11tiles.xpm | pnmscale 1.25 | ppmquant 90 >x11tiles_big.xpm
*/
! /* # define USE_XPM /* Disable if you do not have the XPM library */
# ifdef USE_XPM
# define GRAPHIC_TOMBSTONE /* Use graphical tombstone (rip.xpm) */
# endif
--- 267,273 ----
* would allow:
* xpmtoppm <x11tiles.xpm | pnmscale 1.25 | ppmquant 90 >x11tiles_big.xpm
*/
! # define USE_XPM /* Disable if you do not have the XPM library */
# ifdef USE_XPM
# define GRAPHIC_TOMBSTONE /* Use graphical tombstone (rip.xpm) */
# endif
***************
*** 307,318 ****
#ifdef UNIX
/* path and file name extension for compression program */
! # define COMPRESS "/usr/ucb/compress" /* Lempel-Ziv compression */
! # define COMPRESS_EXTENSION ".Z" /* compress's extension */
/* An example of one alternative you might want to use: */
! /* # define COMPRESS "/usr/local/bin/gzip" /* FSF gzip compression */
! /* # define COMPRESS_EXTENSION ".gz" /* normal gzip extension */
#endif
#ifndef COMPRESS
# define INTERNAL_COMP /* control use of NetHack's compression routines */
--- 307,318 ----
#ifdef UNIX
/* path and file name extension for compression program */
! /* # define COMPRESS "/usr/ucb/compress" /* Lempel-Ziv compression */
! /* # define COMPRESS_EXTENSION ".Z" /* compress's extension */
/* An example of one alternative you might want to use: */
! # define COMPRESS "/usr/bin/gzip" /* FSF gzip compression */
! # define COMPRESS_EXTENSION ".gz" /* normal gzip extension */
#endif
#ifndef COMPRESS
# define INTERNAL_COMP /* control use of NetHack's compression routines */
***************
*** 342,348 ****
* otherwise it will be the current directory.
*/
# ifndef HACKDIR
! # define HACKDIR "/usr/games/lib/jnethackdir" /* nethack directory */
# endif
/*
--- 342,348 ----
* otherwise it will be the current directory.
*/
# ifndef HACKDIR
! # define HACKDIR "/usr/local/lib/jnethackdir" /* nethack directory */
# endif
/*

View File

@ -1,19 +0,0 @@
*** sys/unix/Makefile.doc.orig Thu Apr 4 14:17:35 1996
--- sys/unix/Makefile.doc Fri Aug 30 00:16:46 1996
***************
*** 31,37 ****
GAME = nethack
! MANDIR = /usr/man/man6
MANEXT = 6
# manual installation for most BSD-style systems
--- 31,37 ----
GAME = nethack
! MANDIR = ${PREFIX}/man/man6
MANEXT = 6
# manual installation for most BSD-style systems

View File

@ -1,40 +0,0 @@
diff -ruN ./sys/unix/Makefile.top ../nethack-3.2.2/sys/unix/Makefile.top
--- ./sys/unix/Makefile.top Wed Dec 11 05:20:10 1996
+++ ../nethack-3.2.2/sys/unix/Makefile.top Sun Nov 22 00:26:55 1998
@@ -16,14 +16,14 @@
# make NetHack
GAME = nethack
GAMEUID = games
-GAMEGRP = bin
+GAMEGRP = games
# Permissions - some places use setgid instead of setuid, for instance
# See also the option "SECURE" in include/config.h
-GAMEPERM = 04755
-FILEPERM = 0644
+GAMEPERM = 02755
+FILEPERM = 0664
EXEPERM = 0755
-DIRPERM = 0755
+DIRPERM = 0775
# GAMEDIR also appears in config.h as "HACKDIR".
#
@@ -32,13 +32,13 @@
# therefore there should not be anything in GAMEDIR that you want to keep
# (if there is, you'll have to do the installation by hand or modify the
# instructions)
-GAMEDIR = /usr/games/lib/$(GAME)dir
-SHELLDIR = /usr/games
+GAMEDIR = ${PREFIX}/lib/$(GAME)dir
+SHELLDIR = ${PREFIX}/bin
# per discussion in Install.X11
-VARDATND =
+# VARDATND =
# VARDATND = x11tiles pet_mark.xbm
-# VARDATND = x11tiles pet_mark.xbm rip.xpm
+VARDATND = x11tiles pet_mark.xbm rip.xpm
VARDATD = data oracles options quest.dat rumors
VARDAT = $(VARDATD) $(VARDATND)

View File

@ -1,52 +0,0 @@
diff -ruN ./sys/unix/Makefile.src ../nethack-3.2.2/sys/unix/Makefile.src
--- ./sys/unix/Makefile.src Sun Nov 22 00:50:19 1998
+++ ../nethack-3.2.2/sys/unix/Makefile.src Sun Nov 22 00:52:12 1998
@@ -127,8 +127,8 @@
# flags for debugging:
# CFLAGS = -g -I../include
-CFLAGS = -g -I../include
-LFLAGS = -g
+CFLAGS += -O -I../include -I${X11BASE}/include
+LFLAGS = -L${X11BASE}/lib
# Set the WINSRC, WINOBJ, and WINLIB lines to correspond to your desired
@@ -149,8 +149,8 @@
winmisc.o winstat.o wintext.o winval.o tile.o
#
#
-WINSRC = $(WINTTYSRC)
-WINOBJ = $(WINTTYOBJ)
+WINSRC = $(WINTTYSRC) $(WINX11SRC)
+WINOBJ = $(WINTTYOBJ) $(WINX11OBJ)
# on some systems the termcap library is in -ltermcap or -lcurses
# on 386 Xenix, the -ltermlib tputs() seems not to work; use -lcurses instead
@@ -170,13 +170,14 @@
#
# libraries for X11
# If USE_XPM is defined in config.h, you will also need -lXpm here.
-WINX11LIB = -lXaw -lXmu -lXext -lXt -lX11
+# WINX11LIB = -lXaw -lXmu -lXext -lXt -lX11
# WINX11LIB = -lXaw -lXmu -lXt -lX11
# WINX11LIB = -lXaw -lXmu -lXext -lXt -lXpm -lX11 -lm
-# WINX11LIB = -lXaw -lXmu -lXpm -lXext -lXt -lX11 -lSM -lICE -lm # BSD/OS 2.0
+# BSD/OS 2.0 / FreeBSD 2.2/3.0
+WINX11LIB = -lXaw -lXmu -lXpm -lXext -lXt -lX11 -lSM -lICE -lm
#
#
-WINLIB = $(WINTTYLIB)
+WINLIB = $(WINTTYLIB) $(WINX11LIB)
# any other strange libraries your system needs (for Sysunix only -- the more
# specialized targets should already be right)
@@ -204,7 +205,7 @@
#
# LIBS = -lxpg4
#
-LIBS =
+LIBS = -lxpg4
# make NetHack
#JP by issei(96/5/27)

View File

@ -1,14 +0,0 @@
diff -ruN ./win/X11/JNetHack.ad ../nethack-3.2.2/win/X11/JNetHack.ad
--- ./win/X11/JNetHack.ad Sat Nov 21 01:38:14 1998
+++ ../nethack-3.2.2/win/X11/JNetHack.ad Sat Nov 21 01:40:00 1998
@@ -154,7 +154,7 @@
!
!
!
-JNetHack*fontSet: -*-fixed-medium-r-normal--14-*-iso8859-1,\
- -*-fixed-medium-r-normal--14-*-iso8859-1,\
- -*-fixed-medium-r-*--14-*-jisx0208.1983-*
+JNetHack*fontSet: -*-fixed-medium-r-normal--14-*-*-*-*-*-iso8859-1,\
+ -*-fixed-medium-r-normal--14-*-*-*-*-*-iso8859-1,\
+ -*-fixed-medium-r-*--14-*-*-*-*-*-jisx0208.1983-*
JNetHack*international: True

View File

@ -1,21 +0,0 @@
diff -ruN ./src/polyself.c ../nethack-3.2.2/src/polyself.c
--- ./src/polyself.c Sun Nov 22 01:10:08 1998
+++ ../nethack-3.2.2/src/polyself.c Sun Nov 22 01:12:25 1998
@@ -171,7 +171,7 @@
if (u.uhp <= 0) u.uhp = 1;
if (u.uhpmax <= 0) u.uhpmax = 1;
} else {
-/*JP Your("new form doesn't seem healthy enough to survive.");
+/*JP Your("new form doesn't seem healthy enough to survive.");*/
Your("新しい姿は生きてくだけの力がないようだ.");
killer_format = KILLED_BY_AN;
/*JP killer="unsuccessful polymorph";*/
@@ -181,7 +181,7 @@
}
/*JP polyman("feel like a new %s!",
Role_is('E') ? "elf" : flags.female ? "woman" : "man");*/
- if(saved_sex == flags.female)
+ if(u.umonnum != PM_PLAYERMON || saved_sex == flags.female)
polyman("別の%sとして生まれかわったような気がした",
pl_character[0] == 'E' ? "エルフ" : "人間");
else

View File

@ -1,13 +0,0 @@
--- sys/unix/Makefile.utl.orig Sun Feb 13 07:26:46 2000
+++ sys/unix/Makefile.utl Sun Feb 13 07:27:42 2000
@@ -86,8 +86,8 @@
# if, instead of yacc/lex you have bison/flex, comment/uncomment the following.
# YACC = yacc
# LEX = lex
-YACC = bison -y
-# YACC = byacc
+# YACC = bison -y
+YACC = byacc
LEX = flex -8
# these are the names of the output files from YACC/LEX. Under MS-DOS

View File

@ -1,11 +0,0 @@
--- include/system.h.orig Sun Mar 31 20:46:35 2002
+++ include/system.h Sun Mar 31 20:55:33 2002
@@ -507,7 +507,7 @@
# endif
# endif
-# if defined(ULTRIX) || defined(SYSV) || defined(MICRO) || defined(VMS) || defined(MAC)
+# if defined(ULTRIX) || defined(SYSV) || defined(MICRO) || defined(VMS) || defined(MAC) || defined(BSD)
E time_t FDECL(time, (time_t *));
# else
E long FDECL(time, (time_t *));

View File

@ -1 +0,0 @@
A dungeon explorin', slashin', hackin' game

View File

@ -1,15 +0,0 @@
This is the Japanese version 1.0.5.19970924 (original 3.2.2) of
nethack. You and your puppy (or kitten) will explore the deep
dungeons to retrieve the long-lost magical item that causes so much
trouble to anyone.
Take care, and try not to miss meals.
WWW: http://www.win.tue.nl/games/roguelike/nethack/
- Satoshi
asami@cs.berkeley.edu
P.S. There are newsgroups "rec.games.roguelike.nethack" and
"fj.rec.games.roguelike" if you are
truly interested.

View File

@ -1,6 +0,0 @@
--------
If you want to play jnethack on X, see
/usr/local/share/doc/ja/nethack/README
See also /usr/local/share/doc/ja/nethack/jGuideBook.txt
--------

View File

@ -1,141 +0,0 @@
bin/jnethack
lib/jnethackdir/jnethack
@exec mkdir %D/lib/jnethackdir/save
@exec chmod -R 775 %D/lib/jnethackdir
@exec chmod 2755 %D/lib/jnethackdir/jnethack
@exec chown games:games %D/lib/jnethackdir/save
@unexec rm -rf %D/lib/jnethackdir/save
lib/jnethackdir/A-filla.lev
lib/jnethackdir/A-fillb.lev
lib/jnethackdir/A-goal.lev
lib/jnethackdir/A-locate.lev
lib/jnethackdir/A-start.lev
lib/jnethackdir/B-filla.lev
lib/jnethackdir/B-fillb.lev
lib/jnethackdir/B-goal.lev
lib/jnethackdir/B-locate.lev
lib/jnethackdir/B-start.lev
lib/jnethackdir/C-filla.lev
lib/jnethackdir/C-fillb.lev
lib/jnethackdir/C-goal.lev
lib/jnethackdir/C-locate.lev
lib/jnethackdir/C-start.lev
lib/jnethackdir/E-filla.lev
lib/jnethackdir/E-fillb.lev
lib/jnethackdir/E-goal.lev
lib/jnethackdir/E-locate.lev
lib/jnethackdir/E-start.lev
lib/jnethackdir/F-filla.lev
lib/jnethackdir/F-fillb.lev
lib/jnethackdir/F-goal.lev
lib/jnethackdir/F-locate.lev
lib/jnethackdir/F-start.lev
lib/jnethackdir/H-filla.lev
lib/jnethackdir/H-fillb.lev
lib/jnethackdir/H-goal.lev
lib/jnethackdir/H-locate.lev
lib/jnethackdir/H-start.lev
lib/jnethackdir/K-filla.lev
lib/jnethackdir/K-fillb.lev
lib/jnethackdir/K-goal.lev
lib/jnethackdir/K-locate.lev
lib/jnethackdir/K-start.lev
lib/jnethackdir/P-filla.lev
lib/jnethackdir/P-fillb.lev
lib/jnethackdir/P-goal.lev
lib/jnethackdir/P-locate.lev
lib/jnethackdir/P-start.lev
lib/jnethackdir/R-filla.lev
lib/jnethackdir/R-fillb.lev
lib/jnethackdir/R-goal.lev
lib/jnethackdir/R-locate.lev
lib/jnethackdir/R-start.lev
lib/jnethackdir/S-filla.lev
lib/jnethackdir/S-fillb.lev
lib/jnethackdir/S-goal.lev
lib/jnethackdir/S-locate.lev
lib/jnethackdir/S-start.lev
lib/jnethackdir/T-filla.lev
lib/jnethackdir/T-fillb.lev
lib/jnethackdir/T-goal.lev
lib/jnethackdir/T-locate.lev
lib/jnethackdir/T-start.lev
lib/jnethackdir/V-filla.lev
lib/jnethackdir/V-fillb.lev
lib/jnethackdir/V-goal.lev
lib/jnethackdir/V-locate.lev
lib/jnethackdir/V-start.lev
lib/jnethackdir/W-filla.lev
lib/jnethackdir/W-fillb.lev
lib/jnethackdir/W-goal.lev
lib/jnethackdir/W-locate.lev
lib/jnethackdir/W-start.lev
lib/jnethackdir/air.lev
lib/jnethackdir/asmodeus.lev
lib/jnethackdir/astral.lev
lib/jnethackdir/baalz.lev
lib/jnethackdir/bigrm-1.lev
lib/jnethackdir/bigrm-2.lev
lib/jnethackdir/bigrm-3.lev
lib/jnethackdir/bigrm-4.lev
lib/jnethackdir/bigrm-5.lev
lib/jnethackdir/castle.lev
lib/jnethackdir/data
lib/jnethackdir/dungeon
lib/jnethackdir/earth.lev
lib/jnethackdir/fakewiz1.lev
lib/jnethackdir/fakewiz2.lev
lib/jnethackdir/fire.lev
lib/jnethackdir/history
lib/jnethackdir/jcmdhelp
lib/jnethackdir/jhelp
lib/jnethackdir/jhh
lib/jnethackdir/jjj
lib/jnethackdir/jopthelp
lib/jnethackdir/joracles
lib/jnethackdir/jrumors
lib/jnethackdir/juiblex.lev
lib/jnethackdir/jwizhelp
lib/jnethackdir/knox.lev
lib/jnethackdir/license
lib/jnethackdir/medusa-1.lev
lib/jnethackdir/medusa-2.lev
lib/jnethackdir/minefill.lev
lib/jnethackdir/minend-1.lev
lib/jnethackdir/minend-2.lev
lib/jnethackdir/minetn-1.lev
lib/jnethackdir/minetn-2.lev
lib/jnethackdir/nh_icon.xpm
lib/jnethackdir/options
lib/jnethackdir/oracle.lev
lib/jnethackdir/orcus.lev
lib/jnethackdir/pet_mark.xbm
lib/jnethackdir/quest.dat
lib/jnethackdir/rip.xpm
lib/jnethackdir/sanctum.lev
lib/jnethackdir/tower1.lev
lib/jnethackdir/tower2.lev
lib/jnethackdir/tower3.lev
lib/jnethackdir/valley.lev
lib/jnethackdir/water.lev
lib/jnethackdir/wizard1.lev
lib/jnethackdir/wizard2.lev
lib/jnethackdir/wizard3.lev
lib/jnethackdir/x11tiles
@mode 664
lib/jnethackdir/logfile
lib/jnethackdir/perm
lib/jnethackdir/record
@dirrm lib/jnethackdir
share/doc/ja/nethack/ChangeLog.j
share/doc/ja/nethack/INSTALL.j
share/doc/ja/nethack/README
share/doc/ja/nethack/README.j
share/doc/ja/nethack/jGuidebook.txt
share/examples/ja/nethack/JNetHack.ad
share/examples/ja/nethack/ibm.pcf.gz
share/examples/ja/nethack/nethack.rc
share/examples/ja/nethack/nh10.pcf.gz
@dirrm share/examples/ja/nethack
@unexec rmdir %D/share/examples/ja 2>/dev/null || true
@dirrm share/doc/ja/nethack

View File

@ -17,6 +17,8 @@ PATCHFILES= j${PORTNAME}-${PORTVERSION}.gz
MAINTAINER= max@FreeBSD.org
NO_LATEST_LINK= yes
.include <bsd.port.pre.mk>
.if ${XFREE86_VERSION} == 4