Add ruby-nis, a ruby library to use the NIS/YP API.

This commit is contained in:
Akinori MUSHA 2001-06-21 12:46:15 +00:00
parent ea8c1a55b7
commit c2d4f20484
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=44276
8 changed files with 75 additions and 0 deletions

View File

@ -316,6 +316,7 @@
SUBDIR += ruby-drb
SUBDIR += ruby-icmp
SUBDIR += ruby-ldap
SUBDIR += ruby-nis
SUBDIR += ruby-pcap
SUBDIR += ruby-snmp
SUBDIR += ruby-soap

36
net/ruby-nis/Makefile Normal file
View File

@ -0,0 +1,36 @@
# New ports collection makefile for: ruby-nis
# Date created: 21 June 2001
# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
#
# $FreeBSD$
#
PORTNAME= nis
PORTVERSION= 0.1.1
CATEGORIES= net ruby
MASTER_SITES= http://kt-www.jaist.ac.jp/~ttate/ftp/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
WRKSRC= ${WRKDIR}/ruby-${PORTNAME}
INSTALL_TARGET= site-install
DOCS_EN= README README.html
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
.for f in ${DOCS_EN}
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
.endfor
${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
${INSTALL_DATA} ${WRKSRC}/test/* ${RUBY_EXAMPLESDIR}/${PORTNAME}/
.endif
.include <bsd.port.mk>

1
net/ruby-nis/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (ruby/ruby-nis-0.1.1.tar.gz) = bd8d7ea8e7dd15867afc32a612e4a23b

View File

@ -0,0 +1,13 @@
--- extconf.rb.orig Fri Apr 20 14:38:57 2001
+++ extconf.rb Thu Jun 21 21:24:05 2001
@@ -6,8 +6,8 @@
nis_h = have_header('rpcsvc/nis.h')
ypclnt_h = have_header('rpcsvc/ypclnt.h')
ypprot_h = have_header('rpcsvc/yp_prot.h')
-libnsl = have_library('nsl')
+have_library('nsl')
-if( libnsl && ypclnt_h && ypprot_h )
+if( have_func("yp_all") && ypclnt_h && ypprot_h )
create_makefile('nis')
end

View File

@ -0,0 +1,10 @@
--- yp.c.orig Fri Apr 20 16:07:42 2001
+++ yp.c Thu Jun 21 21:30:30 2001
@@ -3,6 +3,7 @@
*/
#include "nis.h"
+#include <rpc/rpc.h>
#include <rpcsvc/ypclnt.h>
#include <rpcsvc/yp_prot.h>

1
net/ruby-nis/pkg-comment Normal file
View File

@ -0,0 +1 @@
A Ruby library to use the NIS/YP API

4
net/ruby-nis/pkg-descr Normal file
View File

@ -0,0 +1,4 @@
Ruby/NIS is a ruby library to use the NIS/YP API.
WWW: http://kt-www.jaist.ac.jp/~ttate/lang/ruby/ruby-nis.html
Author: Takaaki Tateishi <ttate@jaist.ac.jp>

9
net/ruby-nis/pkg-plist Normal file
View File

@ -0,0 +1,9 @@
%%RUBY_SITEARCHLIBDIR%%/nis.so
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/nis/yp_all.rb
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/nis/yp_all2.rb
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/nis/yp_first.rb
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/nis/yp_match.rb
%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/nis
%%PORTDOCS%%%%RUBY_DOCDIR%%/nis/README
%%PORTDOCS%%%%RUBY_DOCDIR%%/nis/README.html
%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/nis