- Fix build with clang

Feature safe:	yes
This commit is contained in:
Pietro Cerutti 2012-12-03 09:10:19 +00:00
parent 369f9eda57
commit c2972fcd0a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=308127
2 changed files with 22 additions and 0 deletions

View File

@ -0,0 +1,11 @@
--- factor/Makefile.mk.orig 2012-12-03 10:01:29.000000000 +0100
+++ factor/Makefile.mk 2012-12-03 10:01:48.000000000 +0100
@@ -22,7 +22,7 @@
$(CC) ___build$$$$.c -lm -o ___build$$$$ >/dev/null 2>&1 ; \
if test $$? = 0 && test -f ___build$$$$ ; \
then \
- echo '#if !defined (__dietlibc__) && !defined (_AIX)' >>config.h ; \
+ echo '#if !defined (__dietlibc__) && !defined (_AIX) && !defined (__FreeBSD__)' >>config.h ; \
echo '#define USE_LONG_DOUBLE' >>config.h ; \
echo '#endif' >>config.h ; \
fi ; \

View File

@ -0,0 +1,11 @@
--- nawk/main.c.orig 2012-12-03 10:03:30.000000000 +0100
+++ nawk/main.c 2012-12-03 10:03:51.000000000 +0100
@@ -66,7 +66,7 @@
extern const char badopen[];
-int main(int argc, unsigned char *argv[], unsigned char *envp[])
+int main(int argc, char *argv[], char *envp[])
{
unsigned char *fs = NULL;
char label[MAXLABEL+1]; /* Space for the catalogue label */