Fix build on 4.x.

PR:		84560
Submitted by:	Pawel Pekala <c0rn@gazeta.pl>
Approved by:	David <david@pinko.net> (maintainer)
This commit is contained in:
Roman Bogorodskiy 2005-08-28 21:15:04 +00:00
parent db3d72ecbf
commit c28e6a3940
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=141197
2 changed files with 22 additions and 8 deletions

View File

@ -7,7 +7,7 @@
PORTNAME= gkrelltop
PORTVERSION= 2.2.6
PORTREVISION= 3
PORTREVISION= 4
CATEGORIES= sysutils
MASTER_SITES= http://psychology.rutgers.edu/~zaimi/html/gkrelltop/
DISTNAME= ${PORTNAME}_2.2-6
@ -27,13 +27,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PLIST_FILES= libexec/gkrellm2/plugins/gkrelltop.so \
libexec/gkrellm2/plugins/gkrelltopd.so
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
BROKEN= "Does not compile on FreeBSD 4.x"
.endif
post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -0,0 +1,20 @@
--- gkrelltop.c.orig Thu Aug 4 21:08:58 2005
+++ gkrelltop.c Thu Aug 4 21:09:34 2005
@@ -324,7 +324,8 @@
TextStyle *ts, *ts_alt;
gint y;
gint i;
-
+ GkrellmPiximage *krell_image = NULL;
+
/* See comments about first create in demo2.c
*/
if (first_create)
@@ -335,7 +336,6 @@
ts = gkrellm_meter_textstyle(style_id); //smaller font e brighter col
ts_alt = gkrellm_meter_alt_textstyle(style_id); //smaller font e brighter col
- GkrellmPiximage *krell_image = NULL;
//krell_image = gkrellm_krell_meter_piximage(style_id);
gkrellm_load_piximage("krell_panel1", krell_panel1_xpm, &krell_image, STYLE_NAME);
/*