multimedia/libva{,-intel-driver}: convert to USES=meson

Meson is faster than autoreconf + libtool and easier to maintain.
Force rebuild to catch regressions early.
This commit is contained in:
Jan Beich 2019-01-17 23:56:33 +00:00
parent a653947346
commit c2828a7218
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=490613
3 changed files with 7 additions and 39 deletions

View File

@ -2,7 +2,7 @@
PORTNAME= libva-intel-driver
PORTVERSION= 2.3.0
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= multimedia
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
@ -21,24 +21,17 @@ BUILD_DEPENDS= libva>=2.3.0_3:multimedia/libva
LIB_DEPENDS= libdrm_intel.so:graphics/libdrm \
libva.so:multimedia/libva
USES= autoreconf compiler:c11 gmake libtool pkgconfig tar:bzip2
USES= compiler:c11 meson pkgconfig tar:bzip2
USE_GITHUB= yes
GH_ACCOUNT= intel
GH_PROJECT= intel-vaapi-driver
GNU_CONFIGURE= yes
PLIST_FILES= lib/dri/i915_drv_video.so lib/dri/i965_drv_video.so
OPTIONS_DEFINE= HYBRID
HYBRID_DESC= Hybrid VP8 encoding on Gen7/8 and VP9 decoding on Gen7/8/9
HYBRID_RUN_DEPENDS= ${LOCALBASE}/lib/dri/hybrid_drv_video.so:multimedia/libva-intel-hybrid-driver
HYBRID_CONFIGURE_ENABLE= hybrid-codec
post-patch: .SILENT
# XXX Remove va_api_version hack after 2.4.0 update
${REINPLACE_CMD} -e 's|driverdir|& --define-variable prefix=${PREFIX}|' \
-e '/va_api_version/s/1\.4\.0/1.1.0/' \
${WRKSRC}/configure.ac
HYBRID_MESON_TRUE= enable_hybrid_codec
post-install:
${LN} -sf i965_drv_video.so ${STAGEDIR}${PREFIX}/lib/dri/i915_drv_video.so

View File

@ -2,7 +2,7 @@
PORTNAME= libva
PORTVERSION= 2.3.0
PORTREVISION= 4
PORTREVISION= 5
CATEGORIES= multimedia
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
@ -17,13 +17,11 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libdrm.so:graphics/libdrm
USES= autoreconf gmake libtool pkgconfig tar:bzip2
USES= meson pkgconfig tar:bzip2
USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= intel
GNU_CONFIGURE= yes
LDFLAGS+= -lpthread # for pthread_getthreadid_np
INSTALL_TARGET= install-strip
OPTIONS_DEFINE= DEBUG WAYLAND X11
OPTIONS_DEFAULT=WAYLAND X11
@ -32,17 +30,14 @@ OPTIONS_SUB= yes
DEBUG_CFLAGS= -D_DEBUG
DEBUG_CFLAGS_OFF= -DNDEBUG
WAYLAND_CONFIGURE_ENABLE= wayland
WAYLAND_LIB_DEPENDS= libwayland-client.so:graphics/wayland
WAYLAND_MESON_YES= with_wayland
X11_CONFIGURE_ENABLE= x11 glx
X11_USES= gl
X11_USE= GL=gl XORG=x11,xorgproto,xext,xfixes
X11_MESON_YES= with_x11 with_glx
post-patch: .SILENT
${REINPLACE_CMD} -e 's|$${libdir}/\(pkgconfig\)|${PREFIX}/libdata/\1|' \
-e 's/"$$USE_X11:$$enable_glx" != "yes:no"/"$$USE_X11" != "no"/' \
${WRKSRC}/configure.ac
# V4L2 is unused since http://github.com/intel/libva/commit/70074679333c
${REINPLACE_CMD} '/videodev2\.h/d' ${WRKSRC}/va/va_backend.h

View File

@ -1,20 +0,0 @@
BSD sed doesn't support inlining argument for i command, so embed
newlines via C-style quoting as proposed for POSIX[1].
$ echo '/* comment */' | sed -e '1i#include "sysdeps.h"'
sed: 1: "1i#include "sysdeps.h"
": command i expects \ followed by text
[1] http://austingroupbugs.net/view.php?id=249
--- va/wayland/Makefile.am.orig 2018-10-01 23:31:25 UTC
+++ va/wayland/Makefile.am
@@ -70,7 +70,7 @@ va_wayland_drm.c: $(protocol_source_h)
%-client-protocol-export.c : %.xml
$(AM_V_GEN)$(WAYLAND_SCANNER) code < $< > $@
%-client-protocol.c: %-client-protocol-export.c
- $(AM_V_GEN)$(SED) -e '1i#include "sysdeps.h"' \
+ $(AM_V_GEN)$(SED) -e $$'1i\\\n#include "sysdeps.h"\n' \
-e 's@WL_EXPORT@DLL_HIDDEN@g' < $< > $@
EXTRA_DIST = \