Use the linux JDK for the build, which hopefully fixes the

build on bento. Add required patches to support this change.
If WITH_BSD_JDK is set, the original native JDK is used.

Add RES_GER to the supported languages. Apparently this is
now needed by the build system, else the handbook is still
missing.
This commit is contained in:
Martin Blapp 2003-01-25 19:55:09 +00:00
parent 91751ff632
commit c2653e1a14
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=73990
12 changed files with 330 additions and 24 deletions

View File

@ -119,6 +119,9 @@ BUILD_DEPENDS+= ${X11BASE}/lib/libX11.so:${PORTSDIR}/x11/XFree86-4-libraries
.if !defined(DISPLAY)
BUILD_DEPENDS+= Xvfb:${PORTSDIR}/x11-servers/XFree86-4-VirtualFramebufferServer
.endif
.if !defined(WITH_BSD_JDK)
USE_LINUX= yes
.endif
USE_PERL5= yes
USE_BZIP2= yes
@ -130,7 +133,11 @@ EXTRACT_AFTER_ARGS_R= | ${TAR} -xf -
EXTRACT_CMD_R= ${GZIP_CMD}
EXTRACT_REST= gpc231.tar.Z
.if !defined(WITH_BSD_JDK)
JDK13DIR?= ${LOCALBASE}/linux-jdk1.3.1
.else
JDK13DIR?= ${LOCALBASE}/jdk1.3.1
.endif
JAVAVM= ${JDK13DIR}/bin/java
GNU_CONFIGURE= yes
@ -159,12 +166,16 @@ CONFIGURE_ENV= PTHREAD_CFLAGS=${PTHREAD_CFLAGS} \
CONFIGURE_ARGS+= --with-jdk-home=${JDK13DIR} \
--with-os-version=${OSVERSION} \
--with-ant-home=${LOCALBASE}/
--with-ant-home=${LOCALBASE}
#.if !defined(USE_GCC)
#CONFIGURE_ARGS+= --with-stlport4-home=${PREFIX}
#.endif
.if !defined(WITH_BSD_JDK)
CONFIGURE_ARGS+= --enable-linuxjdk=yes
.endif
.if defined(WITH_DEBUG)
.if ${WITH_DEBUG} == 2
CONFIGURE_ARGS+= --enable-debug
@ -213,6 +224,14 @@ pre-fetch:
@${ECHO} "to compile openoffice with your"
@${ECHO} "prefered compiler."
.endif
.if !defined(WITH_BSD_JDK)
@${ECHO}
@${ECHO} "If you like to use the native BSD"
@${ECHO} "JDK for the build system, you can use"
@${ECHO} "WITH_BSD_JDK=TRUE to disable the"
@${ECHO} "usage of the linux-JDK and linux dependency."
@${ECHO}
.endif
.if !defined(WITH_DEBUG)
@${ECHO}
@${ECHO} "You can compile OO with debug symbols"

View File

@ -52,7 +52,7 @@
+ linux*) JINCSUBDIRS="linux genunix";;
++ irix*) JINCSUBDIRS="irix";;
++ netbsd*) JINCSUBDIRS="netbsd linux solaris genunix";;
++ freebsd*) JINCSUBDIRS="freebsd genunix";;
++ freebsd*) JINCSUBDIRS="freebsd linux solaris genunix";;
+ *) JINCSUBDIRS="genunix";;
+ esac
+

View File

@ -1,6 +1,19 @@
--- configure.in.orig Thu Jan 16 13:42:46 2003
+++ configure.in Tue Jan 21 23:09:35 2003
@@ -352,10 +352,7 @@
+++ configure.in Sat Jan 25 18:24:08 2003
@@ -89,6 +89,12 @@
Usage: --enable-check-only=yes
],,)
+AC_ARG_ENABLE(linuxjdk,
+[ --enable-linuxjdk Use this option option if you like to use
+ the linux-jdk instead of the native jdk.
+
+ Usage: --enable-linuxjdk
+],,)
AC_ARG_ENABLE(macos9,
[ --enable-macos9 Use this option option if you want to generate a
macos9 environment on macosx.
@@ -352,10 +358,7 @@
if test "$COMPATH" != "NO_GCC"; then
AC_MSG_RESULT([checked (gcc $_gcc_version)])
fi
@ -12,7 +25,7 @@
dnl ===================================================================
dnl Search all the common names for GNU make
@@ -553,14 +550,27 @@
@@ -553,14 +556,27 @@
fi
dnl ===================================================================
@ -20,8 +33,7 @@
+dnl Set the gcc/gxx include directories
dnl ===================================================================
+if test "$_os" = "FreeBSD" && test "$CC" != "cc"; then
if test "$GXX" = "yes"; then
- _gxx_include_path=`echo "#include <cstring>" | $CXX -E -xc++ - | $SED -n '/.*1*"\(.*\)\/cstring".*/s//\1/p' | head -1`
+if test "$GXX" = "yes"; then
+ if test -n "$enable_gcc3"; then
+ _gccincname1="g++-v3"
+ else
@ -31,7 +43,8 @@
+ _gxx_include_path="$_gcc_include_path/$_gccincname1"
+fi
+else
+if test "$GXX" = "yes"; then
if test "$GXX" = "yes"; then
- _gxx_include_path=`echo "#include <cstring>" | $CXX -E -xc++ - | $SED -n '/.*1*"\(.*\)\/cstring".*/s//\1/p' | head -1`
+ _gcc_include_path=`$CC -print-search-dirs | grep instal |$AWK '{ print \$2 }'`/include
+ _gxx_include_path=`echo "#include <cstring>" | $CXX -E -xc++ - \
+ | $SED -n '/.*1*"\(.*\)\/cstring".*/s//\1/p' | head -1`
@ -44,3 +57,29 @@
dnl ===================================================================
dnl Extra checking for the SUN OS compiler
@@ -1222,12 +1238,16 @@
else
with_lang=","$with_lang","
fi
-
if test -n "$enable_debug"; then
ENABLE_DEBUG="TRUE"
else
ENABLE_DEBUG="FALSE"
fi
+if test -n "$enable_linuxjdk"; then
+ USE_LINUXJDK="TRUE"
+else
+ USE_LINUXJDK="FALSE"
+fi
dnl ===================================================================
dnl Bits to substitute into set_soenv.in
@@ -1272,6 +1292,7 @@
AC_SUBST(PTHREAD_CFLAGS)
AC_SUBST(PTHREAD_LIBS)
AC_SUBST(ENABLE_DEBUG)
+AC_SUBST(USE_LINUXJDK)
AC_OUTPUT([set_soenv])

View File

@ -0,0 +1,44 @@
--- set_soenv.in.orig Thu Jan 9 14:41:31 2003
+++ set_soenv.in Sat Jan 25 18:27:08 2003
@@ -52,8 +52,8 @@
#-------------------------------------------------
#
# Platform independent constant values.
-my @LANGUAGES = ("ARAB", "CHINSIM", "CHINTRAD", "DAN", "DTCH", "ENUS", "FREN", "GREEK", "ITAL",
-"JAPN", "KOREAN", "POL", "PORT", "RUSS", "SPAN", "SWED", "TURK" );
+my @LANGUAGES = ("ARAB", "CHINSIM", "CHINTRAD", "DAN", "DTCH", "ENUS", "FREN", "GREEK", "GER",
+"ITAL", "JAPN", "KOREAN", "POL", "PORT", "RUSS", "SPAN", "SWED", "TURK" );
my ( $CALL_CDECL, $COMMON_OUTDIR, $NO_SRS_PATCH, $PRODUCT, $PROFULLSWITCH, $BIG_GOODIES, $BMP_WRITES_FLAG,
$common_build, $MK_UNROLL, $NO_REC_RES, $PROEXT, $SO3, $SOLAR_JAVA,
$SOLAR_PLUGIN, $TF_PACKAGES, $TF_SDBAPI, $TF_FILEURL, $UPDATER, $BUILD_DELIVER, $USE_NEWCHARSET, $USE_NEW_RSC, $VCL,
@@ -88,7 +88,7 @@
$SOLARINC, $LOCALINI, $MAC_LIB, $PATHEXTRA, $FRAMEWORKSHOME, $COMEX, $MULTITHREAD_OBJ, $PERL,
$COMP_ENV, $IENV, $ILIB, $WIN_INCLUDE, $JAVAHOME, $WIN_LIB, $WIN_HOME, $PSDK_HOME,
$BISON_HAIRY, $BISON_SIMPLE, $TEMP, $COMMON_BUILD_TOOLS, $WIN_GREP, $WIN_FIND, $WIN_LS,
- $WIN_GNUCOPY, $WIN_TOUCH, $STLPORT4, $USE_GCC3, $ENABLE_DEBUG );
+ $WIN_GNUCOPY, $WIN_TOUCH, $STLPORT4, $USE_GCC3, $ENABLE_DEBUG, $USE_LINUXJDK);
#
#-------------------------------------------
# IId. Declaring the aliases.
@@ -141,6 +141,7 @@
$CXX = '@CXX@'; # C++ compiler
$EXCEPTIONS = '@EXCEPTIONS@'; # Exception handling type
$ENABLE_DEBUG = '@ENABLE_DEBUG@'; # Enable a debug build
+$USE_LINUXJDK = '@USE_LINUXJDK@'; # Enable a debug build
$WRAPCMD = ""; # Wrapper (only for winnt)
#
@@ -1265,7 +1266,12 @@
{ $SOLARINC .=$I.'$JAVA_HOME'.$INCLUDE.$ds."linux";
}
elsif ($platform eq "$FreeBSD")
-{ $SOLARINC .=$I.'$JAVA_HOME'.$INCLUDE.$ds."freebsd";
+{
+ if ($USE_LINUXJDK eq "TRUE") {
+ $SOLARINC .=$I.'$JAVA_HOME'.$INCLUDE.$ds."linux";
+ } else {
+ $SOLARINC .=$I.'$JAVA_HOME'.$INCLUDE.$ds."freebsd";
+ }
}
elsif ($platform eq "$NetBSD")
{ $SOLARINC .=$I.'$JAVA_HOME'.$INCLUDE.$ds."netbsd";

View File

@ -119,6 +119,9 @@ BUILD_DEPENDS+= ${X11BASE}/lib/libX11.so:${PORTSDIR}/x11/XFree86-4-libraries
.if !defined(DISPLAY)
BUILD_DEPENDS+= Xvfb:${PORTSDIR}/x11-servers/XFree86-4-VirtualFramebufferServer
.endif
.if !defined(WITH_BSD_JDK)
USE_LINUX= yes
.endif
USE_PERL5= yes
USE_BZIP2= yes
@ -130,7 +133,11 @@ EXTRACT_AFTER_ARGS_R= | ${TAR} -xf -
EXTRACT_CMD_R= ${GZIP_CMD}
EXTRACT_REST= gpc231.tar.Z
.if !defined(WITH_BSD_JDK)
JDK13DIR?= ${LOCALBASE}/linux-jdk1.3.1
.else
JDK13DIR?= ${LOCALBASE}/jdk1.3.1
.endif
JAVAVM= ${JDK13DIR}/bin/java
GNU_CONFIGURE= yes
@ -159,12 +166,16 @@ CONFIGURE_ENV= PTHREAD_CFLAGS=${PTHREAD_CFLAGS} \
CONFIGURE_ARGS+= --with-jdk-home=${JDK13DIR} \
--with-os-version=${OSVERSION} \
--with-ant-home=${LOCALBASE}/
--with-ant-home=${LOCALBASE}
#.if !defined(USE_GCC)
#CONFIGURE_ARGS+= --with-stlport4-home=${PREFIX}
#.endif
.if !defined(WITH_BSD_JDK)
CONFIGURE_ARGS+= --enable-linuxjdk=yes
.endif
.if defined(WITH_DEBUG)
.if ${WITH_DEBUG} == 2
CONFIGURE_ARGS+= --enable-debug
@ -213,6 +224,14 @@ pre-fetch:
@${ECHO} "to compile openoffice with your"
@${ECHO} "prefered compiler."
.endif
.if !defined(WITH_BSD_JDK)
@${ECHO}
@${ECHO} "If you like to use the native BSD"
@${ECHO} "JDK for the build system, you can use"
@${ECHO} "WITH_BSD_JDK=TRUE to disable the"
@${ECHO} "usage of the linux-JDK and linux dependency."
@${ECHO}
.endif
.if !defined(WITH_DEBUG)
@${ECHO}
@${ECHO} "You can compile OO with debug symbols"

View File

@ -52,7 +52,7 @@
+ linux*) JINCSUBDIRS="linux genunix";;
++ irix*) JINCSUBDIRS="irix";;
++ netbsd*) JINCSUBDIRS="netbsd linux solaris genunix";;
++ freebsd*) JINCSUBDIRS="freebsd genunix";;
++ freebsd*) JINCSUBDIRS="freebsd linux solaris genunix";;
+ *) JINCSUBDIRS="genunix";;
+ esac
+

View File

@ -1,6 +1,19 @@
--- configure.in.orig Thu Jan 16 13:42:46 2003
+++ configure.in Tue Jan 21 23:09:35 2003
@@ -352,10 +352,7 @@
+++ configure.in Sat Jan 25 18:24:08 2003
@@ -89,6 +89,12 @@
Usage: --enable-check-only=yes
],,)
+AC_ARG_ENABLE(linuxjdk,
+[ --enable-linuxjdk Use this option option if you like to use
+ the linux-jdk instead of the native jdk.
+
+ Usage: --enable-linuxjdk
+],,)
AC_ARG_ENABLE(macos9,
[ --enable-macos9 Use this option option if you want to generate a
macos9 environment on macosx.
@@ -352,10 +358,7 @@
if test "$COMPATH" != "NO_GCC"; then
AC_MSG_RESULT([checked (gcc $_gcc_version)])
fi
@ -12,7 +25,7 @@
dnl ===================================================================
dnl Search all the common names for GNU make
@@ -553,14 +550,27 @@
@@ -553,14 +556,27 @@
fi
dnl ===================================================================
@ -20,8 +33,7 @@
+dnl Set the gcc/gxx include directories
dnl ===================================================================
+if test "$_os" = "FreeBSD" && test "$CC" != "cc"; then
if test "$GXX" = "yes"; then
- _gxx_include_path=`echo "#include <cstring>" | $CXX -E -xc++ - | $SED -n '/.*1*"\(.*\)\/cstring".*/s//\1/p' | head -1`
+if test "$GXX" = "yes"; then
+ if test -n "$enable_gcc3"; then
+ _gccincname1="g++-v3"
+ else
@ -31,7 +43,8 @@
+ _gxx_include_path="$_gcc_include_path/$_gccincname1"
+fi
+else
+if test "$GXX" = "yes"; then
if test "$GXX" = "yes"; then
- _gxx_include_path=`echo "#include <cstring>" | $CXX -E -xc++ - | $SED -n '/.*1*"\(.*\)\/cstring".*/s//\1/p' | head -1`
+ _gcc_include_path=`$CC -print-search-dirs | grep instal |$AWK '{ print \$2 }'`/include
+ _gxx_include_path=`echo "#include <cstring>" | $CXX -E -xc++ - \
+ | $SED -n '/.*1*"\(.*\)\/cstring".*/s//\1/p' | head -1`
@ -44,3 +57,29 @@
dnl ===================================================================
dnl Extra checking for the SUN OS compiler
@@ -1222,12 +1238,16 @@
else
with_lang=","$with_lang","
fi
-
if test -n "$enable_debug"; then
ENABLE_DEBUG="TRUE"
else
ENABLE_DEBUG="FALSE"
fi
+if test -n "$enable_linuxjdk"; then
+ USE_LINUXJDK="TRUE"
+else
+ USE_LINUXJDK="FALSE"
+fi
dnl ===================================================================
dnl Bits to substitute into set_soenv.in
@@ -1272,6 +1292,7 @@
AC_SUBST(PTHREAD_CFLAGS)
AC_SUBST(PTHREAD_LIBS)
AC_SUBST(ENABLE_DEBUG)
+AC_SUBST(USE_LINUXJDK)
AC_OUTPUT([set_soenv])

View File

@ -0,0 +1,44 @@
--- set_soenv.in.orig Thu Jan 9 14:41:31 2003
+++ set_soenv.in Sat Jan 25 18:27:08 2003
@@ -52,8 +52,8 @@
#-------------------------------------------------
#
# Platform independent constant values.
-my @LANGUAGES = ("ARAB", "CHINSIM", "CHINTRAD", "DAN", "DTCH", "ENUS", "FREN", "GREEK", "ITAL",
-"JAPN", "KOREAN", "POL", "PORT", "RUSS", "SPAN", "SWED", "TURK" );
+my @LANGUAGES = ("ARAB", "CHINSIM", "CHINTRAD", "DAN", "DTCH", "ENUS", "FREN", "GREEK", "GER",
+"ITAL", "JAPN", "KOREAN", "POL", "PORT", "RUSS", "SPAN", "SWED", "TURK" );
my ( $CALL_CDECL, $COMMON_OUTDIR, $NO_SRS_PATCH, $PRODUCT, $PROFULLSWITCH, $BIG_GOODIES, $BMP_WRITES_FLAG,
$common_build, $MK_UNROLL, $NO_REC_RES, $PROEXT, $SO3, $SOLAR_JAVA,
$SOLAR_PLUGIN, $TF_PACKAGES, $TF_SDBAPI, $TF_FILEURL, $UPDATER, $BUILD_DELIVER, $USE_NEWCHARSET, $USE_NEW_RSC, $VCL,
@@ -88,7 +88,7 @@
$SOLARINC, $LOCALINI, $MAC_LIB, $PATHEXTRA, $FRAMEWORKSHOME, $COMEX, $MULTITHREAD_OBJ, $PERL,
$COMP_ENV, $IENV, $ILIB, $WIN_INCLUDE, $JAVAHOME, $WIN_LIB, $WIN_HOME, $PSDK_HOME,
$BISON_HAIRY, $BISON_SIMPLE, $TEMP, $COMMON_BUILD_TOOLS, $WIN_GREP, $WIN_FIND, $WIN_LS,
- $WIN_GNUCOPY, $WIN_TOUCH, $STLPORT4, $USE_GCC3, $ENABLE_DEBUG );
+ $WIN_GNUCOPY, $WIN_TOUCH, $STLPORT4, $USE_GCC3, $ENABLE_DEBUG, $USE_LINUXJDK);
#
#-------------------------------------------
# IId. Declaring the aliases.
@@ -141,6 +141,7 @@
$CXX = '@CXX@'; # C++ compiler
$EXCEPTIONS = '@EXCEPTIONS@'; # Exception handling type
$ENABLE_DEBUG = '@ENABLE_DEBUG@'; # Enable a debug build
+$USE_LINUXJDK = '@USE_LINUXJDK@'; # Enable a debug build
$WRAPCMD = ""; # Wrapper (only for winnt)
#
@@ -1265,7 +1266,12 @@
{ $SOLARINC .=$I.'$JAVA_HOME'.$INCLUDE.$ds."linux";
}
elsif ($platform eq "$FreeBSD")
-{ $SOLARINC .=$I.'$JAVA_HOME'.$INCLUDE.$ds."freebsd";
+{
+ if ($USE_LINUXJDK eq "TRUE") {
+ $SOLARINC .=$I.'$JAVA_HOME'.$INCLUDE.$ds."linux";
+ } else {
+ $SOLARINC .=$I.'$JAVA_HOME'.$INCLUDE.$ds."freebsd";
+ }
}
elsif ($platform eq "$NetBSD")
{ $SOLARINC .=$I.'$JAVA_HOME'.$INCLUDE.$ds."netbsd";

View File

@ -119,6 +119,9 @@ BUILD_DEPENDS+= ${X11BASE}/lib/libX11.so:${PORTSDIR}/x11/XFree86-4-libraries
.if !defined(DISPLAY)
BUILD_DEPENDS+= Xvfb:${PORTSDIR}/x11-servers/XFree86-4-VirtualFramebufferServer
.endif
.if !defined(WITH_BSD_JDK)
USE_LINUX= yes
.endif
USE_PERL5= yes
USE_BZIP2= yes
@ -130,7 +133,11 @@ EXTRACT_AFTER_ARGS_R= | ${TAR} -xf -
EXTRACT_CMD_R= ${GZIP_CMD}
EXTRACT_REST= gpc231.tar.Z
.if !defined(WITH_BSD_JDK)
JDK13DIR?= ${LOCALBASE}/linux-jdk1.3.1
.else
JDK13DIR?= ${LOCALBASE}/jdk1.3.1
.endif
JAVAVM= ${JDK13DIR}/bin/java
GNU_CONFIGURE= yes
@ -159,12 +166,16 @@ CONFIGURE_ENV= PTHREAD_CFLAGS=${PTHREAD_CFLAGS} \
CONFIGURE_ARGS+= --with-jdk-home=${JDK13DIR} \
--with-os-version=${OSVERSION} \
--with-ant-home=${LOCALBASE}/
--with-ant-home=${LOCALBASE}
#.if !defined(USE_GCC)
#CONFIGURE_ARGS+= --with-stlport4-home=${PREFIX}
#.endif
.if !defined(WITH_BSD_JDK)
CONFIGURE_ARGS+= --enable-linuxjdk=yes
.endif
.if defined(WITH_DEBUG)
.if ${WITH_DEBUG} == 2
CONFIGURE_ARGS+= --enable-debug
@ -213,6 +224,14 @@ pre-fetch:
@${ECHO} "to compile openoffice with your"
@${ECHO} "prefered compiler."
.endif
.if !defined(WITH_BSD_JDK)
@${ECHO}
@${ECHO} "If you like to use the native BSD"
@${ECHO} "JDK for the build system, you can use"
@${ECHO} "WITH_BSD_JDK=TRUE to disable the"
@${ECHO} "usage of the linux-JDK and linux dependency."
@${ECHO}
.endif
.if !defined(WITH_DEBUG)
@${ECHO}
@${ECHO} "You can compile OO with debug symbols"

View File

@ -52,7 +52,7 @@
+ linux*) JINCSUBDIRS="linux genunix";;
++ irix*) JINCSUBDIRS="irix";;
++ netbsd*) JINCSUBDIRS="netbsd linux solaris genunix";;
++ freebsd*) JINCSUBDIRS="freebsd genunix";;
++ freebsd*) JINCSUBDIRS="freebsd linux solaris genunix";;
+ *) JINCSUBDIRS="genunix";;
+ esac
+

View File

@ -1,6 +1,19 @@
--- configure.in.orig Thu Jan 16 13:42:46 2003
+++ configure.in Tue Jan 21 23:09:35 2003
@@ -352,10 +352,7 @@
+++ configure.in Sat Jan 25 18:24:08 2003
@@ -89,6 +89,12 @@
Usage: --enable-check-only=yes
],,)
+AC_ARG_ENABLE(linuxjdk,
+[ --enable-linuxjdk Use this option option if you like to use
+ the linux-jdk instead of the native jdk.
+
+ Usage: --enable-linuxjdk
+],,)
AC_ARG_ENABLE(macos9,
[ --enable-macos9 Use this option option if you want to generate a
macos9 environment on macosx.
@@ -352,10 +358,7 @@
if test "$COMPATH" != "NO_GCC"; then
AC_MSG_RESULT([checked (gcc $_gcc_version)])
fi
@ -12,7 +25,7 @@
dnl ===================================================================
dnl Search all the common names for GNU make
@@ -553,14 +550,27 @@
@@ -553,14 +556,27 @@
fi
dnl ===================================================================
@ -20,8 +33,7 @@
+dnl Set the gcc/gxx include directories
dnl ===================================================================
+if test "$_os" = "FreeBSD" && test "$CC" != "cc"; then
if test "$GXX" = "yes"; then
- _gxx_include_path=`echo "#include <cstring>" | $CXX -E -xc++ - | $SED -n '/.*1*"\(.*\)\/cstring".*/s//\1/p' | head -1`
+if test "$GXX" = "yes"; then
+ if test -n "$enable_gcc3"; then
+ _gccincname1="g++-v3"
+ else
@ -31,7 +43,8 @@
+ _gxx_include_path="$_gcc_include_path/$_gccincname1"
+fi
+else
+if test "$GXX" = "yes"; then
if test "$GXX" = "yes"; then
- _gxx_include_path=`echo "#include <cstring>" | $CXX -E -xc++ - | $SED -n '/.*1*"\(.*\)\/cstring".*/s//\1/p' | head -1`
+ _gcc_include_path=`$CC -print-search-dirs | grep instal |$AWK '{ print \$2 }'`/include
+ _gxx_include_path=`echo "#include <cstring>" | $CXX -E -xc++ - \
+ | $SED -n '/.*1*"\(.*\)\/cstring".*/s//\1/p' | head -1`
@ -44,3 +57,29 @@
dnl ===================================================================
dnl Extra checking for the SUN OS compiler
@@ -1222,12 +1238,16 @@
else
with_lang=","$with_lang","
fi
-
if test -n "$enable_debug"; then
ENABLE_DEBUG="TRUE"
else
ENABLE_DEBUG="FALSE"
fi
+if test -n "$enable_linuxjdk"; then
+ USE_LINUXJDK="TRUE"
+else
+ USE_LINUXJDK="FALSE"
+fi
dnl ===================================================================
dnl Bits to substitute into set_soenv.in
@@ -1272,6 +1292,7 @@
AC_SUBST(PTHREAD_CFLAGS)
AC_SUBST(PTHREAD_LIBS)
AC_SUBST(ENABLE_DEBUG)
+AC_SUBST(USE_LINUXJDK)
AC_OUTPUT([set_soenv])

View File

@ -0,0 +1,44 @@
--- set_soenv.in.orig Thu Jan 9 14:41:31 2003
+++ set_soenv.in Sat Jan 25 18:27:08 2003
@@ -52,8 +52,8 @@
#-------------------------------------------------
#
# Platform independent constant values.
-my @LANGUAGES = ("ARAB", "CHINSIM", "CHINTRAD", "DAN", "DTCH", "ENUS", "FREN", "GREEK", "ITAL",
-"JAPN", "KOREAN", "POL", "PORT", "RUSS", "SPAN", "SWED", "TURK" );
+my @LANGUAGES = ("ARAB", "CHINSIM", "CHINTRAD", "DAN", "DTCH", "ENUS", "FREN", "GREEK", "GER",
+"ITAL", "JAPN", "KOREAN", "POL", "PORT", "RUSS", "SPAN", "SWED", "TURK" );
my ( $CALL_CDECL, $COMMON_OUTDIR, $NO_SRS_PATCH, $PRODUCT, $PROFULLSWITCH, $BIG_GOODIES, $BMP_WRITES_FLAG,
$common_build, $MK_UNROLL, $NO_REC_RES, $PROEXT, $SO3, $SOLAR_JAVA,
$SOLAR_PLUGIN, $TF_PACKAGES, $TF_SDBAPI, $TF_FILEURL, $UPDATER, $BUILD_DELIVER, $USE_NEWCHARSET, $USE_NEW_RSC, $VCL,
@@ -88,7 +88,7 @@
$SOLARINC, $LOCALINI, $MAC_LIB, $PATHEXTRA, $FRAMEWORKSHOME, $COMEX, $MULTITHREAD_OBJ, $PERL,
$COMP_ENV, $IENV, $ILIB, $WIN_INCLUDE, $JAVAHOME, $WIN_LIB, $WIN_HOME, $PSDK_HOME,
$BISON_HAIRY, $BISON_SIMPLE, $TEMP, $COMMON_BUILD_TOOLS, $WIN_GREP, $WIN_FIND, $WIN_LS,
- $WIN_GNUCOPY, $WIN_TOUCH, $STLPORT4, $USE_GCC3, $ENABLE_DEBUG );
+ $WIN_GNUCOPY, $WIN_TOUCH, $STLPORT4, $USE_GCC3, $ENABLE_DEBUG, $USE_LINUXJDK);
#
#-------------------------------------------
# IId. Declaring the aliases.
@@ -141,6 +141,7 @@
$CXX = '@CXX@'; # C++ compiler
$EXCEPTIONS = '@EXCEPTIONS@'; # Exception handling type
$ENABLE_DEBUG = '@ENABLE_DEBUG@'; # Enable a debug build
+$USE_LINUXJDK = '@USE_LINUXJDK@'; # Enable a debug build
$WRAPCMD = ""; # Wrapper (only for winnt)
#
@@ -1265,7 +1266,12 @@
{ $SOLARINC .=$I.'$JAVA_HOME'.$INCLUDE.$ds."linux";
}
elsif ($platform eq "$FreeBSD")
-{ $SOLARINC .=$I.'$JAVA_HOME'.$INCLUDE.$ds."freebsd";
+{
+ if ($USE_LINUXJDK eq "TRUE") {
+ $SOLARINC .=$I.'$JAVA_HOME'.$INCLUDE.$ds."linux";
+ } else {
+ $SOLARINC .=$I.'$JAVA_HOME'.$INCLUDE.$ds."freebsd";
+ }
}
elsif ($platform eq "$NetBSD")
{ $SOLARINC .=$I.'$JAVA_HOME'.$INCLUDE.$ds."netbsd";