Moving Vic Abell's LSOF package from ports/misc to ports/sysutils.

LSOF is a very useful package for a system administrateor. Ot shows all
kind of open files, including sockets, pipes and knows about NFS.
This commit is contained in:
David E. O'Brien 1996-11-11 19:42:45 +00:00
parent 6379e5c2cc
commit c2583f209a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=4401
6 changed files with 74 additions and 0 deletions

52
sysutils/lsof/Makefile Normal file
View File

@ -0,0 +1,52 @@
# New ports collection makefile for: lsof
# Version required: 3.75
# Date created: Sat July 20, 1996
# Whom: David O'Brien (obrien@cs.ucdavis.edu)
#
# $Id: Makefile,v 1.2 1996/11/11 05:49:47 obrien Exp $
#
DISTNAME= lsof_3.75_W
PKGNAME= lsof-3.75
CATEGORIES= sysutils
MASTER_SITES= ftp://vic.cc.purdue.edu/pub/tools/unix/lsof/ \
ftp://ftp.cert.dfn.de/pub/tools/admin/lsof/ \
ftp://ftp.auscert.org.au/pub/mirrors/vic.cc.purdue.edu/lsof/ \
ftp://ftp.web.ad.jp/pub/UNIX/tools/lsof/ \
ftp://ftp.sunet.se/pub/unix/admin/lsof
MAINTAINER= obrien@cs.ucdavis.edu
WRKSRC= ${WRKDIR}/${SRCBALL_NAME}
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= Configure
CONFIGURE_ARGS= -n freebsd
SRCBALL_NAME= ${DISTNAME:S/_W$//}
post-extract:
@( cd ${WRKDIR} ; \
EXPMD5=`/usr/bin/grep MD5 README.${SRCBALL_NAME} | sed 's/^[ ]*//'` ; \
CALCMD5=`${MD5} ${SRCBALL_NAME}.tar` ; \
if [ "$${EXPMD5}"X != "$${CALCMD5}"X ]; then \
echo "Expected and calculated MD5 signatures don't agree." ; \
echo "($$EXPMD5 != $$CALCMD5)" ; \
exit 1 ; \
fi ; \
${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS:S/z//} ${SRCBALL_NAME}.tar \
)
@( cd ${WRKSRC} ; echo "y" | ./Inventory || exit 1 )
do-install:
${INSTALL} ${COPY} ${STRIP} -o ${BINOWN} -g ${BINGRP} -m 2755 -g kmem ${WRKSRC}/lsof ${PREFIX}/sbin
${INSTALL_MAN} ${WRKSRC}/lsof.man ${PREFIX}/man/man1/lsof.1
post-install:
.if !defined(NOMANCOMPRESS)
gzip -9nf ${PREFIX}/man/man1/lsof.1
.endif
.include <bsd.port.mk>

1
sysutils/lsof/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (lsof_3.69_W.tar.gz) = 6a522fdd5305e29b25c9b472427e1ba8

View File

@ -0,0 +1,11 @@
--- dialects/freebsd/machine.h.orig Mon Jul 29 11:32:54 1996
+++ dialects/freebsd/machine.h Tue Aug 6 18:55:07 1996
@@ -274,7 +274,7 @@
* (the one that its user logged on with) of the lsof process.
*/
-/* #define HASSECURITY 1 */
+#define HASSECURITY 1
/*

View File

@ -0,0 +1 @@
Lists information about open files.

7
sysutils/lsof/pkg-descr Normal file
View File

@ -0,0 +1,7 @@
Lsof (LiSt Open Files) lists information about files that are open by the
running processes. An open file may be a regular file, a directory, a block
special file, a character special file, an executing text reference, a
library, a stream or a network file (Internet socket, NFS file or Unix domain
socket).
-- David (obrien@cs.ucdavis.edu)

2
sysutils/lsof/pkg-plist Normal file
View File

@ -0,0 +1,2 @@
sbin/lsof
man/man1/lsof.1.gz