MyPasswordSafe is a straight-forward, easy-to-use password manager that

maintains compatibility with Password Safe files. MyPasswordSafe has the
following features:

* Safes are encrypted when they are stored to disk.
* Passwords never have to be seen, because they are copied to the clipboard.
* Random passwords can be generated.
* Window size, position, and column widths are remembered.
* Passwords remain encrypted until they need to be decrypted at the dialog and
  file levels.
* A safe can be made active so it will always be opened when MyPasswordSafe
  starts.
* Supports Unicode in the safes.
* Languages supported: English and French.

WWW: http://www.semanticgap.com/myps/
This commit is contained in:
Alejandro Pulver 2006-12-17 20:29:05 +00:00
parent 6256380ee1
commit c22052f6b7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=180037
8 changed files with 99 additions and 0 deletions

View File

@ -261,6 +261,7 @@
SUBDIR += mindterm-binary
SUBDIR += mosref
SUBDIR += mussh
SUBDIR += mypasswordsafe
SUBDIR += nbaudit
SUBDIR += ncrypt
SUBDIR += nessus

View File

@ -0,0 +1,33 @@
# New ports collection makefile for: mypasswordsafe
# Date created: 2006-11-26
# Whom: alepulver
#
# $FreeBSD$
#
PORTNAME= MyPasswordSafe
PORTVERSION= 20060326
CATEGORIES= security
MASTER_SITES= http://www.semanticgap.com/myps/release/
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
EXTRACT_SUFX= .tgz
MAINTAINER= alepulver@FreeBSD.org
COMMENT= Easy-to-use password manager compatible with Password Safe
BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
USE_GMAKE= yes
USE_KDELIBS_VER=3
WRKSRC= ${WRKDIR}/${DISTNAME:S/.src//}
MAKE_ENV= QTDIR="${X11BASE}" \
QMAKESPEC="${LOCALBASE}/share/qt/mkspecs/freebsd-g++"
post-patch:
@${REINPLACE_CMD} -Ee 's|(USER=)\$$\(USER\)|\1$$(shell whoami)|' \
${WRKSRC}/${MAKEFILE}
.if defined(NOPORTDOCS)
@${REINPLACE_CMD} -e '63,64d; 66,67d' ${WRKSRC}/${MAKEFILE}
.endif
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
MD5 (MyPasswordSafe-20060326.src.tgz) = 5f93e1545819f75901eb7dc921089720
SHA256 (MyPasswordSafe-20060326.src.tgz) = 64aacf6836100019d636e2d3c69044cef8a273cbd99992d5fb37999a1d7df582
SIZE (MyPasswordSafe-20060326.src.tgz) = 835296

View File

@ -0,0 +1,11 @@
--- ./src/crypto/sha1.h.orig Mon Dec 6 09:32:07 2004
+++ ./src/crypto/sha1.h Sun Nov 26 21:56:00 2006
@@ -15,7 +15,7 @@
#include <stdint.h>
#include <string>
-#include "endian.h"
+#include "myendian.h"
using std::string;

View File

@ -0,0 +1,11 @@
--- ./src/myendian.h.orig Mon Nov 1 20:23:03 2004
+++ ./src/myendian.h Sun Nov 26 20:50:13 2006
@@ -8,7 +8,7 @@
# define BYTE_ORDER LITTLE_ENDIAN
# endif
#else
-# ifdef __NetBSD__
+# if defined(__NetBSD__) || defined(__FreeBSD__)
# include <sys/endian.h>
# elif __APPLE__
# include <ppc/endian.h>

View File

@ -0,0 +1,9 @@
--- ./src/mypasswordsafe.ui.orig Sat Dec 17 08:33:21 2005
+++ ./src/mypasswordsafe.ui Sun Nov 26 21:55:40 2006
@@ -1025,6 +1025,5 @@
<pixmapinproject/>
<layoutdefaults spacing="6" margin="11"/>
<includehints>
- <includehint>safelistview.h</includehint>
</includehints>
</UI>

View File

@ -0,0 +1,16 @@
MyPasswordSafe is a straight-forward, easy-to-use password manager that
maintains compatibility with Password Safe files. MyPasswordSafe has the
following features:
* Safes are encrypted when they are stored to disk.
* Passwords never have to be seen, because they are copied to the clipboard.
* Random passwords can be generated.
* Window size, position, and column widths are remembered.
* Passwords remain encrypted until they need to be decrypted at the dialog and
file levels.
* A safe can be made active so it will always be opened when MyPasswordSafe
starts.
* Supports Unicode in the safes.
* Languages supported: English and French.
WWW: http://www.semanticgap.com/myps/

View File

@ -0,0 +1,15 @@
bin/MyPasswordSafe
%%DATADIR%%/locale/mypasswordsafe_c.qm
%%DATADIR%%/locale/mypasswordsafe_en.qm
%%DATADIR%%/locale/mypasswordsafe_fr.qm
%%PORTDOCS%%%%DOCSDIR%%/manual.html
%%PORTDOCS%%%%DOCSDIR%%/sshots/editdialog.fr.jpg
%%PORTDOCS%%%%DOCSDIR%%/sshots/editdialog.jpg
%%PORTDOCS%%%%DOCSDIR%%/sshots/mainwindow.fr.jpg
%%PORTDOCS%%%%DOCSDIR%%/sshots/mainwindow.jpg
%%PORTDOCS%%%%DOCSDIR%%/sshots/prefsdialog.fr.jpg
%%PORTDOCS%%%%DOCSDIR%%/sshots/prefsdialog.jpg
%%PORTDOCS%%@dirrm %%DOCSDIR%%/sshots
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%DATADIR%%/locale
@dirrm %%DATADIR%%