Upgrade to 4.0.10.

This commit is contained in:
Thomas Gellekum 2000-02-14 13:05:12 +00:00
parent 7f1c13ce26
commit c1e3ecebdf
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=25817
11 changed files with 90 additions and 85 deletions

View File

@ -1,13 +1,13 @@
# New ports collection makefile for: opendx
# Version required: 4.0.9
# Version required: 4.0.10
# Date created: 27 May 1999
# Whom: Thomas Gellekum <tg@FreeBSD.org>
#
# $FreeBSD$
#
DISTNAME= dx-4.0.9
PKGNAME= opendx-4.0.9
DISTNAME= dx-4.0.10
PKGNAME= opendx-4.0.10
CATEGORIES= graphics math
MASTER_SITES= http://opendx.npaci.edu/source/
@ -18,6 +18,7 @@ LIB_DEPENDS= GL.14:${PORTSDIR}/graphics/Mesa3 \
USE_XLIB= yes
REQUIRES_MOTIF= yes
USE_NEWGCC= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CFLAGS="${CFLAGS} -Dfreebsd -I${PREFIX}/include" \
CPPFLAGS="-I${PREFIX}/include" \

View File

@ -1 +1 @@
MD5 (dx-4.0.9.tar.gz) = 4cf860d01a25c57d4ca53195d851dad0
MD5 (dx-4.0.10.tar.gz) = b38eb261303faf33fd5bed5a8d3c3bcc

View File

@ -1,11 +1,28 @@
--- src/exec/dpexec/Makefile.in.orig Wed Aug 25 22:21:36 1999
+++ src/exec/dpexec/Makefile.in Wed Sep 15 12:31:03 1999
@@ -1341,7 +1341,7 @@
mostlyclean distclean maintainer-clean
--- src/exec/dpexec/Makefile.in.orig Thu Jan 6 21:17:53 2000
+++ src/exec/dpexec/Makefile.in Sat Feb 12 15:22:32 2000
@@ -90,7 +90,7 @@
YACC = @YACC@
yakker = @yakker@
-INCLUDES = -I../../../include -I../libdx -D@ARCH@
+INCLUDES = -I../../../include -I../libdx
noinst_LIBRARIES = libDPEXEC.a
@@ -204,6 +204,7 @@
else :; fi
yuiif.h: yuiif.c
+lex.o: yuiif.h
tags: TAGS
@@ -302,7 +303,7 @@
maintainer-clean-generic clean mostlyclean distclean maintainer-clean
-$(libDPEXEC_a_SOURCES): yuiif.c yuiif.h
+# $(libDPEXEC_a_SOURCES): yuiif.c yuiif.h
.y.h:
$(YACC) $(YFLAGS) -d $*.y
include local.mk

View File

@ -1,6 +1,6 @@
--- bin/dxworker.in.orig Fri Sep 3 17:52:03 1999
+++ bin/dxworker.in Wed Nov 3 12:52:46 1999
@@ -22,10 +22,10 @@
--- bin/dxworker.in.orig Sun Dec 19 00:22:09 1999
+++ bin/dxworker.in Fri Feb 11 19:21:17 2000
@@ -22,8 +22,8 @@
# determine the machine type, and set uiarch, exarch and thisver defaults
switch ( $thissys )
case FreeBSD:
@ -9,12 +9,9 @@
+ set exarch=$thismach
+ set uiarch=$thismach
- set remove=/usr/bin/rsh
+ set remote=/usr/bin/rsh
set remote=/usr/bin/rsh
breaksw
@@ -136,7 +136,7 @@
@@ -139,7 +139,7 @@
# default to running locally, from /usr/lpp/dx
set exhost=$thishost
@ -23,7 +20,7 @@
set startup=1 # run the startup window by default
@@ -1456,7 +1456,7 @@
@@ -1459,7 +1459,7 @@
case aviion:
case alphax:
case linux:

View File

@ -31,28 +31,6 @@
noinst_LIBRARIES = libHW.a
--- src/exec/hwrender/opengl/Makefile.in.orig Tue Sep 28 17:56:55 1999
+++ src/exec/hwrender/opengl/Makefile.in Tue Sep 28 17:57:41 1999
@@ -86,7 +86,7 @@
YACC = @YACC@
yakker = @yakker@
-INCLUDES = -I../../../../include -I.. -I../../libdx -I/usr/include -I/usr/local/include -D@ARCH@
+INCLUDES = -I../../../../include -I.. -I../../libdx -I/usr/include -I/usr/local/include
noinst_LIBRARIES = libOPENGL.a
--- src/exec/dpexec/Makefile.in.orig Tue Sep 28 17:58:27 1999
+++ src/exec/dpexec/Makefile.in Tue Sep 28 17:58:36 1999
@@ -87,7 +87,7 @@
YACC = @YACC@
yakker = @yakker@
-INCLUDES = -I../../../include -I../libdx -D@ARCH@
+INCLUDES = -I../../../include -I../libdx
noinst_LIBRARIES = libDPEXEC.a
--- src/exec/dxexec/Makefile.in.orig Tue Sep 28 17:59:10 1999
+++ src/exec/dxexec/Makefile.in Tue Sep 28 17:59:17 1999
@@ -86,7 +86,7 @@
@ -64,17 +42,6 @@
EXPARG = @EXPARG@
--- src/uipp/dxuilib/Makefile.in.orig Tue Sep 28 18:01:04 1999
+++ src/uipp/dxuilib/Makefile.in Tue Sep 28 18:01:13 1999
@@ -86,7 +86,7 @@
YACC = @YACC@
yakker = @yakker@
-INCLUDES = -I../base -I../../../include -I../dxui -D@ARCH@
+INCLUDES = -I../base -I../../../include -I../dxui
noinst_LIBRARIES = libDXUI.a
--- src/uipp/base/Makefile.in.orig Tue Sep 28 18:01:51 1999
+++ src/uipp/base/Makefile.in Tue Sep 28 18:02:01 1999
@@ -86,7 +86,7 @@
@ -119,17 +86,6 @@
dxbindir = $(prefix)/dx/bin_@ARCH@
dxbin_PROGRAMS = dxui
--- src/uipp/prompter/Makefile.in.orig Tue Sep 28 18:06:39 1999
+++ src/uipp/prompter/Makefile.in Tue Sep 28 18:06:56 1999
@@ -86,7 +86,7 @@
YACC = @YACC@
yakker = @yakker@
-INCLUDES = -I../base -I../../../include -D@ARCH@
+INCLUDES = -I../base -I../../../include
dxbindir = $(prefix)/dx/bin_@ARCH@
--- src/uipp/tutor/Makefile.in.orig Tue Sep 28 18:07:31 1999
+++ src/uipp/tutor/Makefile.in Tue Sep 28 18:07:41 1999
@@ -86,7 +86,7 @@
@ -152,25 +108,3 @@
dxbindir = $(prefix)/dx/bin_@ARCH@
--- src/uipp/startup/Makefile.in.orig Tue Sep 28 18:09:07 1999
+++ src/uipp/startup/Makefile.in Tue Sep 28 18:09:21 1999
@@ -86,7 +86,7 @@
YACC = @YACC@
yakker = @yakker@
-INCLUDES = -I../../../include -I../base -D@ARCH@
+INCLUDES = -I../../../include -I../base
dxbindir = $(prefix)/dx/bin_@ARCH@
--- src/uipp/java/Makefile.in.orig Tue Sep 28 18:10:10 1999
+++ src/uipp/java/Makefile.in Tue Sep 28 18:10:57 1999
@@ -422,7 +422,7 @@
DXLink.o: server.jar
(CLASSPATH=aaaaa ; unset CLASSPATH ; cd dxsc; @JDKBIN@javah -jni -d ../server server.DXServer server.DXServerThread)
- (cd server; $(CC) -o ../DXLink.o -I../../../../include -c -D@ARCH@ $(CFLAGS) $(JINC) DXLink.c)
+ (cd server; $(CC) -o ../DXLink.o -I../../../../include -c $(CFLAGS) $(JINC) DXLink.c)
clean:
rm -rf classes dxsc

View File

@ -0,0 +1,11 @@
--- src/exec/hwrender/opengl/Makefile.in.orig Thu Jan 6 21:17:56 2000
+++ src/exec/hwrender/opengl/Makefile.in Fri Feb 11 19:24:28 2000
@@ -90,7 +90,7 @@
YACC = @YACC@
yakker = @yakker@
-INCLUDES = -I../../../../include -I.. -I../../libdx -I/usr/include -I/usr/local/include -D@ARCH@
+INCLUDES = -I../../../../include -I.. -I../../libdx -I/usr/include -I/usr/local/include
noinst_LIBRARIES = libOPENGL.a

View File

@ -0,0 +1,11 @@
--- src/uipp/dxuilib/Makefile.in.orig Thu Jan 6 21:18:03 2000
+++ src/uipp/dxuilib/Makefile.in Fri Feb 11 19:26:20 2000
@@ -90,7 +90,7 @@
YACC = @YACC@
yakker = @yakker@
-INCLUDES = -I../base -I../../../include -I../dxui -D@ARCH@
+INCLUDES = -I../base -I../../../include -I../dxui
noinst_LIBRARIES = libDXUI.a

View File

@ -0,0 +1,11 @@
--- src/uipp/prompter/Makefile.in.orig Thu Jan 6 21:18:08 2000
+++ src/uipp/prompter/Makefile.in Fri Feb 11 19:27:16 2000
@@ -90,7 +90,7 @@
YACC = @YACC@
yakker = @yakker@
-INCLUDES = -I../base -I../../../include -D@ARCH@
+INCLUDES = -I../base -I../../../include
dxbindir = $(prefix)/dx/bin_@ARCH@

View File

@ -0,0 +1,11 @@
--- src/uipp/startup/Makefile.in.orig Thu Jan 6 21:18:09 2000
+++ src/uipp/startup/Makefile.in Fri Feb 11 19:28:16 2000
@@ -90,7 +90,7 @@
YACC = @YACC@
yakker = @yakker@
-INCLUDES = -I../../../include -I../base -D@ARCH@
+INCLUDES = -I../../../include -I../base
dxbindir = $(prefix)/dx/bin_@ARCH@

View File

@ -0,0 +1,11 @@
--- src/uipp/java/Makefile.in.orig Thu Jan 6 21:18:07 2000
+++ src/uipp/java/Makefile.in Fri Feb 11 19:29:50 2000
@@ -460,7 +460,7 @@
DXLink.o: server.jar
(cd dxsc; $(JAVAH) -d ../server server.DXServer server.DXServerThread)
- (cd server; $(CC) -o ../DXLink.o -I../../../../include -c -D@ARCH@ $(CFLAGS) @JINC@ DXLink.c)
+ (cd server; $(CC) -o ../DXLink.o -I../../../../include -c $(CFLAGS) @JINC@ DXLink.c)
distclean-local:
rm -rf classes dxsc

View File

@ -1,4 +1,5 @@
bin/dx
dx/bin/dx
dx/bin/dxworker
dx/bin/mdf2c
dx/bin_%%ARCH%%/builder