Update to 0.3.2.
Note: there is a sneaking suspicion abounding that this program will not work with libc_r. If you are forcing libc_r for something like the NVidia kernel module, update that port and switch over to libpthread. Note also: a noticible pause when starting a new game seems to be normal. This pause is also associated with a gigantic memory spike, but it'll subside once the game starts.
This commit is contained in:
parent
91de6dd40b
commit
c10d8e4505
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=117216
@ -6,29 +6,22 @@
|
||||
#
|
||||
|
||||
PORTNAME= monkeybubble
|
||||
PORTVERSION= 0.1.9
|
||||
PORTREVISION= 7
|
||||
PORTVERSION= 0.3.2
|
||||
CATEGORIES= games gnome
|
||||
#MASTER_SITES= http://monkey-bubble.tuxfamily.org/ #OMG where did the website go?!?!
|
||||
MASTER_SITES= ${MASTER_SITE_LOCAL}
|
||||
MASTER_SITE_SUBDIR= adamw
|
||||
MASTER_SITES= http://home.gna.org/monkeybubble/downloads/
|
||||
DISTNAME= monkey-bubble-${PORTVERSION}
|
||||
|
||||
MAINTAINER= adamw@FreeBSD.org
|
||||
COMMENT= GTK2 Puzzle Bobble clone with monkeys
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_LIBTOOL_VER=13
|
||||
USE_LIBTOOL_VER=15
|
||||
USE_REINPLACE= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GNOME= gnomehack gnomeprefix librsvg2 libgnomeui \
|
||||
gstreamerplugins intlhack lthack
|
||||
gstreamerplugins intlhack
|
||||
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LIBS="-L${LOCALBASE}/lib"
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e "s|gstreamer-0.6|gstreamer-0.8|g" \
|
||||
${WRKSRC}/configure
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,2 @@
|
||||
MD5 (monkey-bubble-0.1.9.tar.gz) = ad4fd5cbbbcfd2be7dcfc12ac1c59ebc
|
||||
SIZE (monkey-bubble-0.1.9.tar.gz) = 5134215
|
||||
MD5 (monkey-bubble-0.3.2.tar.gz) = 37e91fa4cdbab9ec06b2ee2a5aa0683c
|
||||
SIZE (monkey-bubble-0.3.2.tar.gz) = 5453029
|
||||
|
20
games/monkeybubble/files/patch-src::audio::sound-manager.c
Normal file
20
games/monkeybubble/files/patch-src::audio::sound-manager.c
Normal file
@ -0,0 +1,20 @@
|
||||
--- src/audio/sound-manager.c.orig Tue Aug 24 22:53:40 2004
|
||||
+++ src/audio/sound-manager.c Tue Aug 24 22:54:13 2004
|
||||
@@ -193,6 +193,8 @@
|
||||
GObject *new_pad,
|
||||
SoundManager * m)
|
||||
{
|
||||
+
|
||||
+ GstPad * pad;
|
||||
|
||||
gst_element_set_state (PRIVATE(m)->main_bin, GST_STATE_PAUSED);
|
||||
|
||||
@@ -209,7 +211,7 @@
|
||||
PRIVATE(m)->output,
|
||||
NULL);
|
||||
|
||||
- GstPad * pad = gst_element_get_pad( GST_ELEMENT(PRIVATE(m)->vorbis_dec),"sink");
|
||||
+ pad = gst_element_get_pad( GST_ELEMENT(PRIVATE(m)->vorbis_dec),"sink");
|
||||
|
||||
gst_pad_link( GST_PAD(new_pad), pad);
|
||||
PRIVATE(m)->new_pad_ok = TRUE;
|
@ -0,0 +1,20 @@
|
||||
--- src/ui/eggcellrendererkeys.c.orig Fri Aug 13 14:50:55 2004
|
||||
+++ src/ui/eggcellrendererkeys.c Fri Aug 13 14:51:54 2004
|
||||
@@ -588,7 +588,7 @@
|
||||
void
|
||||
egg_cell_renderer_keys_set_accelerator (EggCellRendererKeys *keys,
|
||||
guint keyval,
|
||||
- GdkModifierType mask)
|
||||
+ EggVirtualModifierType mask)
|
||||
{
|
||||
char *text;
|
||||
gboolean changed;
|
||||
@@ -630,7 +630,7 @@
|
||||
void
|
||||
egg_cell_renderer_keys_get_accelerator (EggCellRendererKeys *keys,
|
||||
guint *keyval,
|
||||
- GdkModifierType *mask)
|
||||
+ EggVirtualModifierType *mask)
|
||||
{
|
||||
g_return_if_fail (EGG_IS_CELL_RENDERER_KEYS (keys));
|
||||
|
@ -0,0 +1,16 @@
|
||||
--- src/ui/game-network-player-manager.c.orig Tue Aug 24 22:56:44 2004
|
||||
+++ src/ui/game-network-player-manager.c Tue Aug 24 22:57:00 2004
|
||||
@@ -125,11 +125,12 @@
|
||||
gboolean start_timeout(gpointer data) {
|
||||
GameNetworkPlayerManager * manager;
|
||||
GameNetworkPlayer * game;
|
||||
+ UiMain * ui_main;
|
||||
|
||||
manager = GAME_NETWORK_PLAYER_MANAGER(data);
|
||||
|
||||
|
||||
- UiMain * ui_main = ui_main_get_instance();
|
||||
+ ui_main = ui_main_get_instance();
|
||||
|
||||
PRIVATE(manager)->playing = TRUE;
|
||||
|
@ -1,18 +1,18 @@
|
||||
--- src/ui/ui-main.c.orig Fri Jan 16 20:28:27 2004
|
||||
+++ src/ui/ui-main.c Fri Jan 16 20:28:45 2004
|
||||
@@ -587,6 +587,7 @@
|
||||
const char *message_format, ...) {
|
||||
char *message;
|
||||
va_list args;
|
||||
+ GtkWidget *dialog;
|
||||
--- src/ui/ui-main.c.orig Fri Aug 13 14:47:33 2004
|
||||
+++ src/ui/ui-main.c Fri Aug 13 14:48:06 2004
|
||||
@@ -647,6 +647,7 @@
|
||||
const char *message_format, ...) {
|
||||
char *message;
|
||||
va_list args;
|
||||
+ GtkWidget *dialog;
|
||||
|
||||
if (message_format) {
|
||||
va_start (args, message_format);
|
||||
@@ -596,7 +597,6 @@
|
||||
message = NULL;
|
||||
}
|
||||
if (message_format) {
|
||||
va_start (args, message_format);
|
||||
@@ -656,7 +657,6 @@
|
||||
message = NULL;
|
||||
}
|
||||
|
||||
- GtkWidget *dialog;
|
||||
dialog = gtk_message_dialog_new (transient_parent,
|
||||
GTK_DIALOG_DESTROY_WITH_PARENT,
|
||||
GTK_MESSAGE_ERROR,
|
||||
- GtkWidget *dialog;
|
||||
dialog = gtk_message_dialog_new (transient_parent,
|
||||
GTK_DIALOG_DESTROY_WITH_PARENT,
|
||||
GTK_MESSAGE_ERROR,
|
||||
|
@ -1,4 +1,5 @@
|
||||
bin/monkey-bubble
|
||||
bin/monkey-srv
|
||||
@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/monkey-bubble.schemas > /dev/null || /usr/bin/true
|
||||
etc/gconf/schemas/monkey-bubble.schemas
|
||||
@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/monkey-bubble.schemas > /dev/null || /usr/bin/true
|
||||
@ -16,17 +17,20 @@ share/gnome/monkey-bubble/gfx/bubbles/bubble_05.svg
|
||||
share/gnome/monkey-bubble/gfx/bubbles/bubble_06.svg
|
||||
share/gnome/monkey-bubble/gfx/bubbles/bubble_07.svg
|
||||
share/gnome/monkey-bubble/gfx/bubbles/bubble_08.svg
|
||||
share/gnome/monkey-bubble/gfx/bubbles/little_bubble.svg
|
||||
share/gnome/monkey-bubble/gfx/frozen-bubble/back_hiscores.png
|
||||
share/gnome/monkey-bubble/gfx/harm.svg
|
||||
share/gnome/monkey-bubble/gfx/harm_down.svg
|
||||
share/gnome/monkey-bubble/gfx/harm_shoot.svg
|
||||
share/gnome/monkey-bubble/gfx/harm_up.svg
|
||||
share/gnome/monkey-bubble/gfx/hurry_up.svg
|
||||
share/gnome/monkey-bubble/gfx/layout_1_player.svg
|
||||
share/gnome/monkey-bubble/gfx/layout_2_players.svg
|
||||
share/gnome/monkey-bubble/gfx/layout_network_player.svg
|
||||
share/gnome/monkey-bubble/gfx/left_monkey.svg
|
||||
share/gnome/monkey-bubble/gfx/looser.svg
|
||||
share/gnome/monkey-bubble/gfx/lost.svg
|
||||
share/gnome/monkey-bubble/gfx/monkey.png
|
||||
share/gnome/monkey-bubble/gfx/monkeys.svg
|
||||
share/gnome/monkey-bubble/gfx/number/0.svg
|
||||
share/gnome/monkey-bubble/gfx/number/1.svg
|
||||
share/gnome/monkey-bubble/gfx/number/2.svg
|
||||
@ -39,6 +43,7 @@ share/gnome/monkey-bubble/gfx/number/8.svg
|
||||
share/gnome/monkey-bubble/gfx/number/9.svg
|
||||
share/gnome/monkey-bubble/gfx/pane.svg
|
||||
share/gnome/monkey-bubble/gfx/pause.svg
|
||||
share/gnome/monkey-bubble/gfx/right_monkey.svg
|
||||
share/gnome/monkey-bubble/gfx/snake-body.svg
|
||||
share/gnome/monkey-bubble/gfx/snake/snake.svg
|
||||
share/gnome/monkey-bubble/gfx/snake/snake_-0.svg
|
||||
@ -129,6 +134,8 @@ share/gnome/monkey-bubble/gfx/tomato.svg
|
||||
share/gnome/monkey-bubble/gfx/win.svg
|
||||
share/gnome/monkey-bubble/glade/keybinding.glade
|
||||
share/gnome/monkey-bubble/glade/monkey-bubble.glade
|
||||
share/gnome/monkey-bubble/glade/netgame.glade
|
||||
share/gnome/monkey-bubble/glade/netserver.glade
|
||||
share/gnome/monkey-bubble/levels
|
||||
share/gnome/monkey-bubble/sounds/game.ogg
|
||||
share/gnome/monkey-bubble/sounds/splash.ogg
|
||||
@ -137,10 +144,22 @@ share/gnome/omf/monkey-bubble/monkey-bubble-C.omf
|
||||
share/gnome/omf/monkey-bubble/monkey-bubble-fr.omf
|
||||
@exec scrollkeeper-install -q %D/share/gnome/omf/monkey-bubble/monkey-bubble-fr.omf 2>/dev/null || /usr/bin/true
|
||||
share/gnome/pixmaps/monkey-bubble-icon.png
|
||||
share/locale/cs/LC_MESSAGES/monkey-bubble.mo
|
||||
share/locale/de/LC_MESSAGES/monkey-bubble.mo
|
||||
share/locale/en_CA/LC_MESSAGES/monkey-bubble.mo
|
||||
share/locale/en_GB/LC_MESSAGES/monkey-bubble.mo
|
||||
share/locale/es/LC_MESSAGES/monkey-bubble.mo
|
||||
share/locale/eu/LC_MESSAGES/monkey-bubble.mo
|
||||
share/locale/fr/LC_MESSAGES/monkey-bubble.mo
|
||||
share/locale/hr/LC_MESSAGES/monkey-bubble.mo
|
||||
share/locale/nl/LC_MESSAGES/monkey-bubble.mo
|
||||
share/locale/pt/LC_MESSAGES/monkey-bubble.mo
|
||||
share/locale/pt_BR/LC_MESSAGES/monkey-bubble.mo
|
||||
share/locale/sr/LC_MESSAGES/monkey-bubble.mo
|
||||
share/locale/sr@Latn/LC_MESSAGES/monkey-bubble.mo
|
||||
share/locale/sv/LC_MESSAGES/monkey-bubble.mo
|
||||
share/locale/tr/LC_MESSAGES/monkey-bubble.mo
|
||||
share/locale/uk/LC_MESSAGES/monkey-bubble.mo
|
||||
@dirrm share/gnome/omf/monkey-bubble
|
||||
@dirrm share/gnome/monkey-bubble/sounds
|
||||
@dirrm share/gnome/monkey-bubble/glade
|
||||
|
Loading…
Reference in New Issue
Block a user