Add kio_fish 1.0.1, a KIO module that allows you to use sftp or scp
from within KDE's Konqueror. Submitted by: Lauri Watts <lauri@kde.org>
This commit is contained in:
parent
36e50f6985
commit
c0f7f37878
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=51010
@ -183,6 +183,7 @@
|
||||
SUBDIR += kdetelnet
|
||||
SUBDIR += kicq
|
||||
SUBDIR += kinkatta
|
||||
SUBDIR += kio_fish
|
||||
SUBDIR += kmsn
|
||||
SUBDIR += kmud
|
||||
SUBDIR += konverse
|
||||
|
32
net/kio_fish/Makefile
Normal file
32
net/kio_fish/Makefile
Normal file
@ -0,0 +1,32 @@
|
||||
# New ports collection makefile for: kio_fish
|
||||
# Date created: Mon 26 Nov 2001
|
||||
# Whom: Lauri Watts <lauri@kde.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= kio_fish
|
||||
PORTVERSION= 1.0.1
|
||||
CATEGORIES?= net kde
|
||||
MASTER_SITES= http://ich.bin.kein.hoschi.de/fish/
|
||||
DIST_SUBDIR= KDE
|
||||
|
||||
MAINTAINER?= kde@FreeBSD.org
|
||||
|
||||
USE_KDELIBS_VER=2
|
||||
INSTALLS_SHLIB= yes
|
||||
USE_AUTOCONF= yes
|
||||
USE_GMAKE= yes
|
||||
CONFIGURE_ENV+= PATH=$$PATH:${WRKSRC}/auto-bin
|
||||
MAKE_ENV+= ${CONFIGURE_ENV}
|
||||
|
||||
pre-configure:
|
||||
${MKDIR} ${WRKSRC}/auto-bin
|
||||
.for AC in autoconf autoheader
|
||||
${LN} -sf ${LOCALBASE}/bin/${AC}213 ${WRKSRC}/auto-bin/${AC}
|
||||
.endfor
|
||||
.for AM in automake aclocal
|
||||
${LN} -sf ${LOCALBASE}/bin/${AM}14 ${WRKSRC}/auto-bin/${AM}
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.mk>
|
1
net/kio_fish/distinfo
Normal file
1
net/kio_fish/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (KDE/kio_fish-1.0.1.tar.gz) = 08154676dc975e7fc91dc2bb61de030b
|
11
net/kio_fish/files/patch-configure.in
Normal file
11
net/kio_fish/files/patch-configure.in
Normal file
@ -0,0 +1,11 @@
|
||||
--- configure.in Tue Oct 9 20:54:28 2001
|
||||
+++ configure.in.new Mon Nov 26 22:08:38 2001
|
||||
@@ -51,7 +51,7 @@
|
||||
CFLAGS="$CFLAGS -D_GNU_SOURCE"
|
||||
CXXFLAGS="$CXXFLAGS -D_GNU_SOURCE"
|
||||
|
||||
-AC_CHECK_HEADERS(termios.h pty.h)
|
||||
+AC_CHECK_HEADERS(termios.h pty.h libutil.h sys/types.h sys/ioctl.h)
|
||||
AC_CHECK_LIB(util,openpty)
|
||||
AC_CHECK_FUNCS(getpt openpty unlockpt grantpt isastream)
|
||||
|
18
net/kio_fish/files/patch-fish::fish.cpp
Normal file
18
net/kio_fish/files/patch-fish::fish.cpp
Normal file
@ -0,0 +1,18 @@
|
||||
--- fish/fish.cpp Mon Oct 22 14:52:05 2001
|
||||
+++ fish/fish.cpp.new Mon Nov 26 22:13:52 2001
|
||||
@@ -39,6 +39,15 @@
|
||||
#ifdef HAVE_TERMIOS_H
|
||||
#include <termios.h>
|
||||
#endif
|
||||
+#ifdef HAVE_SYS_TYPES_H
|
||||
+#include <sys/types.h>
|
||||
+#endif
|
||||
+#ifdef HAVE_SYS_IOCTL_H
|
||||
+#include <sys/ioctl.h>
|
||||
+#endif
|
||||
+#ifdef HAVE_LIBUTIL_H
|
||||
+#include <libutil.h>
|
||||
+#endif
|
||||
#include <math.h>
|
||||
#include <unistd.h>
|
||||
#include <sys/socket.h>
|
1
net/kio_fish/pkg-comment
Normal file
1
net/kio_fish/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
A KIO module that allows you to use sftp or scp from within KDE's Konqueror
|
12
net/kio_fish/pkg-descr
Normal file
12
net/kio_fish/pkg-descr
Normal file
@ -0,0 +1,12 @@
|
||||
kio_fish is a kioslave for KDE 2.0 that lets you view and manipulate
|
||||
your remote files using just a simple shell account and some standard
|
||||
unix commands on the remote machine. You get full filesystem access
|
||||
without setting up a server - no NFS, Samba, ... needed.
|
||||
|
||||
Usage is really simple: open up a konqueror window (or use the Alt-F2
|
||||
dialog) and type 'fish://user@remote.machi.ne'. kio_fish will ask you
|
||||
for the password, if any is needed, and you will start out in your
|
||||
home directory. Now you can do everything you do on your local hard
|
||||
disk.
|
||||
|
||||
WWW: http://ich.bin.kein.hoschi.de/fish/
|
5
net/kio_fish/pkg-plist
Normal file
5
net/kio_fish/pkg-plist
Normal file
@ -0,0 +1,5 @@
|
||||
share/services/fish.protocol
|
||||
share/doc/HTML/en/fish/fish.docbook
|
||||
lib/kde2/kio_fish.so
|
||||
lib/kde2/kio_fish.la
|
||||
@dirrm share/doc/HTML/en/fish
|
Loading…
Reference in New Issue
Block a user