MFH: r525988
security/nss: unbreak on armv6 after r524147 In file included from ../../lib/freebl/gcm-arm32-neon.c:16: /usr/lib/clang/8.0.1/include/arm_neon.h:28:2: error: "NEON support not enabled" #error "NEON support not enabled" ^ PR: 243734 Reported by: garga Submitted by: mikael Approved by: ports-secteam blanket
This commit is contained in:
parent
48d23973bc
commit
c0b2600b4f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/branches/2020Q1/; revision=525995
21
security/nss/files/patch-bug1612177
Normal file
21
security/nss/files/patch-bug1612177
Normal file
@ -0,0 +1,21 @@
|
||||
--- lib/freebl/Makefile.orig 2020-02-07 20:58:46 UTC
|
||||
+++ lib/freebl/Makefile
|
||||
@@ -770,7 +770,7 @@ ifeq ($(CPU_ARCH),arm)
|
||||
# Confusingly, __SOFTFP__ is the name of the define for the softfloat ABI, not for the softfp ABI.
|
||||
USES_SOFTFLOAT_ABI := $(shell $(CC) -o - -E -dM - $(CFLAGS) < /dev/null | grep __SOFTFP__ > /dev/null && echo 1)
|
||||
$(OBJDIR)/$(PROG_PREFIX)aes-armv8$(OBJ_SUFFIX): CFLAGS += -march=armv8-a -mfpu=crypto-neon-fp-armv8$(if $(USES_SOFTFLOAT_ABI), -mfloat-abi=softfp)
|
||||
-$(OBJDIR)/$(PROG_PREFIX)gcm-arm32-neon$(OBJ_SUFFIX): CFLAGS += -mfpu=neon$(if $(USES_SOFTFLOAT_ABI), -mfloat-abi=softfp)
|
||||
+$(OBJDIR)/$(PROG_PREFIX)gcm-arm32-neon$(OBJ_SUFFIX): CFLAGS += -march=armv7-a -mfpu=neon$(if $(USES_SOFTFLOAT_ABI), -mfloat-abi=softfp)
|
||||
endif
|
||||
ifeq ($(CPU_ARCH),aarch64)
|
||||
$(OBJDIR)/$(PROG_PREFIX)aes-armv8$(OBJ_SUFFIX): CFLAGS += -march=armv8-a+crypto
|
||||
--- lib/freebl/freebl.gyp.orig 2020-02-07 20:58:46 UTC
|
||||
+++ lib/freebl/freebl.gyp
|
||||
@@ -158,6 +158,7 @@
|
||||
'<(DEPTH)/exports.gyp:nss_exports'
|
||||
],
|
||||
'cflags': [
|
||||
+ '-march=armv7-a',
|
||||
'-mfpu=neon',
|
||||
'<@(softfp_cflags)',
|
||||
],
|
Loading…
Reference in New Issue
Block a user