Upgrade to 2.14
This commit is contained in:
parent
ff638b131d
commit
c0ae55e1e9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=44882
@ -6,9 +6,10 @@
|
||||
#
|
||||
|
||||
PORTNAME= leafnode+
|
||||
PORTVERSION= 2.12
|
||||
PORTVERSION= 2.14
|
||||
CATEGORIES= news
|
||||
MASTER_SITES= http://www.io.com/~kazushi/leafnode+/
|
||||
MASTER_SITES= http://www.io.com/~kazushi/leafnode+/ \
|
||||
ftp://ftp.io.com/pub/usr/kazushi/leafnode+/
|
||||
|
||||
MAINTAINER= tom@FreeBSD.org
|
||||
|
||||
@ -20,9 +21,9 @@ PLIST= ${PKGDIR}/pkg-plist.nodocs
|
||||
.endif
|
||||
|
||||
LEAFLIBDIR?= ${PREFIX}/lib/leafnode
|
||||
LEAFSPOOLDIR?= /var/spool/leafnode
|
||||
SPOOLDIR?= /var/spool/leafnode
|
||||
REWRITE= ${SED} -e "s:@LIBDIR@:${LEAFLIBDIR}:g" \
|
||||
-e "s:@SPOOLDIR@:${LEAFSPOOLDIR}:g" \
|
||||
-e "s:@SPOOLDIR@:${SPOOLDIR}:g" \
|
||||
-e "s:@PREFIX@:${PREFIX}:g"
|
||||
|
||||
post-patch:
|
||||
|
@ -1 +1 @@
|
||||
MD5 (leafnode+-2.12.tar.gz) = 13f5c42bcb99c1b2dc2af994ee2d5b36
|
||||
MD5 (leafnode+-2.14.tar.gz) = 34f0bb1fe516f4cdc0166c965c77b117
|
||||
|
@ -1,46 +0,0 @@
|
||||
--- Makefile.orig Sun Aug 1 06:23:40 1999
|
||||
+++ Makefile Sun Sep 26 18:18:55 1999
|
||||
@@ -1,12 +1,8 @@
|
||||
# -*- makefile -*-
|
||||
# $Orig-Id: Makefile,v 1.16 1997/07/20 00:28:31 agulbra Exp $
|
||||
-CC = gcc
|
||||
DEBUG = -g -Wall -Wformat -Wstrict-prototypes -Wmissing-prototypes
|
||||
-CFLAGS = $(DEBUG)
|
||||
LIBS =
|
||||
-PREFIX = /usr/local
|
||||
BINDIR = $(PREFIX)/sbin
|
||||
-MANDIR = $(PREFIX)/man
|
||||
VERSION = 2.12
|
||||
#
|
||||
# if you want to use Socks, use following.
|
||||
@@ -29,11 +25,11 @@
|
||||
#RANLIB = ranlib
|
||||
#
|
||||
# this is the directory where the news is stored.
|
||||
-SPOOLDIR = /var/spool/news
|
||||
+SPOOLDIR = @SPOOLDIR@
|
||||
#
|
||||
# this is the directory where the configuration and group information is
|
||||
# kept. It should preferably not be on the same partition as spooldir
|
||||
-LIBDIR = /usr/lib/leafnode
|
||||
+LIBDIR = @LIBDIR@
|
||||
#
|
||||
# local library
|
||||
LIBUTIL = libutil.a
|
||||
@@ -93,7 +89,7 @@
|
||||
@if [ -f $(BINDIR)/fetch ]; then echo don"'"t forget to change the name of a command in scripts and crontab from fetch into fetchnews.; fi
|
||||
@if [ -f $(BINDIR)/newsfetch ]; then echo don"'"t forget to change the name of a command in scripts and crontab from newsfetch into fetchnews.; fi
|
||||
|
||||
-installall: install
|
||||
+installall:
|
||||
-mkdir -p $(SPOOLDIR) $(LIBDIR)
|
||||
-mkdir -p $(SPOOLDIR)/message.id
|
||||
-mkdir -p $(SPOOLDIR)/interesting.groups
|
||||
@@ -105,7 +101,6 @@
|
||||
$${a}$${b}6 $${a}$${b}7 $${a}$${b}8 \
|
||||
$${a}$${b}9 ; \
|
||||
done ; done
|
||||
- cp config.example $(LIBDIR)
|
||||
chown -R news.news $(LIBDIR)/. $(SPOOLDIR)/.
|
||||
chmod 2750 $(SPOOLDIR)
|
||||
@echo edit /etc/inetd.conf to start $(BINDIR)/leafnode
|
47
news/leafnode+/files/patch-ac
Normal file
47
news/leafnode+/files/patch-ac
Normal file
@ -0,0 +1,47 @@
|
||||
--- Makefile.orig Wed Jun 13 10:53:27 2001
|
||||
+++ Makefile Sat Jul 7 08:06:32 2001
|
||||
@@ -11,19 +11,19 @@
|
||||
#AR = ar
|
||||
#RANLIB = ranlib
|
||||
# Programs for distribution.
|
||||
-CP = cp
|
||||
-CHMOD = chmod
|
||||
-CHOWN = chown
|
||||
-GZIP = gzip -f9
|
||||
-MKDIR = mkdir -p
|
||||
-RM = rm -f
|
||||
-SED = sed
|
||||
-TAR = tar
|
||||
+#CP = cp
|
||||
+#CHMOD = chmod
|
||||
+#CHOWN = chown
|
||||
+#GZIP = gzip -f9
|
||||
+#MKDIR = mkdir -p
|
||||
+#RM = rm -f
|
||||
+#SED = sed
|
||||
+#TAR = tar
|
||||
#
|
||||
# You can specify the place programs are installed.
|
||||
-PREFIX = /usr/local
|
||||
-BINDIR = $(PREFIX)/sbin
|
||||
-MANDIR = $(PREFIX)/man
|
||||
+#PREFIX = /usr/local
|
||||
+#BINDIR = $(PREFIX)/sbin
|
||||
+#MANDIR = $(PREFIX)/man
|
||||
#
|
||||
# If you want to build with debugging, use below.
|
||||
#CFLAGS += -g -Wall -Wformat -Wstrict-prototypes -Wmissing-prototypes
|
||||
@@ -68,11 +68,11 @@
|
||||
#LIBS += -L/usr/local/v6/lib -linet6
|
||||
#
|
||||
# This is the directory where the news is stored.
|
||||
-SPOOLDIR = /var/spool/news
|
||||
+#SPOOLDIR = /var/spool/news
|
||||
#
|
||||
# This is the directory where the configuration and group information is
|
||||
# kept. It should preferably not be on the same partition as spooldir
|
||||
-LIBDIR = /usr/lib/leafnode
|
||||
+LIBDIR = LEAFLIBDIR
|
||||
#
|
||||
# These are about local library.
|
||||
LIBUTIL = libutil.a
|
Loading…
Reference in New Issue
Block a user