Update 0.6

PR:		46765
Submitted by:	Jonathan Belson <jon@witchspace.com> (maintainer)
This commit is contained in:
Tilman Keskinoz 2003-01-07 07:01:08 +00:00
parent 020e1848e4
commit c0a1c435a6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=72679
4 changed files with 20 additions and 35 deletions

View File

@ -6,29 +6,22 @@
#
PORTNAME= landscape
PORTVERSION= 0.5.1
PORTREVISION= 2
CATEGORIES= graphics kde
MASTER_SITES= http://www.dookie.demon.co.uk/
PORTVERSION= 0.6
CATEGORIES= graphics kde
MASTER_SITES= http://www.witchspace.com/files/
MAINTAINER= jon@witchspace.com
LIB_DEPENDS= pth.14:${PORTSDIR}/devel/pth
USE_MESA= yes
USE_KDELIBS_VER= 3
QTDIR?= ${X11BASE}
MAKE_ENV= QTDIR="${QTDIR}"
BROKEN= "Author is working on new version. Coming soon."
post-patch:
${PERL} -pi.orig -e \
's,/usr/local,${LOCALBASE},g; \
s,/usr/X11R6,${X11BASE},g' ${WRKSRC}/makefile
pre-build:
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} qmake \
-spec ${X11BASE}/mkspecs/freebsd-g++ landscape.pro
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/landscape ${PREFIX}/bin
post-install:
strip ${PREFIX}/bin/landscape
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (landscape-0.5.1.tar.gz) = 948510f4f00aed0e151107d216787709
MD5 (landscape-0.6.tar.gz) = d2a460acc4833994d42a3f3073313a48

View File

@ -1,19 +0,0 @@
--- makefile.orig Fri Jun 8 03:52:18 2001
+++ makefile Tue Sep 4 08:28:49 2001
@@ -7,13 +7,13 @@
ARCH = freebsd
#ARCH = solaris
-INCLUDEPATH.freebsd = -I/usr/local/include/ -I. -Iutil -Iprefs -Irenderer \
+INCLUDEPATH.freebsd = `pthread-config --cflags` -I/usr/local/include/ -I. -Iutil -Iprefs -Irenderer \
-Iwindows -Iwindows/unix -Ifractal -Itexture -Imain/unix -Imath \
-I/usr/X11R6/include/qt2 -I/usr/X11R6/include
INCLUDEPATH.solaris = -I. -I/usr/local/include/qt2
-LIBRARYPATH = -L/usr/local/lib -L/usr/X11R6/lib -L/usr/compat/linux/lib/
+LIBRARYPATH = `pthread-config --ldflags` -L/usr/local/lib -L/usr/X11R6/lib
-CC = gcc
+#CC = gcc
CPP = gcc
RM = rm -f
MOC = moc2

View File

@ -0,0 +1,11 @@
--- windows/unix/widget_main.ui.orig Tue Jan 7 05:17:48 2003
+++ windows/unix/widget_main.ui Tue Jan 7 05:19:02 2003
@@ -552,7 +552,7 @@
<customwidgets>
<customwidget>
<class>mouse_bm_view</class>
- <header location="global">/home/jon/projects/landscape/windows/unix/mouse_bm_view.h</header>
+ <header location="local">mouse_bm_view.h</header>
<sizehint>
<width>-1</width>
<height>-1</height>