- Update `games/qstat' to version 2.14
- Project had moved from SF to GitHub - Build must be bootstrapped now (USES+=autoreconf) - Define LICENSE (ART20) and install CHANGES.txt - Convert two-line pkg-plist into PLIST_FILES - Remove incomplete list of games from pkg-descr Because GitHub releases (tarballs) are not fetched with correct modification time, set TIMESTAMP to 1393638577 which corresponds to commit 71f0e4c tagged as this release.
This commit is contained in:
parent
aceb14ba8c
commit
c07cff0ac0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=432482
@ -2,18 +2,25 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= qstat
|
||||
PORTVERSION= 2.11
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 2.14
|
||||
DISTVERSIONPREFIX= v
|
||||
CATEGORIES= games net
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
|
||||
|
||||
MAINTAINER= danfe@FreeBSD.org
|
||||
COMMENT= Command-line program to query game servers on the net
|
||||
|
||||
LICENSE= ART20
|
||||
|
||||
CONFLICTS_INSTALL= torque-[0-9]*
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= multiplay
|
||||
|
||||
USES= autoreconf
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
PLIST_FILES= bin/qstat \
|
||||
@sample\ etc/qstat.cfg.sample
|
||||
PORTDOCS= *
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
@ -22,12 +29,13 @@ post-extract:
|
||||
@${MV} ${WRKSRC}/qstat.cfg ${WRKSRC}/qstat.cfg.sample
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|qstat\.cfg|&.sample|' ${WRKSRC}/Makefile.in
|
||||
@${REINPLACE_CMD} -e 's|qstat\.cfg|&.sample|' ${WRKSRC}/Makefile.am
|
||||
@${REINPLACE_CMD} -e 's|OpenBSD|${OPSYS}|' ${WRKSRC}/qstat.c
|
||||
|
||||
post-install:
|
||||
do-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}/info ${STAGEDIR}${DOCSDIR}/template
|
||||
${INSTALL_DATA} ${WRKSRC}/qstatdoc.html ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/CHANGES.txt ${WRKSRC}/qstatdoc.html \
|
||||
${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/template/*.html ${WRKSRC}/template/*.txt \
|
||||
${STAGEDIR}${DOCSDIR}/template
|
||||
${INSTALL_DATA} ${WRKSRC}/info/*.txt ${STAGEDIR}${DOCSDIR}/info
|
||||
|
@ -1,2 +1,3 @@
|
||||
SHA256 (qstat-2.11.tar.gz) = 16f0c0f55567597d7f2db5136a0858c56effb4481a2c821a48cd0432ea572150
|
||||
SIZE (qstat-2.11.tar.gz) = 258335
|
||||
TIMESTAMP = 1393638577
|
||||
SHA256 (multiplay-qstat-v2.14_GH0.tar.gz) = ae906b74d4cce8057b5a265b76859101da8104c2a07c05f11a51f7c9f033ef8b
|
||||
SIZE (multiplay-qstat-v2.14_GH0.tar.gz) = 210440
|
||||
|
@ -1,11 +1,18 @@
|
||||
--- config.c.orig Fri Nov 8 19:06:04 2002
|
||||
+++ config.c Fri Feb 14 13:07:09 2003
|
||||
@@ -204,7 +204,7 @@
|
||||
filename= getenv( "HOME");
|
||||
if ( filename != NULL && filename[0] != '\0') {
|
||||
char path[1024];
|
||||
- sprintf( path, "%s/%s", filename, HOME_CONFIG_FILE);
|
||||
--- config.c.orig 2014-03-01 01:49:37 UTC
|
||||
+++ config.c
|
||||
@@ -192,14 +192,7 @@ qsc_load_default_config_files()
|
||||
|
||||
var= getenv( "HOME");
|
||||
if ( var != NULL && var[0] != '\0') {
|
||||
- int len= strlen(var);
|
||||
- if ( len > 900)
|
||||
- len= 900;
|
||||
- strncpy( path, var, len);
|
||||
- path[len]= '\0';
|
||||
- strcat( path, "/");
|
||||
- strcat( path, HOME_CONFIG_FILE);
|
||||
-/* sprintf( path, "%s/%s", var, HOME_CONFIG_FILE); */
|
||||
+ snprintf( path, sizeof(path), "%s/%s", var, HOME_CONFIG_FILE);
|
||||
}
|
||||
/* 1. $QSTAT_CONFIG
|
||||
2. UNIX: $HOME/.qstatrc WIN: $HOME/qstat.cfg
|
||||
rc= try_load_config_file( path, 0);
|
||||
if ( rc == 0 || rc == -1)
|
||||
return rc;
|
||||
|
@ -1,10 +0,0 @@
|
||||
--- doom3.c.orig Sat Dec 17 14:14:38 2005
|
||||
+++ doom3.c Sat Dec 17 14:14:49 2005
|
||||
@@ -11,6 +11,7 @@
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#ifndef _WIN32
|
||||
+#include <sys/types.h>
|
||||
#include <sys/socket.h>
|
||||
#endif
|
||||
|
@ -4,18 +4,6 @@ running a game. For servers running a game, the server name, map name,
|
||||
current number of players, and response time are displayed. Server rules
|
||||
and player information may also be displayed. It can output templates for
|
||||
automatic HTML generation, and also has raw display mode for integration
|
||||
with custom server browsers. Incomplete list of supported games includes:
|
||||
with custom server browsers.
|
||||
|
||||
- old Quake (NetQuake)
|
||||
- QuakeWorld
|
||||
- Hexen II
|
||||
- HexenWorld
|
||||
- Quake II
|
||||
- Unreal
|
||||
- Half-Life 2
|
||||
- Half-Life
|
||||
- Doom III
|
||||
- Warsow
|
||||
- Tremulous
|
||||
|
||||
WWW: http://www.qstat.org/
|
||||
WWW: https://github.com/multiplay/qstat
|
||||
|
@ -1,2 +0,0 @@
|
||||
bin/qstat
|
||||
@sample etc/qstat.cfg.sample
|
Loading…
Reference in New Issue
Block a user