- remove IGNORE on old perl

Submitted by:	leeym
Approved by:	maintainer via email
This commit is contained in:
Yen-Ming Lee 2005-12-30 20:38:46 +00:00
parent 29e56c9935
commit c06da79cfb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=152445
18 changed files with 135 additions and 52 deletions

View File

@ -18,7 +18,11 @@ PERL_CONFIGURE= yes
MAN3= Crypt::AppleTwoFish.3 MAN3= Crypt::AppleTwoFish.3
.include <bsd.port.pre.mk> .include <bsd.port.pre.mk>
.if ${PERL_LEVEL} <= 500503
IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again .if ${PERL_LEVEL} < 500800
post-patch:
${PERL} -pi -e '$$_="" if m{5.008|warnings}' ${WRKSRC}/t/*.t \
${WRKSRC}/lib/Crypt/AppleTwoFish.pm ${WRKSRC}/${CONFIGURE_SCRIPT}
.endif .endif
.include <bsd.port.post.mk> .include <bsd.port.post.mk>

View File

@ -17,8 +17,4 @@ PERL_CONFIGURE= yes
MAN3= Crypt::CFB.3 MAN3= Crypt::CFB.3
.include <bsd.port.pre.mk> .include <bsd.port.mk>
.if ${PERL_LEVEL} <= 500503
IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
.endif
.include <bsd.port.post.mk>

View File

@ -17,8 +17,4 @@ PERL_CONFIGURE= yes
MAN3= Crypt::Caesar.3 MAN3= Crypt::Caesar.3
.include <bsd.port.pre.mk> .include <bsd.port.mk>
.if ${PERL_LEVEL} <= 500503
IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
.endif
.include <bsd.port.post.mk>

View File

@ -17,8 +17,4 @@ PERL_CONFIGURE= yes
MAN3= Crypt::Chimera.3 MAN3= Crypt::Chimera.3
.include <bsd.port.pre.mk> .include <bsd.port.mk>
.if ${PERL_LEVEL} <= 500503
IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
.endif
.include <bsd.port.post.mk>

View File

@ -17,8 +17,4 @@ PERL_CONFIGURE= yes
MAN3= Crypt::DES_PP.3 MAN3= Crypt::DES_PP.3
.include <bsd.port.pre.mk> .include <bsd.port.mk>
.if ${PERL_LEVEL} <= 500503
IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
.endif
.include <bsd.port.post.mk>

View File

@ -17,8 +17,4 @@ PERL_CONFIGURE= yes
MAN3= Crypt::Enigma.3 MAN3= Crypt::Enigma.3
.include <bsd.port.pre.mk> .include <bsd.port.mk>
.if ${PERL_LEVEL} <= 500503
IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
.endif
.include <bsd.port.post.mk>

View File

@ -17,8 +17,4 @@ PERL_CONFIGURE= yes
MAN3= Crypt::GOST_PP.3 MAN3= Crypt::GOST_PP.3
.include <bsd.port.pre.mk> .include <bsd.port.mk>
.if ${PERL_LEVEL} <= 500503
IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
.endif
.include <bsd.port.post.mk>

View File

@ -17,8 +17,4 @@ PERL_CONFIGURE= yes
MAN3= Crypt::HCE_MD5.3 MAN3= Crypt::HCE_MD5.3
.include <bsd.port.pre.mk> .include <bsd.port.mk>
.if ${PERL_LEVEL} <= 500503
IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
.endif
.include <bsd.port.post.mk>

View File

@ -18,7 +18,16 @@ PERL_CONFIGURE= yes
MAN3= Crypt::Khazad.3 MAN3= Crypt::Khazad.3
.include <bsd.port.pre.mk> .include <bsd.port.pre.mk>
.if ${PERL_LEVEL} <= 500503
IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again .if ${PERL_LEVEL} < 500600
BUILD_DEPENDS+= ${SITE_PERL}/XSLoader.pm:${PORTSDIR}/devel/p5-XSLoader
RUN_DEPENDS+= ${SITE_PERL}/XSLoader.pm:${PORTSDIR}/devel/p5-XSLoader
EXTRA_PATCHES+= ${PATCHDIR}/extrapatch-Khazad.xs
post-patch:
${PERL} -pi -e 's/^our\s+([\$$\@\%]\w+)/use vars qw($$1); $$1/;' ${WRKSRC}/Khazad.pm
${PERL} -pi -e '$$_="" if m{warnings}' ${WRKSRC}/Khazad.pm ${WRKSRC}/t/*.t
${PERL} -pi -e 's/void/int argc, char**argv, char**env/ if m{int main}' ${WRKSRC}/_khazad.c
.endif .endif
.include <bsd.port.post.mk> .include <bsd.port.post.mk>

View File

@ -0,0 +1,18 @@
--- Khazad.xs.orig Sat Dec 31 02:51:21 2005
+++ Khazad.xs Sat Dec 31 02:51:56 2005
@@ -4,6 +4,15 @@
#include "ppport.h"
#include "_khazad.c"
+/* try to be compatible with older perls */
+/* SvPV_nolen() macro first defined in 5.005_55 */
+/* this is slow, not threadsafe, but works */
+#include "patchlevel.h"
+#if (PATCHLEVEL == 4) || ((PATCHLEVEL == 5) && (SUBVERSION < 55))
+static STRLEN nolen_na;
+# define SvPV_nolen(sv) SvPV ((sv), nolen_na)
+#endif
+
typedef struct khazad {
NESSIEstruct key;
}* Crypt__Khazad;

View File

@ -18,7 +18,16 @@ PERL_CONFIGURE= yes
MAN3= Crypt::Loki97.3 MAN3= Crypt::Loki97.3
.include <bsd.port.pre.mk> .include <bsd.port.pre.mk>
.if ${PERL_LEVEL} <= 500503
IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again .if ${PERL_LEVEL} < 500600
BUILD_DEPENDS+= ${SITE_PERL}/XSLoader.pm:${PORTSDIR}/devel/p5-XSLoader
RUN_DEPENDS+= ${SITE_PERL}/XSLoader.pm:${PORTSDIR}/devel/p5-XSLoader
EXTRA_PATCHES+= ${PATCHDIR}/extrapatch-Loki97.xs
post-patch:
${PERL} -pi -e 's/^our\s+([\$$\@\%]\w+)/use vars qw($$1); $$1/;' ${WRKSRC}/Loki97.pm
${PERL} -pi -e 's/void/int argc, char**argv, char**env/ if m{int main}' ${WRKSRC}/_loki97.c
${PERL} -pi -e '$$_="" if m{warnings}' ${WRKSRC}/Loki97.pm ${WRKSRC}/t/*.t
.endif .endif
.include <bsd.port.post.mk> .include <bsd.port.post.mk>

View File

@ -0,0 +1,18 @@
--- Loki97.xs.orig Sat Dec 31 03:04:38 2005
+++ Loki97.xs Sat Dec 31 03:05:06 2005
@@ -4,6 +4,15 @@
#include "ppport.h"
#include "_loki97.c"
+/* try to be compatible with older perls */
+/* SvPV_nolen() macro first defined in 5.005_55 */
+/* this is slow, not threadsafe, but works */
+#include "patchlevel.h"
+#if (PATCHLEVEL == 4) || ((PATCHLEVEL == 5) && (SUBVERSION < 55))
+static STRLEN nolen_na;
+# define SvPV_nolen(sv) SvPV ((sv), nolen_na)
+#endif
+
typedef struct loki97 {
keyInstance enc_key, dec_key;
cipherInstance cipher;

View File

@ -17,8 +17,4 @@ PERL_CONFIGURE= yes
MAN3= Crypt::MySQL.3 MAN3= Crypt::MySQL.3
.include <bsd.port.pre.mk> .include <bsd.port.mk>
.if ${PERL_LEVEL} <= 500503
IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
.endif
.include <bsd.port.post.mk>

View File

@ -18,7 +18,15 @@ PERL_CONFIGURE= yes
MAN3= Crypt::Rabbit.3 MAN3= Crypt::Rabbit.3
.include <bsd.port.pre.mk> .include <bsd.port.pre.mk>
.if ${PERL_LEVEL} <= 500503
IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again .if ${PERL_LEVEL} < 500600
BUILD_DEPENDS+= ${SITE_PERL}/XSLoader.pm:${PORTSDIR}/devel/p5-XSLoader
RUN_DEPENDS+= ${SITE_PERL}/XSLoader.pm:${PORTSDIR}/devel/p5-XSLoader
EXTRA_PATCHES+= ${PATCHDIR}/extrapatch-Rabbit.xs
post-patch:
${PERL} -pi -e 's/^our\s+([\$$\@\%]\w+)/use vars qw($$1); $$1/;' ${WRKSRC}/Rabbit.pm
${PERL} -pi -e '$$_="" if m{warnings}' ${WRKSRC}/Rabbit.pm ${WRKSRC}/t/*.t
.endif .endif
.include <bsd.port.post.mk> .include <bsd.port.post.mk>

View File

@ -0,0 +1,18 @@
--- Rabbit.xs.orig Sat Dec 31 03:49:51 2005
+++ Rabbit.xs Sat Dec 31 03:50:13 2005
@@ -4,6 +4,15 @@
#include "ppport.h"
#include "_rabbit.c"
+/* try to be compatible with older perls */
+/* SvPV_nolen() macro first defined in 5.005_55 */
+/* this is slow, not threadsafe, but works */
+#include "patchlevel.h"
+#if (PATCHLEVEL == 4) || ((PATCHLEVEL == 5) && (SUBVERSION < 55))
+static STRLEN nolen_na;
+# define SvPV_nolen(sv) SvPV ((sv), nolen_na)
+#endif
+
typedef struct rabbit {
t_instance state;
}* Crypt__Rabbit;

View File

@ -18,7 +18,16 @@ PERL_CONFIGURE= yes
MAN3= Crypt::Shark.3 MAN3= Crypt::Shark.3
.include <bsd.port.pre.mk> .include <bsd.port.pre.mk>
.if ${PERL_LEVEL} <= 500503
IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again .if ${PERL_LEVEL} < 500600
BUILD_DEPENDS+= ${SITE_PERL}/XSLoader.pm:${PORTSDIR}/devel/p5-XSLoader
RUN_DEPENDS+= ${SITE_PERL}/XSLoader.pm:${PORTSDIR}/devel/p5-XSLoader
EXTRA_PATCHES+= ${PATCHDIR}/extrapatch-Shark.xs
post-patch:
${PERL} -pi -e 's/^our\s+([\$$\@\%]\w+)/use vars qw($$1); $$1/;' ${WRKSRC}/Shark.pm
${PERL} -pi -e 's/void/int argc, char**argv, char**env/ if m{int main}' ${WRKSRC}/_shark.c
${PERL} -pi -e '$$_="" if m{warnings}' ${WRKSRC}/Shark.pm ${WRKSRC}/t/*.t
.endif .endif
.include <bsd.port.post.mk> .include <bsd.port.post.mk>

View File

@ -0,0 +1,18 @@
--- Shark.xs.orig Sat Dec 31 04:10:06 2005
+++ Shark.xs Sat Dec 31 04:10:37 2005
@@ -4,6 +4,15 @@
#include "ppport.h"
#include "_shark.c"
+/* try to be compatible with older perls */
+/* SvPV_nolen() macro first defined in 5.005_55 */
+/* this is slow, not threadsafe, but works */
+#include "patchlevel.h"
+#if (PATCHLEVEL == 4) || ((PATCHLEVEL == 5) && (SUBVERSION < 55))
+static STRLEN nolen_na;
+# define SvPV_nolen(sv) SvPV ((sv), nolen_na)
+#endif
+
typedef struct shark {
ddword roundkey_enc[14];
ddword roundkey_dec[14];

View File

@ -22,7 +22,11 @@ MAN3= Crypt::X509.3
WRKSRC= ${WRKDIR}/Crypt-X509 WRKSRC= ${WRKDIR}/Crypt-X509
.include <bsd.port.pre.mk> .include <bsd.port.pre.mk>
.if ${PERL_LEVEL} <= 500503
IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again .if ${PERL_LEVEL} < 500600
post-patch:
${PERL} -pi -e 's/^our\s+([\$$\@\%]\w+)/use vars qw($$1); $$1/;' ${WRKSRC}/lib/Crypt/X509.pm
${PERL} -pi -e '$$_="" if m{warnings}' ${WRKSRC}/lib/Crypt/X509.pm
.endif .endif
.include <bsd.port.post.mk> .include <bsd.port.post.mk>