- Remove unnecessary hostname -s.

- Update WWW: in pkg-descr.
- Style clean-ups.
This commit is contained in:
Hiroki Sato 2016-12-30 13:09:29 +00:00
parent f71f4cb959
commit c05ab09e69
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=429978
4 changed files with 20 additions and 26 deletions

View File

@ -7,19 +7,17 @@ PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= http://hyperelliptic.org/nacl/
MAINTAINER= ports@FreeBSD.org
MAINTAINER= hrs@FreeBSD.org
COMMENT= High speed cryptography library
LICENSE= PD
USES= tar:bzip2
ALL_TARGET= do
USE_BINUTILS= yes
MAKE_JOBS_UNSAFE= yes
ONLY_FOR_ARCHS= i386 amd64
HOSTNAME_CMD?= /bin/hostname -s
MYARCH= ${ARCH:S/i386/x86/}
post-patch:
@ -29,24 +27,20 @@ post-patch:
pre-build:
${RM} -r ${WRKSRC}/crypto_onetimeauth/poly1305/amd64
do-build:
cd ${WRKSRC} && ./do
.include <bsd.port.pre.mk>
${PRINTF} "%s\n\t%s\n" "all:" "${SH} ./do" > ${WRKSRC}/Makefile
post-build:
${AR} -r ${WRKSRC}/build/`${HOSTNAME_CMD}`/lib/${MYARCH}/libnacl.a \
${WRKSRC}/build/`${HOSTNAME_CMD}`/lib/${MYARCH}/randombytes.o
${AR} -r ${WRKSRC}/build/HOSTNAME/lib/${MYARCH}/libnacl.a \
${WRKSRC}/build/HOSTNAME/lib/${MYARCH}/randombytes.o
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/build/`${HOSTNAME_CMD} -s`/bin/nacl-sha256 \
${STAGEDIR}${PREFIX}/bin
@${INSTALL_PROGRAM} ${WRKSRC}/build/`${HOSTNAME_CMD} -s`/bin/nacl-sha512 \
${STAGEDIR}${PREFIX}/bin
@${INSTALL_DATA} ${WRKSRC}/build/`${HOSTNAME_CMD}`/lib/${MYARCH}/* \
${STAGEDIR}${PREFIX}/lib
@${INSTALL_DATA} ${WRKSRC}/build/`${HOSTNAME_CMD}`/include/${MYARCH}/* \
${STAGEDIR}${PREFIX}/include
${INSTALL_PROGRAM} ${WRKSRC}/build/HOSTNAME/bin/nacl-sha256 \
${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/build/HOSTNAME/bin/nacl-sha512 \
${STAGEDIR}${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/build/HOSTNAME/lib/${MYARCH}/* \
${STAGEDIR}${PREFIX}/lib
${INSTALL_DATA} ${WRKSRC}/build/HOSTNAME/include/${MYARCH}/* \
${STAGEDIR}${PREFIX}/include
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,5 +1,5 @@
--- curvecp/socket_udp.c.orig 2014-01-29 15:34:07.000000000 -0800
+++ curvecp/socket_udp.c 2014-01-29 15:34:12.000000000 -0800
--- curvecp/socket_udp.c.orig 2011-02-21 01:49:34 UTC
+++ curvecp/socket_udp.c
@@ -6,6 +6,10 @@
#include "socket.h"
#include "blocking.h"

View File

@ -1,15 +1,15 @@
--- do.orig 2011-02-20 17:49:34.000000000 -0800
+++ do 2012-03-20 16:49:10.324256193 -0700
--- do.orig 2011-02-21 01:49:34 UTC
+++ do
@@ -6,7 +6,7 @@
version=`cat version`
project=nacl
-shorthostname=`hostname | sed 's/\..*//' | tr -cd '[a-z][A-Z][0-9]'`
+shorthostname=`hostname -s`
+shorthostname=HOSTNAME
top="`pwd`/build/$shorthostname"
bin="$top/bin"
@@ -38,8 +38,8 @@
@@ -38,8 +38,8 @@ mkdir -p "$bin"
mkdir -p "$lib"
mkdir -p "$include"

View File

@ -7,4 +7,4 @@ Of course, other libraries already exist for these core operations.
NaCl advances the state of the art by improving security, by improving
usability, and by improving speed.
WWW: http://nacl.cace-project.eu/
WWW: https://nacl.cr.yp.to/