math/curv: Fix the patch: remove unintended characters, remove -g
This commit is contained in:
parent
e721b925ab
commit
c04cb844b8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=501277
@ -1,6 +1,12 @@
|
||||
--- CMakeLists.txt.orig 2019-05-11 14:42:40 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -15,12 +15,10 @@ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS}
|
||||
@@ -10,18 +10,14 @@ execute_process(COMMAND sh -c "${CMAKE_S
|
||||
|
||||
list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake")
|
||||
|
||||
-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -g")
|
||||
+#set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -g")
|
||||
|
||||
# Global include directories, visible in subdirectories.
|
||||
include_directories(.
|
||||
extern/googletest/googletest/include
|
||||
@ -10,11 +16,11 @@
|
||||
extern/blosc
|
||||
extern/stb
|
||||
- extern/glfw/include
|
||||
+ extern/gglfwglfwlfw/include
|
||||
extern/glm
|
||||
- extern/glm
|
||||
extern/glad)
|
||||
|
||||
@@ -30,19 +28,6 @@ if (APPLE)
|
||||
if (APPLE)
|
||||
@@ -30,19 +26,6 @@ if (APPLE)
|
||||
link_directories(/usr/local/lib)
|
||||
endif (APPLE)
|
||||
|
||||
@ -34,7 +40,7 @@
|
||||
# glad library, an OpenGL loader
|
||||
add_library(glad
|
||||
extern/glad/glad/glad.c)
|
||||
@@ -93,7 +78,7 @@ target_link_libraries(libcurv_geom PUBLI
|
||||
@@ -93,7 +76,7 @@ target_link_libraries(libcurv_geom PUBLI
|
||||
|
||||
file(GLOB Src "curv/*.c" "curv/*.cc")
|
||||
add_executable(curv ${Src})
|
||||
@ -43,7 +49,7 @@
|
||||
|
||||
file(GLOB CurvcSrc "curvc/*.cc")
|
||||
add_executable(curvc EXCLUDE_FROM_ALL ${CurvcSrc})
|
||||
@@ -128,5 +113,3 @@ if (NOT TARGET uninstall)
|
||||
@@ -128,5 +111,3 @@ if (NOT TARGET uninstall)
|
||||
endif()
|
||||
|
||||
add_subdirectory(extern/googletest/googletest EXCLUDE_FROM_ALL)
|
||||
|
Loading…
Reference in New Issue
Block a user