audio/beatslash-lv2: Fix build on some systems

Waf warning about duplicately-installed files somehow caused failure to find some files later.
This commit adds the patch to prevent duplicate file installation. This fixes the warning and hopefully fixes poudriere build.
I couldn't reproduce this failure in my poudriere.

Also:
* Strip binarires
* Fix WWW

MFH:		2020Q3
This commit is contained in:
Yuri Victorovich 2020-09-22 00:11:36 +00:00
parent 8f45229004
commit c02b2339f5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=549539
3 changed files with 15 additions and 3 deletions

View File

@ -3,7 +3,7 @@
PORTNAME= beatslash
DISTVERSIONPREFIX= v
DISTVERSION= 1.0.6
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= audio
PKGNAMESUFFIX= -lv2
@ -29,4 +29,7 @@ USE_GNOME= atkmm gdkpixbuf2 gtkmm24
post-patch:
@${REINPLACE_CMD} -e 's|#include <lvtk-1/lvtk|#include <lvtk-2/lvtk|' ${WRKSRC}/src/*.?pp
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lv2/beatslash.lv2/*.so
.include <bsd.port.mk>

View File

@ -1,4 +1,4 @@
--- wscript.orig 2016-11-06 20:24:40 UTC
--- wscript.orig 2019-02-23 21:03:41 UTC
+++ wscript
@@ -31,9 +31,9 @@ def configure(conf):
autowaf.check_pkg(conf, 'gtk+-2.0', uselib_store='GTK2', atleast_version='2.24.0')
@ -13,3 +13,12 @@
check = 'Extended Initializer Lists'
conf.check_cxx(msg = check,
@@ -78,7 +78,7 @@ def build_plugin(bld, bundle, name, source, cxxflags=[
# Install data file
data_file = '%s.ttl' % name
- bld.install_files('${LV2DIR}/' + bundle, os.path.join(bundle, data_file))
+ #bld.install_files('${LV2DIR}/' + bundle, os.path.join(bundle, data_file)) # see https://github.com/blablack/beatslash-lv2/issues/9
def build_plugin_gui(bld, bundle, name, source, cxxflags=[], libs=[], add_source=[]):

View File

@ -4,4 +4,4 @@ Features:
* the beat repeater will repeat the current beat
* the beat slicer will randomly repeat parts of a live sample
WWW: https://objectivewave.wordpress.com/beatslash-lv2/
WWW: https://github.com/blablack/beatslash-lv2