Update quassel to 0.3.1
Approved by: miwi (mentor)
This commit is contained in:
parent
c099059d8f
commit
c0264b1806
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=224537
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= quassel
|
||||
DISTVERSION= 0.3.0.3
|
||||
DISTVERSION= 0.3.1
|
||||
CATEGORIES= irc
|
||||
MASTER_SITES= http://www.quassel-irc.org/pub/
|
||||
|
||||
@ -35,8 +35,12 @@ CMAKE_ARGS+= -DWANT_MONO=${QUASSEL_MONO} \
|
||||
IGNORE= needs at least one Quassel component. Please, rerun 'make config'
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_NLS)
|
||||
QT_COMPONENTS+= linguist_build
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_MONO)
|
||||
QT_COMPONENTS+= dbus gui network script sql xml
|
||||
QT_COMPONENTS+= dbus gui network script sql xml webkit
|
||||
QUASSEL_MONO= ON
|
||||
PLIST_SUB+= MONO=""
|
||||
.else
|
||||
@ -54,7 +58,7 @@ PLIST_SUB+= CORE="@comment "
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_CLIENT)
|
||||
QT_COMPONENTS+= dbus gui network xml
|
||||
QT_COMPONENTS+= dbus gui network xml webkit
|
||||
QUASSEL_CLIENT= ON
|
||||
PLIST_SUB+= CLIENT=""
|
||||
.else
|
||||
@ -62,4 +66,10 @@ QUASSEL_CLIENT= OFF
|
||||
PLIST_SUB+= CLIENT="@comment "
|
||||
.endif
|
||||
|
||||
pre-configure:
|
||||
.if defined(WITHOUT_NLS)
|
||||
${REINPLACE_CMD} -e '/add_subdirectory(i18n)/d' \
|
||||
${WRKSRC}/CMakeLists.txt
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
MD5 (quassel-0.3.0.3.tar.bz2) = d1fc1ff14748e89cc5d8be7539a09e20
|
||||
SHA256 (quassel-0.3.0.3.tar.bz2) = 78d164d85ce695c3c3cacc2197d95bf8aeca3e6af3e7f450b6960e44ab632049
|
||||
SIZE (quassel-0.3.0.3.tar.bz2) = 1971668
|
||||
MD5 (quassel-0.3.1.tar.bz2) = c75fdc99e5d296a2b7db3b58994c501b
|
||||
SHA256 (quassel-0.3.1.tar.bz2) = dd00edc2d600e939776c5092ac4f6d68706a97a133322fb46e08defbd39affda
|
||||
SIZE (quassel-0.3.1.tar.bz2) = 2237851
|
||||
|
@ -1,13 +1,29 @@
|
||||
--- ./CMakeLists.txt.orig 2008-09-02 03:12:37.000000000 +0400
|
||||
+++ ./CMakeLists.txt 2008-09-07 16:16:33.000000000 +0400
|
||||
@@ -188,8 +188,8 @@
|
||||
add_dependencies(mod_common genversion_run)
|
||||
--- ./CMakeLists.txt.orig 2008-11-20 17:08:21.000000000 +0300
|
||||
+++ ./CMakeLists.txt 2008-12-18 01:10:56.000000000 +0300
|
||||
@@ -8,7 +8,7 @@
|
||||
# -DOXYGEN_ICONS=(Builtin|External) : If "Builtin" (the default), compile our Oxygen Icon Theme subset into the binary
|
||||
# : If "External", we assume Oxygen is already installed on the system
|
||||
# -DQUASSEL_ICONS=(Builtin|External) : If "Builtin" (the default), put our own icons into the binary
|
||||
-# : If "External", we install our icons into $PREFIX/share/apps/quassel (UNIX only)
|
||||
+# : If "External", we install our icons into $PREFIX/share/quassel (UNIX only)
|
||||
# -DQT=/path/to/qt : Choose a Qt4 installation to use instead of the system Qt4
|
||||
# -DSTATIC=ON : Enable static building of Quassel. Use with care.
|
||||
# -DDEPLOY=ON : Mac OS X only. Use only for creating Quassel Packages!
|
||||
@@ -58,7 +58,7 @@
|
||||
|
||||
# Generate binary translation files
|
||||
-include(QuasselGenerateTranslations)
|
||||
-quassel_generate_i18n_resource(RC_I18N ${LINGUAS})
|
||||
+# include(QuasselGenerateTranslations)
|
||||
+# quassel_generate_i18n_resource(RC_I18N ${LINGUAS})
|
||||
# Define install locations. Using variables will allow overriding this by the KDE macros later.
|
||||
set(BIN_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/bin)
|
||||
-set(DATA_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/share/apps)
|
||||
+set(DATA_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/share)
|
||||
set(ICON_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/share/icons)
|
||||
set(XDG_APPS_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/share/applications)
|
||||
|
||||
# Add resources
|
||||
qt4_add_resources(RC_ICONS src/icons/icons.qrc)
|
||||
@@ -193,7 +193,7 @@
|
||||
# Decide what to do with icons
|
||||
if(WANT_QTCLIENT OR WANT_MONO)
|
||||
if(QUASSEL_ICONS MATCHES "External")
|
||||
- message(STATUS "Install Quassel icons to ${CMAKE_INSTALL_PREFIX}/share/apps/quassel")
|
||||
+ message(STATUS "Install Quassel icons to ${CMAKE_INSTALL_PREFIX}/share/quassel")
|
||||
else(QUASSEL_ICONS MATCHES "External")
|
||||
set(QUASSEL_ICONS "Builtin")
|
||||
message(STATUS "Compile Quassel icons into the binary")
|
||||
|
@ -3,4 +3,9 @@
|
||||
%%CORE%%bin/quasselcore
|
||||
%%MONO%%share/applications/quassel.desktop
|
||||
%%CLIENT%%share/applications/quasselclient.desktop
|
||||
share/icons/hicolor/48x48/apps/quassel.png
|
||||
@dirrmtry share/icons/hicolor/48x48/apps
|
||||
@dirrmtry share/icons/hicolor/48x48
|
||||
@dirrmtry share/icons/hicolor
|
||||
@dirrmtry share/icons
|
||||
@dirrmtry share/applications
|
||||
|
Loading…
Reference in New Issue
Block a user