security/xmlsec1: Fix build with LibreSSL

- Fix build with LibreSSL
  - USE_OPENSSL -> USES= ssl

PR:		213301
Submitted by:	grembo
Reported by:	grembo
Approved by:	ssl blanket
This commit is contained in:
Bernard Spil 2016-10-08 11:21:02 +00:00
parent 96b53bd85b
commit bff4eaa777
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=423502
2 changed files with 33 additions and 2 deletions

View File

@ -25,8 +25,7 @@ NSS_LIB_DEPENDS= libnss3.so:security/nss
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USES= libtool pathfix pkgconfig
USE_OPENSSL= yes
USES= libtool pathfix pkgconfig ssl
USE_GNOME= libxml2 libxslt
USE_LDCONFIG= yes

View File

@ -0,0 +1,32 @@
https://github.com/lsh123/xmlsec/pull/45
- LibreSSL:
* defines OPENSSL_VERSION_NUMBER as 0x20000000L
* deFines LIBRESS_VERSION_NUMBER in opensslv.h
* was forked from 1.0.1f / 0x1000107fL
PR: https://bugs.freebsd.org/213301
Reported by: Michael Gmelin <grembo@freebsd.org>
--- configure.ac.orig 2016-04-20 16:26:22 UTC
+++ configure.ac
@@ -495,7 +495,7 @@ if test "z$OPENSSL_FOUND" = "zyes" -a "z
if test "z$OPENSSL_VERSION" = "z" ; then
AC_EGREP_CPP(yes,[
#include <openssl/opensslv.h>
- #if OPENSSL_VERSION_NUMBER >= 0x10100000L
+ #if OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER)
yes
#endif
],[
--- configure.orig 2016-10-08 10:49:21 UTC
+++ configure
@@ -14258,7 +14258,7 @@ $as_echo_n "checking for openssl librari
/* end confdefs.h. */
#include <openssl/opensslv.h>
- #if OPENSSL_VERSION_NUMBER >= 0x10100000L
+ #if OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER)
yes
#endif