Firetray is a system tray add-on for firefox.

WWW: http://code.google.com/p/firetray/

PR:		ports/150048
Submitted by:	Andriy Gapon <avg at icyb dot net dot ua>
Approved by:	beat (co-mentor)
This commit is contained in:
Bernhard Froehlich 2010-09-06 08:28:59 +00:00
parent 39f6f921ef
commit bfa804e89e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=260633
5 changed files with 77 additions and 0 deletions

View File

@ -151,6 +151,7 @@
SUBDIR += filtermail
SUBDIR += firemime
SUBDIR += firepay
SUBDIR += firetray
SUBDIR += freepops
SUBDIR += ftrack
SUBDIR += gambas2-gb-net-smtp

50
mail/firetray/Makefile Normal file
View File

@ -0,0 +1,50 @@
# New ports collection makefile for: firetray
# Date created: 2010-08-27
# Whom: Andriy Gapon <avg@icyb.net.ua>
#
# $FreeBSD$
#
PORTNAME= firetray
DISTVERSION= 0.2.8
CATEGORIES= mail www
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
DISTNAME= ${PORTNAME}-${DISTVERSION}-src
MAINTAINER= avg@icyb.net.ua
COMMENT= System tray add-on for firefox, thunderbird, seamonkey, etc
PATCH_DEPENDS= nspr>=4.8:${PORTSDIR}/devel/nspr \
pkg-config:${PORTSDIR}/devel/pkg-config
USE_ZIP= yes
USE_GECKO= libxul
USE_SCONS= yes
USE_GNOME= pkgconfig
WRKSRC= ${WRKDIR}/${PORTNAME}
EXTRACT_AFTER_ARGS= -d ${WRKSRC}
GECKO_CONFIG= ${LOCALBASE}/bin/pkg-config ${GECKO}
BUILD_SH_FLAGS= --dynamic-linking \
--gecko-sdk-bin=`${DIRNAME} ${XPIDL}` \
--gecko-sdk-lib=`${GECKO_CONFIG} --variable=sdkdir`/lib \
--gecko-sdk-idl=`${GECKO_CONFIG} --variable=idldir` \
--gecko-sdk-include=`${GECKO_CONFIG} --variable=includedir`
NSPR_INCLUDE= `${LOCALBASE}/bin/pkg-config nspr --variable=includedir`
PLIST_DIRS= ${DATADIR:S,${PREFIX}/,,}
PLIST_FILES= ${DATADIR:S,${PREFIX}/,,}/${PORTNAME}.xpi
post-patch:
@${REINPLACE_CMD} s,/usr/include/nspr,${NSPR_INCLUDE}, \
${WRKSRC}/components/SConscript
do-build:
cd ${WRKSRC} && ./build.sh ${BUILD_SH_FLAGS}
do-install:
${MKDIR} ${DATADIR} && \
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.xpi ${DATADIR}
.include <bsd.port.mk>

3
mail/firetray/distinfo Normal file
View File

@ -0,0 +1,3 @@
MD5 (firetray-0.2.8-src.zip) = cd71b82da69c8a626d1ac471b268a4fd
SHA256 (firetray-0.2.8-src.zip) = bfe78b722b5946320f2f0b92475a44bc20ff00adc9acaf99d924a4395e2db1f6
SIZE (firetray-0.2.8-src.zip) = 263602

View File

@ -0,0 +1,20 @@
--- components/SConscript.orig 2010-08-27 01:55:51.642176846 +0300
+++ components/SConscript 2010-08-27 02:00:10.042030350 +0300
@@ -51,7 +51,7 @@ env.AppendENVPath('PATH', gecko_bin)
env.Append(BUILDERS = {'MozXPT' : bxpt, 'MozHeader' : bhdr })
# Add additional param for different platforms
-if platform == 'linux2':
+if 1 or platform == 'linux2':
env.ParseConfig('pkg-config --static --cflags gtk+-2.0') # libnotify
env.AppendUnique(
CXXFLAGS = ['-include', 'xpcom-config.h', '-Wall', '-O2',
@@ -73,7 +73,7 @@ xpts = [env.MozXPT('nsITray'), env.MozXP
headers = [env.MozHeader('nsITray')]
parts = []
-if platform == 'linux2':
+if 1 or platform == 'linux2':
parts.extend(['nsTray.cpp', 'nsTrayModue.cpp'])
nptray_name = 'nptray' + lib_arch

3
mail/firetray/pkg-descr Normal file
View File

@ -0,0 +1,3 @@
Firetray is a system tray add-on for firefox.
WWW: http://code.google.com/p/firetray/