Add scintilla - a full-featured free source code editing component for GTK+.
This commit is contained in:
parent
157c9afadd
commit
bfa077b20e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=35466
@ -77,6 +77,7 @@
|
||||
SUBDIR += ruby-qt
|
||||
SUBDIR += ruby-tk
|
||||
SUBDIR += ruby14-tk
|
||||
SUBDIR += scintilla
|
||||
SUBDIR += slingshot
|
||||
SUBDIR += thinice
|
||||
SUBDIR += tix
|
||||
|
35
x11-toolkits/scintilla/Makefile
Normal file
35
x11-toolkits/scintilla/Makefile
Normal file
@ -0,0 +1,35 @@
|
||||
# New ports collection makefile for: scintilla
|
||||
# Date created: 27 November 2000
|
||||
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= scintilla
|
||||
PORTVERSION= 1.33
|
||||
CATEGORIES= x11-toolkits
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
|
||||
http://www.scintilla.org/
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= sobomax@FreeBSD.org
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}/gtk
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GTK= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
MAKEFILE= makefile
|
||||
|
||||
do-install:
|
||||
${MKDIR} ${PREFIX}/include/scintilla
|
||||
${INSTALL_DATA} ${WRKSRC}/../include/*.h ${PREFIX}/include/scintilla
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/../bin/libscintilla.so.1 ${PREFIX}/lib
|
||||
${LN} -sf ${PREFIX}/lib/libscintilla.so.1 ${PREFIX}/lib/libscintilla.so
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/../bin/libscintilla_lexers.so.1 ${PREFIX}/lib
|
||||
${LN} -sf ${PREFIX}/lib/libscintilla_lexers.so.1 ${PREFIX}/lib/libscintilla_lexers.so
|
||||
|
||||
.include <bsd.port.mk>
|
1
x11-toolkits/scintilla/distinfo
Normal file
1
x11-toolkits/scintilla/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (scintilla133.tgz) = 0968a486def05cb2fd0c3b04b8d7c84e
|
43
x11-toolkits/scintilla/files/patch-aa
Normal file
43
x11-toolkits/scintilla/files/patch-aa
Normal file
@ -0,0 +1,43 @@
|
||||
--- makefile 2000/11/27 09:54:21 1.1
|
||||
+++ makefile 2000/11/27 12:51:45
|
||||
@@ -5,10 +5,11 @@
|
||||
# GNU make does not like \r\n line endings so should be saved to CVS in binary form.
|
||||
|
||||
.SUFFIXES: .cxx .o .h .a
|
||||
-CC = g++
|
||||
-AR = ar
|
||||
+CC = c++
|
||||
+AR = $(CC) -shared
|
||||
|
||||
-COMPLIB=../bin/scintilla.a
|
||||
+COMPLIB=../bin/libscintilla.so.1
|
||||
+LEXRLIB=../bin/libscintilla_lexers.so.1
|
||||
|
||||
vpath %.h ../src ../include
|
||||
vpath %.cxx ../src
|
||||
@@ -25,19 +26,22 @@
|
||||
endif
|
||||
|
||||
.cxx.o:
|
||||
- $(CC) `gtk-config --cflags` $(INCLUDEDIRS) $(CXXFLAGS) -c $< -o $@
|
||||
+ $(CC) -DPIC -fPIC -fpic `$(GTK_CONFIG) --cflags` $(INCLUDEDIRS) $(CXXFLAGS) -c $< -o $@
|
||||
|
||||
LEXOBJS = LexCPP.o LexHTML.o LexLua.o LexOthers.o LexPerl.o LexPython.o LexSQL.o LexVB.o LexConf.o
|
||||
|
||||
# The LEXOBJS have to be treated specially as the functions in them are not called from external code
|
||||
|
||||
-all: $(COMPLIB) $(LEXOBJS)
|
||||
+all: $(COMPLIB) $(LEXRLIB)
|
||||
|
||||
$(COMPLIB): DocumentAccessor.o WindowAccessor.o KeyWords.o Document.o CallTip.o \
|
||||
ScintillaBase.o ContractionState.o Editor.o PropSet.o PlatGTK.o \
|
||||
KeyMap.o LineMarker.o ScintillaGTK.o CellBuffer.o ViewStyle.o \
|
||||
Style.o Indicator.o AutoComplete.o
|
||||
- $(AR) rc $@ $^
|
||||
+ $(AR) -o $@ $^
|
||||
+
|
||||
+$(LEXRLIB): $(LEXOBJS)
|
||||
+ $(AR) -o $@ $^
|
||||
|
||||
AutoComplete.o: AutoComplete.cxx Platform.h AutoComplete.h
|
||||
CallTip.o: CallTip.cxx Platform.h CallTip.h
|
1
x11-toolkits/scintilla/pkg-comment
Normal file
1
x11-toolkits/scintilla/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
A full-featured free source code editing component for GTK+
|
11
x11-toolkits/scintilla/pkg-descr
Normal file
11
x11-toolkits/scintilla/pkg-descr
Normal file
@ -0,0 +1,11 @@
|
||||
Scintilla is a free source code editing component. As well as features found in
|
||||
standard text editing components, Scintilla includes features especially useful
|
||||
when editing and debugging source code. These include support for syntax
|
||||
styling, error indicators, code completion and call tips. The selection margin
|
||||
can contain markers like those used in debuggers to indicate breakpoints and
|
||||
the current line. Styling choices are more open than with many editors,
|
||||
allowing the use of proportional fonts, bold and italics, multiple foreground
|
||||
and background colours and multiple fonts. It comes with complete source code
|
||||
and may be used in any free project or commercial product.
|
||||
|
||||
WWW: http://www.scintilla.org/
|
16
x11-toolkits/scintilla/pkg-plist
Normal file
16
x11-toolkits/scintilla/pkg-plist
Normal file
@ -0,0 +1,16 @@
|
||||
include/scintilla/Accessor.h
|
||||
include/scintilla/KeyWords.h
|
||||
include/scintilla/Platform.h
|
||||
include/scintilla/PosRegExp.h
|
||||
include/scintilla/PropSet.h
|
||||
include/scintilla/SciLexer.h
|
||||
include/scintilla/Scintilla.h
|
||||
include/scintilla/ScintillaWidget.h
|
||||
include/scintilla/WinDefs.h
|
||||
include/scintilla/WindowAccessor.h
|
||||
lib/libscintilla.so
|
||||
lib/libscintilla.so.1
|
||||
lib/libscintilla_lexers.so
|
||||
lib/libscintilla_lexers.so.1
|
||||
@dirrm include/scintilla
|
||||
|
Loading…
Reference in New Issue
Block a user