- Fix build on i386

- Install plugins to ${LOCALBASE}/lib/mupen64plus directory. This is default
  directory used by emulator
- Bump PORTREVISION

Reported by:	David Demelier <demelier.david@ at gmail.com>
This commit is contained in:
Jose Alonso Cardenas Marquez 2010-12-17 05:47:55 +00:00
parent 5f71d29bc5
commit bf98a86fdd
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=266480
8 changed files with 28 additions and 5 deletions

View File

@ -5,6 +5,8 @@
# $FreeBSD$
#
PORTREVISION= 1
PKGNAMESUFFIX= -audio-sdl
COMMENT= Mupen64plus audio sdl plugin

View File

@ -7,7 +7,7 @@
PORTNAME= mupen64plus
PORTVERSION?= 1.99.4
PORTREVISION?= 0
PORTREVISION?= 1
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
PKGNAMESUFFIX?= -core
@ -17,7 +17,7 @@ MAINTAINER?= acm@FreeBSD.org
COMMENT?= A fork of Mupen64 Nintendo 64 emulator
USE_GL?= yes
USE_SDL?= #
USE_SDL?= yes
USE_GMAKE= yes
USE_LDCONFIG?= yes
ONLY_FOR_ARCHS= i386 amd64

View File

@ -9,8 +9,6 @@ EXTRACT_AFTER_ARGS= | ${TAR} -xf - "${DISTNAME}/source/${PORTNAME}-core/*" \
"${DISTNAME}/source/${PORTNAME}${PKGNAMESUFFIX}/*"
.if ${PKGNAMESUFFIX} == "-core"
USE_SDL= sdl
LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2 \
png.6:${PORTSDIR}/graphics/png
.else
@ -42,7 +40,8 @@ pre-install:
. endif
. if ${PKGNAMESUFFIX} != "-ui-console"
@${ECHO_CMD} "lib/${PORTNAME}${PKGNAMESUFFIX}.so" >> ${PLIST}
@${ECHO_CMD} "lib/${PORTNAME}/${PORTNAME}${PKGNAMESUFFIX}.so" >> ${PLIST}
@${ECHO_CMD} "@dirrmtry lib/${PORTNAME}" >> ${PLIST}
@${ECHO_CMD} "@dirrmtry %%DATADIR%%" >> ${PLIST}
. else
@${ECHO_CMD} "bin/${PORTNAME}" >> ${PLIST}
@ -84,6 +83,7 @@ do-install:
. endif
. if ${PKGNAMESUFFIX} != "-ui-console"
@${MKDIR} ${PREFIX}/lib/${PORTNAME}
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME}${PKGNAMESUFFIX}.so ${PREFIX}/lib
. else
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME} ${PREFIX}/bin

View File

@ -5,6 +5,8 @@
# $FreeBSD$
#
PORTREVISION= 1
PKGNAMESUFFIX= -input-sdl
COMMENT= Input plugin for Mupen64plus

View File

@ -5,6 +5,8 @@
# $FreeBSD$
#
PORTREVISION= 1
PKGNAMESUFFIX= -rsp-hle
COMMENT= RSP plugin for Mupen64plus

View File

@ -5,6 +5,8 @@
# $FreeBSD$
#
PORTREVISION= 1
PKGNAMESUFFIX= -video-rice
COMMENT= The rice graphics plugin for Mupen64plus

View File

@ -0,0 +1,14 @@
--- source/mupen64plus-video-rice/projects/unix/Makefile 2010-12-17 00:32:33.000000000 -0500
+++ source/mupen64plus-video-rice/projects/unix/Makefile 2010-12-17 00:34:09.000000000 -0500
@@ -111,6 +111,11 @@
ifeq ($(OS),FREEBSD)
LDFLAGS += -lGL $(shell pkg-config --libs libpng)
CFLAGS += $(shell pkg-config --cflags libpng)
+ ifeq ($(CPU), X86)
+ ifeq ($(ARCH_DETECTED), 32BITS)
+ CFLAGS += -pipe -mmmx -msse -fomit-frame-pointer
+ endif
+ endif
endif
ifeq ($(OS), LINUX)
LDFLAGS += -ldl -lGL

View File

@ -7,6 +7,7 @@
PORTNAME= mupen64plus
PORTVERSION= 1.99.4
PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= # empty
DISTFILES= # empty