Split gdk-pixbuf into the non-GNOME part (gdk-pixbuf) and the
GNOME part (gnomecanvas) to allow for other ports to access the lower level parts of gdk-pixbuf without the "excess baggage" of even a minimal GNOME environment. Submitted by: sobomax (with extensive patches - complain to me)
This commit is contained in:
parent
535a41be37
commit
bf774b0f98
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=42828
@ -67,6 +67,7 @@
|
||||
SUBDIR += gliv
|
||||
SUBDIR += gltk
|
||||
SUBDIR += gnofract4d
|
||||
SUBDIR += gnomecanvas
|
||||
SUBDIR += gnomeiconedit
|
||||
SUBDIR += gozer
|
||||
SUBDIR += gpaint
|
||||
|
@ -5,25 +5,34 @@
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= gdk-pixbuf
|
||||
PORTNAME?= gdk-pixbuf
|
||||
PORTVERSION= 0.11.0
|
||||
CATEGORIES= graphics gnome
|
||||
PORTREVISION= 1
|
||||
CATEGORIES?= graphics
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME}
|
||||
MASTER_SITE_SUBDIR= unstable/sources/gdk-pixbuf
|
||||
DISTNAME= gdk-pixbuf-${PORTVERSION}
|
||||
|
||||
MAINTAINER= gnome@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS+= png.4:${PORTSDIR}/graphics/png \
|
||||
tiff.4:${PORTSDIR}/graphics/tiff \
|
||||
jpeg.9:${PORTSDIR}/graphics/jpeg
|
||||
|
||||
USE_GMAKE= yes
|
||||
USE_X_PREFIX= yes
|
||||
USE_GNOMELIBS= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_GTK= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LIBS="-L${LOCALBASE}/lib"
|
||||
LIBS="-L${LOCALBASE}/lib" \
|
||||
BUILD_CANVAS="${BUILD_CANVAS}"
|
||||
|
||||
BUILD_CANVAS?= no
|
||||
|
||||
pre-patch:
|
||||
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
|
||||
's|\$$\(datadir\)/gnome/|\$$\(datadir\)/|g ; \
|
||||
s|\$$\(datadir\)/aclocal|\$$\(prefix\)/share/aclocal|g'
|
||||
's|\$$\(datadir\)/aclocal|\$$\(prefix\)/share/aclocal|g'
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,14 +1,45 @@
|
||||
--- configure.orig Thu Apr 26 18:41:47 2001
|
||||
+++ configure Fri Apr 27 16:39:52 2001
|
||||
@@ -3593,4 +3593,4 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- configure.orig Fri Apr 27 02:41:47 2001
|
||||
+++ configure Fri May 18 16:03:47 2001
|
||||
@@ -3443,6 +3443,8 @@
|
||||
INSIDE_GNOME=yes
|
||||
BUILD_CANVAS=yes
|
||||
else
|
||||
+
|
||||
+if [ x"$BUILD_CANVAS" != x"no" ]; then
|
||||
|
||||
# Extract the first word of "gnome-config", so it can be a program name with args.
|
||||
set dummy gnome-config; ac_word=$2
|
||||
@@ -3474,6 +3476,10 @@
|
||||
esac
|
||||
fi
|
||||
GNOME_CONFIG="$ac_cv_path_GNOME_CONFIG"
|
||||
+else
|
||||
+GNOME_CONFIG="no"
|
||||
+fi
|
||||
+
|
||||
if test -n "$GNOME_CONFIG"; then
|
||||
echo "$ac_t""$GNOME_CONFIG" 1>&6
|
||||
else
|
||||
@@ -3591,8 +3597,8 @@
|
||||
#define USE_GMODULE 1
|
||||
EOF
|
||||
|
||||
- GMODULE_LIBS="`glib-config --libs gmodule`"
|
||||
- GMODULE_FLAGS="`glib-config --cflags gmodule`"
|
||||
+ GMODULE_LIBS="`$GLIB_CONFIG --libs gmodule`"
|
||||
+ GMODULE_FLAGS="`$GLIB_CONFIG --cflags gmodule`"
|
||||
|
||||
@@ -4470,3 +4470,3 @@
|
||||
|
||||
echo "$ac_t""yes" 1>&6
|
||||
@@ -4468,7 +4474,7 @@
|
||||
|
||||
|
||||
if test "x$with_html_dir" = "x" ; then
|
||||
- HTML_DIR='${datadir}/gnome/html'
|
||||
+ HTML_DIR='${datadir}/html'
|
||||
else
|
||||
HTML_DIR=$with_html_dir
|
||||
fi
|
||||
|
@ -1,7 +1,20 @@
|
||||
--- Makefile.in.orig Sun Aug 27 18:48:23 2000
|
||||
+++ Makefile.in Mon Aug 28 10:14:58 2000
|
||||
@@ -109,3 +109,3 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- Makefile.in.orig Fri May 18 16:16:44 2001
|
||||
+++ Makefile.in Fri May 18 16:20:28 2001
|
||||
@@ -111,11 +111,11 @@
|
||||
|
||||
bin_SCRIPTS = gdk-pixbuf-config
|
||||
|
||||
-confexecdir = $(libdir)
|
||||
-confexec_DATA = gdk_pixbufConf.sh gdk_pixbuf_xlibConf.sh gnomecanvaspixbufConf.sh
|
||||
+confexecdir = $(sysconfdir)
|
||||
confexec_DATA = gdk_pixbufConf.sh gdk_pixbuf_xlibConf.sh gnomecanvaspixbufConf.sh
|
||||
+confexec_DATA = gdk_pixbufConf.sh gdk_pixbuf_xlibConf.sh @BUILD_CANVAS_ITEM_TRUE@gnomecanvaspixbufConf.sh
|
||||
|
||||
|
||||
-EXTRA_DIST = gdk_pixbufConf.sh.in gdk_pixbuf_xlibConf.sh.in gnomecanvaspixbufConf.sh.in gdk-pixbuf-config.in gdk-pixbuf.m4 gdk-pixbuf.spec gdk-pixbuf.spec.in
|
||||
+EXTRA_DIST = gdk_pixbufConf.sh.in gdk_pixbuf_xlibConf.sh.in gdk-pixbuf-config.in gdk-pixbuf.m4 gdk-pixbuf.spec gdk-pixbuf.spec.in @BUILD_CANVAS_ITEM_TRUE@gnomecanvaspixbufConf.sh.in
|
||||
|
||||
|
||||
m4datadir = $(prefix)/share/aclocal
|
||||
|
@ -1 +1 @@
|
||||
A graphic library for GNOME
|
||||
A graphic library for GTK+
|
||||
|
@ -1,13 +1,11 @@
|
||||
bin/gdk-pixbuf-config
|
||||
etc/gdk_pixbufConf.sh
|
||||
etc/gdk_pixbuf_xlibConf.sh
|
||||
etc/gnomecanvaspixbufConf.sh
|
||||
include/gdk-pixbuf/gdk-pixbuf-features.h
|
||||
include/gdk-pixbuf/gdk-pixbuf-loader.h
|
||||
include/gdk-pixbuf/gdk-pixbuf-xlib.h
|
||||
include/gdk-pixbuf/gdk-pixbuf-xlibrgb.h
|
||||
include/gdk-pixbuf/gdk-pixbuf.h
|
||||
include/gdk-pixbuf/gnome-canvas-pixbuf.h
|
||||
lib/gdk-pixbuf/loaders/libpixbufloader-bmp.so
|
||||
lib/gdk-pixbuf/loaders/libpixbufloader-gif.so
|
||||
lib/gdk-pixbuf/loaders/libpixbufloader-ico.so
|
||||
@ -24,49 +22,46 @@ lib/libgdk_pixbuf.so.2
|
||||
lib/libgdk_pixbuf_xlib.a
|
||||
lib/libgdk_pixbuf_xlib.so
|
||||
lib/libgdk_pixbuf_xlib.so.2
|
||||
lib/libgnomecanvaspixbuf.a
|
||||
lib/libgnomecanvaspixbuf.so
|
||||
lib/libgnomecanvaspixbuf.so.1
|
||||
share/aclocal/gdk-pixbuf.m4
|
||||
share/gnome/html/gdk-pixbuf/a2605.html
|
||||
share/gnome/html/gdk-pixbuf/a3640.html
|
||||
share/gnome/html/gdk-pixbuf/a3652.html
|
||||
share/gnome/html/gdk-pixbuf/a3694.html
|
||||
share/gnome/html/gdk-pixbuf/a3716.html
|
||||
share/gnome/html/gdk-pixbuf/book1.html
|
||||
share/gnome/html/gdk-pixbuf/compiling.html
|
||||
share/gnome/html/gdk-pixbuf/extra-configuration-options.html
|
||||
share/gnome/html/gdk-pixbuf/gdk-pixbuf-animation.html
|
||||
share/gnome/html/gdk-pixbuf/gdk-pixbuf-creating.html
|
||||
share/gnome/html/gdk-pixbuf/gdk-pixbuf-file-loading.html
|
||||
share/gnome/html/gdk-pixbuf/gdk-pixbuf-from-drawables.html
|
||||
share/gnome/html/gdk-pixbuf/gdk-pixbuf-gdk-pixbuf-xlib-from-drawables.html
|
||||
share/gnome/html/gdk-pixbuf/gdk-pixbuf-gdk-pixbuf-xlib-init.html
|
||||
share/gnome/html/gdk-pixbuf/gdk-pixbuf-gdk-pixbuf-xlib-rendering.html
|
||||
share/gnome/html/gdk-pixbuf/gdk-pixbuf-gdk-pixbuf-xlib-rgb.html
|
||||
share/gnome/html/gdk-pixbuf/gdk-pixbuf-gdk-pixbuf.html
|
||||
share/gnome/html/gdk-pixbuf/gdk-pixbuf-refcounting.html
|
||||
share/gnome/html/gdk-pixbuf/gdk-pixbuf-rendering.html
|
||||
share/gnome/html/gdk-pixbuf/gdk-pixbuf-scaling.html
|
||||
share/gnome/html/gdk-pixbuf/gdk-pixbuf-util.html
|
||||
share/gnome/html/gdk-pixbuf/gdkpixbufloader.html
|
||||
share/gnome/html/gdk-pixbuf/gnomecanvaspixbuf.html
|
||||
share/gnome/html/gdk-pixbuf/index.html
|
||||
share/gnome/html/gdk-pixbuf/index.sgml
|
||||
share/gnome/html/gdk-pixbuf/license.html
|
||||
share/gnome/html/gdk-pixbuf/r15.html
|
||||
share/gnome/html/gdk-pixbuf/r27.html
|
||||
share/gnome/html/gdk-pixbuf/x2624.html
|
||||
share/gnome/html/gdk-pixbuf/x2676.html
|
||||
share/gnome/html/gdk-pixbuf/x3659.html
|
||||
share/gnome/html/gdk-pixbuf/x3671.html
|
||||
share/gnome/html/gdk-pixbuf/x3711.html
|
||||
share/gnome/html/gdk-pixbuf/x3713.html
|
||||
share/gnome/html/gdk-pixbuf/x3723.html
|
||||
share/gnome/html/gdk-pixbuf/x3735.html
|
||||
share/gnome/html/gdk-pixbuf/x3765.html
|
||||
share/gnome/html/gdk-pixbuf/x3787.html
|
||||
@dirrm share/gnome/html/gdk-pixbuf
|
||||
share/doc/gdk-pixbuf/a2605.html
|
||||
share/doc/gdk-pixbuf/a3640.html
|
||||
share/doc/gdk-pixbuf/a3652.html
|
||||
share/doc/gdk-pixbuf/a3694.html
|
||||
share/doc/gdk-pixbuf/a3716.html
|
||||
share/doc/gdk-pixbuf/book1.html
|
||||
share/doc/gdk-pixbuf/compiling.html
|
||||
share/doc/gdk-pixbuf/extra-configuration-options.html
|
||||
share/doc/gdk-pixbuf/gdk-pixbuf-animation.html
|
||||
share/doc/gdk-pixbuf/gdk-pixbuf-creating.html
|
||||
share/doc/gdk-pixbuf/gdk-pixbuf-file-loading.html
|
||||
share/doc/gdk-pixbuf/gdk-pixbuf-from-drawables.html
|
||||
share/doc/gdk-pixbuf/gdk-pixbuf-gdk-pixbuf-xlib-from-drawables.html
|
||||
share/doc/gdk-pixbuf/gdk-pixbuf-gdk-pixbuf-xlib-init.html
|
||||
share/doc/gdk-pixbuf/gdk-pixbuf-gdk-pixbuf-xlib-rendering.html
|
||||
share/doc/gdk-pixbuf/gdk-pixbuf-gdk-pixbuf-xlib-rgb.html
|
||||
share/doc/gdk-pixbuf/gdk-pixbuf-gdk-pixbuf.html
|
||||
share/doc/gdk-pixbuf/gdk-pixbuf-refcounting.html
|
||||
share/doc/gdk-pixbuf/gdk-pixbuf-rendering.html
|
||||
share/doc/gdk-pixbuf/gdk-pixbuf-scaling.html
|
||||
share/doc/gdk-pixbuf/gdk-pixbuf-util.html
|
||||
share/doc/gdk-pixbuf/gdkpixbufloader.html
|
||||
share/doc/gdk-pixbuf/gnomecanvaspixbuf.html
|
||||
share/doc/gdk-pixbuf/index.html
|
||||
share/doc/gdk-pixbuf/index.sgml
|
||||
share/doc/gdk-pixbuf/license.html
|
||||
share/doc/gdk-pixbuf/r15.html
|
||||
share/doc/gdk-pixbuf/r27.html
|
||||
share/doc/gdk-pixbuf/x2624.html
|
||||
share/doc/gdk-pixbuf/x2676.html
|
||||
share/doc/gdk-pixbuf/x3659.html
|
||||
share/doc/gdk-pixbuf/x3671.html
|
||||
share/doc/gdk-pixbuf/x3711.html
|
||||
share/doc/gdk-pixbuf/x3713.html
|
||||
share/doc/gdk-pixbuf/x3723.html
|
||||
share/doc/gdk-pixbuf/x3735.html
|
||||
share/doc/gdk-pixbuf/x3765.html
|
||||
share/doc/gdk-pixbuf/x3787.html
|
||||
@dirrm share/doc/gdk-pixbuf
|
||||
@dirrm lib/gdk-pixbuf/loaders
|
||||
@dirrm lib/gdk-pixbuf
|
||||
@dirrm include/gdk-pixbuf
|
||||
|
34
graphics/gnomecanvas/Makefile
Normal file
34
graphics/gnomecanvas/Makefile
Normal file
@ -0,0 +1,34 @@
|
||||
# New ports collection makefile for: gnomecanvas
|
||||
# Date created: 18 May 2001
|
||||
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= gnomecanvas
|
||||
CATEGORIES= graphics gnome
|
||||
|
||||
LIB_DEPENDS= gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../gdk-pixbuf
|
||||
|
||||
COMMENT= ${.CURDIR}/pkg-comment
|
||||
DESCR= ${.CURDIR}/pkg-descr
|
||||
PLIST= ${.CURDIR}/pkg-plist
|
||||
|
||||
USE_GNOMELIBS= yes
|
||||
|
||||
BUILD_CANVAS= yes
|
||||
|
||||
NAME= gnomecanvaspixbuf
|
||||
|
||||
do-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/${NAME}Conf.sh ${PREFIX}/etc
|
||||
cd ${WRKSRC}/gdk-pixbuf/.libs && \
|
||||
${MKDIR} ${PREFIX}/include/gdk-pixbuf/ && \
|
||||
${INSTALL_DATA} ../gnome-canvas-pixbuf.h ${PREFIX}/include/gdk-pixbuf/ && \
|
||||
${INSTALL_DATA} lib${NAME}.a ${PREFIX}/lib && \
|
||||
${INSTALL_PROGRAM} lib${NAME}.so.1 ${PREFIX}/lib && \
|
||||
${LN} -sf lib${NAME}.so.1 ${PREFIX}/lib/lib${NAME}.so
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
1
graphics/gnomecanvas/pkg-comment
Normal file
1
graphics/gnomecanvas/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
A graphic library for GNOME
|
6
graphics/gnomecanvas/pkg-descr
Normal file
6
graphics/gnomecanvas/pkg-descr
Normal file
@ -0,0 +1,6 @@
|
||||
The GNOMECanvas library provides a number of features:
|
||||
|
||||
- Image loading facilities.
|
||||
- Rendering of a GdkPixBuf into various formats:
|
||||
drawables (windows, pixmaps), GdkRGB buffers.
|
||||
- A cache interface
|
5
graphics/gnomecanvas/pkg-plist
Normal file
5
graphics/gnomecanvas/pkg-plist
Normal file
@ -0,0 +1,5 @@
|
||||
etc/gnomecanvaspixbufConf.sh
|
||||
include/gdk-pixbuf/gnome-canvas-pixbuf.h
|
||||
lib/libgnomecanvaspixbuf.a
|
||||
lib/libgnomecanvaspixbuf.so
|
||||
lib/libgnomecanvaspixbuf.so.1
|
34
graphics/libgnomecanvas/Makefile
Normal file
34
graphics/libgnomecanvas/Makefile
Normal file
@ -0,0 +1,34 @@
|
||||
# New ports collection makefile for: gnomecanvas
|
||||
# Date created: 18 May 2001
|
||||
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= gnomecanvas
|
||||
CATEGORIES= graphics gnome
|
||||
|
||||
LIB_DEPENDS= gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../gdk-pixbuf
|
||||
|
||||
COMMENT= ${.CURDIR}/pkg-comment
|
||||
DESCR= ${.CURDIR}/pkg-descr
|
||||
PLIST= ${.CURDIR}/pkg-plist
|
||||
|
||||
USE_GNOMELIBS= yes
|
||||
|
||||
BUILD_CANVAS= yes
|
||||
|
||||
NAME= gnomecanvaspixbuf
|
||||
|
||||
do-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/${NAME}Conf.sh ${PREFIX}/etc
|
||||
cd ${WRKSRC}/gdk-pixbuf/.libs && \
|
||||
${MKDIR} ${PREFIX}/include/gdk-pixbuf/ && \
|
||||
${INSTALL_DATA} ../gnome-canvas-pixbuf.h ${PREFIX}/include/gdk-pixbuf/ && \
|
||||
${INSTALL_DATA} lib${NAME}.a ${PREFIX}/lib && \
|
||||
${INSTALL_PROGRAM} lib${NAME}.so.1 ${PREFIX}/lib && \
|
||||
${LN} -sf lib${NAME}.so.1 ${PREFIX}/lib/lib${NAME}.so
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
1
graphics/libgnomecanvas/pkg-comment
Normal file
1
graphics/libgnomecanvas/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
A graphic library for GNOME
|
6
graphics/libgnomecanvas/pkg-descr
Normal file
6
graphics/libgnomecanvas/pkg-descr
Normal file
@ -0,0 +1,6 @@
|
||||
The GNOMECanvas library provides a number of features:
|
||||
|
||||
- Image loading facilities.
|
||||
- Rendering of a GdkPixBuf into various formats:
|
||||
drawables (windows, pixmaps), GdkRGB buffers.
|
||||
- A cache interface
|
5
graphics/libgnomecanvas/pkg-plist
Normal file
5
graphics/libgnomecanvas/pkg-plist
Normal file
@ -0,0 +1,5 @@
|
||||
etc/gnomecanvaspixbufConf.sh
|
||||
include/gdk-pixbuf/gnome-canvas-pixbuf.h
|
||||
lib/libgnomecanvaspixbuf.a
|
||||
lib/libgnomecanvaspixbuf.so
|
||||
lib/libgnomecanvaspixbuf.so.1
|
@ -7,6 +7,7 @@
|
||||
|
||||
PORTNAME= gnome
|
||||
PORTVERSION= 1.4
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= x11 gnome
|
||||
MASTER_SITES= # empty
|
||||
DISTFILES= # empty
|
||||
|
@ -7,6 +7,7 @@
|
||||
|
||||
PORTNAME= gnome
|
||||
PORTVERSION= 1.4
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= x11 gnome
|
||||
MASTER_SITES= # empty
|
||||
DISTFILES= # empty
|
||||
|
Loading…
Reference in New Issue
Block a user