Update to version 1.1.5 of GNU Smalltalk.
This commit is contained in:
parent
3fee04a75a
commit
bf19628812
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=8895
@ -3,25 +3,26 @@
|
||||
# Date created: 09 Feb 1995
|
||||
# Whom: gpalmer
|
||||
#
|
||||
# $Id: Makefile,v 1.12 1996/12/07 17:58:22 max Exp $
|
||||
# $Id: Makefile,v 1.13 1996/12/08 01:44:46 max Exp $
|
||||
#
|
||||
|
||||
DISTNAME= smalltalk-1.1.1
|
||||
DISTNAME= smalltalk-1.1.5
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= ${MASTER_SITE_GNU}
|
||||
|
||||
MAINTAINER= jraynard@FreeBSD.ORG
|
||||
|
||||
BUILD_DEPENDS= ${PREFIX}/lib/libgdbm.a:${PORTSDIR}/databases/gdbm
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-optimize --with-readline
|
||||
|
||||
IS_INTERACTIVE= yes
|
||||
NO_PACKAGE= "Installation requires interaction"
|
||||
|
||||
pre-configure:
|
||||
@${CP} ${FILESDIR}/m-fbsd-2.h ${WRKSRC}/config/m-fbsd-2.h
|
||||
@(cd ${WRKSRC} ; ./config.mst fbsd-2)
|
||||
@${TOUCH} ${TOUCH_FLAGS} ${CONFIGURE_COOKIE}
|
||||
|
||||
do-build:
|
||||
if [ -d ${X11BASE} ]; then (cd ${WRKSRC}/stix; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${ALL_TARGET}; ${CP} mst *.st ${WRKSRC}); else (cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${ALL_TARGET}); fi;
|
||||
# For some reason configure doesn't set this up properly and my feeble
|
||||
# brain can't see how to fix it.
|
||||
CFLAGS+= -I${X11BASE}/include
|
||||
|
||||
do-install:
|
||||
@echo "Installing method definitions..."
|
||||
@ -29,21 +30,23 @@ do-install:
|
||||
@(cd ${WRKSRC}; ${CP} *.st ${PREFIX}/lib/smalltalk)
|
||||
@(cd ${PREFIX}/lib/smalltalk ; chmod +r *.st)
|
||||
@echo
|
||||
@echo
|
||||
@echo "To complete the installation of GNU Smalltalk, do"
|
||||
@echo " cd ${WRKSRC}; ./mst -iV"
|
||||
@echo "to build the image and test the interpreter."
|
||||
@echo " cd ${WRKSRC};"
|
||||
@echo "./gst -iV"
|
||||
@echo "to test the interpreter and create the image."
|
||||
@echo
|
||||
@echo "When you are satisfied everything works, do Control-D to quit"
|
||||
@echo "(this will give a parse error, which can be safely ignored)"
|
||||
@echo "followed by 'cp mst ${PREFIX}/bin'."
|
||||
@echo "followed by"
|
||||
@echo "cp gst ${PREFIX}/bin"
|
||||
@echo "cp gst.im ${PREFIX}/lib/smalltalk"
|
||||
@echo "to install the interpreter and image."
|
||||
@echo
|
||||
@echo "Finally, if Emacs is installed, you may also wish to copy the"
|
||||
@echo "st*.el files to the Emacs Lisp directory. This will enable you"
|
||||
@echo "If Emacs is installed, you may also wish to copy the"
|
||||
@echo "*st.el files to the Emacs Lisp directory. This will enable you"
|
||||
@echo "to configure Emacs for Interactor mode."
|
||||
@echo
|
||||
@echo ">>Please read the file"
|
||||
@echo "${WRKSRC}/mst.texinfo"
|
||||
@echo ">>Please read the file"
|
||||
@echo "${WRKSRC}/info/gst.txi"
|
||||
@echo "for more information.<<"
|
||||
@echo
|
||||
|
||||
|
@ -1 +1 @@
|
||||
MD5 (smalltalk-1.1.1.tar.gz) = 216ed66fa5f8db790192ff6ab4d88736
|
||||
MD5 (smalltalk-1.1.5.tar.gz) = 6151d3aa1c0eddcef876c419542aef5d
|
||||
|
@ -1,68 +1,15 @@
|
||||
*** /dev/null Thu Feb 2 13:59:15 1995
|
||||
--- mstpaths.h Thu Feb 2 14:43:38 1995
|
||||
***************
|
||||
*** 0 ****
|
||||
--- 1,63 ----
|
||||
+ /***********************************************************************
|
||||
+ *
|
||||
+ * Definitions for various path related things. These are compiled into
|
||||
+ * the GNU Smalltalk interpreter and are used for finding various files
|
||||
+ * (the image file, the kernel .st files, etc.).
|
||||
+ *
|
||||
+ ***********************************************************************/
|
||||
+
|
||||
+
|
||||
+ /***********************************************************************
|
||||
+ *
|
||||
+ * Copyright (C) 1990, 1991 Free Software Foundation, Inc.
|
||||
+ * Written by Steve Byrne.
|
||||
+ *
|
||||
+ * This file is part of GNU Smalltalk.
|
||||
+ *
|
||||
+ * GNU Smalltalk is free software; you can redistribute it and/or modify it
|
||||
+ * under the terms of the GNU General Public License as published by the Free
|
||||
+ * Software Foundation; either version 1, or (at your option) any later
|
||||
+ * version.
|
||||
+ *
|
||||
+ * GNU Smalltalk is distributed in the hope that it will be useful, but WITHOUT
|
||||
+ * ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
|
||||
+ * FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for
|
||||
+ * more details.
|
||||
+ *
|
||||
+ * You should have received a copy of the GNU General Public License along with
|
||||
+ * GNU Smalltalk; see the file COPYING. If not, write to the Free Software
|
||||
+ * Foundation, 675 Mass Ave, Cambridge, MA 02139, USA.
|
||||
+ *
|
||||
+ ***********************************************************************/
|
||||
+
|
||||
+
|
||||
+
|
||||
+ /*
|
||||
+ * Change Log
|
||||
+ * ============================================================================
|
||||
+ * Author Date Change
|
||||
+ * sbyrne 15 Oct 89 Created.
|
||||
+ *
|
||||
+ */
|
||||
+
|
||||
+
|
||||
+ /***********************************************************************
|
||||
+ *
|
||||
+ * You'll need to change these definitions if you do not install GNU
|
||||
+ * Smalltalk in the standard place (which, as defined here, is
|
||||
+ * /usr/local/smalltalk). You should save this file as mstpaths.h and
|
||||
+ * leave mstpaths.h-dist in its original form.
|
||||
+ *
|
||||
+ ***********************************************************************/
|
||||
+
|
||||
+
|
||||
+ #ifndef __MSTPATHS__
|
||||
+ #define __MSTPATHS__
|
||||
+
|
||||
+ /* This defines where the kernel smalltalk (.st) files can be found */
|
||||
+ #define KERNEL_PATH "/usr/local/lib/smalltalk"
|
||||
+
|
||||
+ /* This defines where to search for the saved binary image */
|
||||
+ #define IMAGE_PATH "/usr/local/lib/smalltalk"
|
||||
+
|
||||
+ #endif /* __MSTPATHS__ */
|
||||
--- lib/gst.h.orig Fri Nov 28 21:37:24 1997
|
||||
+++ lib/gst.h Fri Nov 28 21:38:09 1997
|
||||
@@ -135,10 +135,12 @@
|
||||
* define __STDC__ */
|
||||
#if (defined (__STDC__) && __STDC__) || defined(_ANSI_C_SOURCE) || defined (__cplusplus) || defined(_WIN32)
|
||||
|
||||
+#ifndef __FreeBSD__
|
||||
#define __P(args) args
|
||||
#define __const const
|
||||
#define __signed signed
|
||||
#define __volatile volatile
|
||||
+#endif
|
||||
#define __DOTS , ...
|
||||
|
||||
#else /* Not ANSI C or C++. */
|
||||
|
@ -1,23 +1,19 @@
|
||||
*** ymakefile.orig Sun Dec 10 17:56:09 1995
|
||||
--- ymakefile Sun Dec 10 17:57:22 1995
|
||||
***************
|
||||
*** 121,130 ****
|
||||
/* Compilation flags definitions */
|
||||
CFLAGS_NORMAL = -g EXTRA_CC_FLAGS
|
||||
CFLAGS_PROFILE = -g -pg -DUSE_MONCONTROL EXTRA_CC_FLAGS
|
||||
CFLAGS_OPTIMIZE = -O -DOPTIMIZE EXTRA_CC_FLAGS
|
||||
|
||||
/* Actual compilation flags and compiler definition */
|
||||
! CFLAGS = $(CFLAGS_NORMAL) $(READLINEDEF)
|
||||
|
||||
|
||||
|
||||
--- 121,130 ----
|
||||
/* Compilation flags definitions */
|
||||
CFLAGS_NORMAL = -g EXTRA_CC_FLAGS
|
||||
CFLAGS_PROFILE = -g -pg -DUSE_MONCONTROL EXTRA_CC_FLAGS
|
||||
CFLAGS_OPTIMIZE = -O -DOPTIMIZE EXTRA_CC_FLAGS
|
||||
|
||||
/* Actual compilation flags and compiler definition */
|
||||
! CFLAGS = $(CFLAGS_OPTIMIZE) $(READLINEDEF)
|
||||
|
||||
--- lib/Makefile.in.orig Fri Nov 28 22:28:12 1997
|
||||
+++ lib/Makefile.in Fri Nov 28 23:19:37 1997
|
||||
@@ -73,7 +73,7 @@
|
||||
LIB=@LIB_EXTENSION@
|
||||
|
||||
# optimization flag -- may become host dependent
|
||||
-OPT_FLAG = -O
|
||||
+#OPT_FLAG = -O
|
||||
CDEBUG = @CDEBUG@
|
||||
USER_OBJECTS = @USER_OBJECTS@
|
||||
|
||||
@@ -195,7 +195,6 @@
|
||||
$(INSTALL_DATA) libgst.$(LIB) $(smlibdir)/libgst.$(LIB)
|
||||
$(INSTALL_DATA) gst.h $(includedir)/gst.h
|
||||
$(INSTALL_DATA) gstpub.h $(includedir)/gstpub.h
|
||||
- $(INSTALL_DATA) config.h $(includedir)/config.h
|
||||
|
||||
uninstall:
|
||||
|
||||
|
@ -1,37 +1,57 @@
|
||||
|
||||
*** stix/Makefile.orig Thu Sep 12 15:11:30 1991
|
||||
--- stix/Makefile Sun Jun 2 17:51:14 1996
|
||||
***************
|
||||
*** 56,62 ****
|
||||
CPP = cc -E
|
||||
|
||||
# Uncomment this line to enable the ultra-winning readline-reader
|
||||
! #READLINE = -DUSE_READLINE
|
||||
|
||||
######################################################################
|
||||
######################################################################
|
||||
--- 56,62 ----
|
||||
CPP = cc -E
|
||||
|
||||
# Uncomment this line to enable the ultra-winning readline-reader
|
||||
! READLINE = -DUSE_READLINE
|
||||
|
||||
######################################################################
|
||||
######################################################################
|
||||
***************
|
||||
*** 88,94 ****
|
||||
|
||||
# Edit this to reflect the path on your system where the X include files
|
||||
# may be found.
|
||||
! XINCLUDE = /usr/include/X11
|
||||
|
||||
socket.o: socket.c
|
||||
$(CC) -I$(XINCLUDE) $(CFLAGS) -DUNIXCONN -c socket.c
|
||||
--- 88,94 ----
|
||||
|
||||
# Edit this to reflect the path on your system where the X include files
|
||||
# may be found.
|
||||
! XINCLUDE = /usr/X11R6/include
|
||||
|
||||
socket.o: socket.c
|
||||
$(CC) -I$(XINCLUDE) $(CFLAGS) -DUNIXCONN -c socket.c
|
||||
--- Makefile.in.orig Sun Sep 17 11:49:10 1995
|
||||
+++ Makefile.in Sat Nov 29 01:33:15 1997
|
||||
@@ -70,7 +70,7 @@
|
||||
COMPLETE_MAKE=@COMPLETE_MAKE@
|
||||
|
||||
# optimization flag -- may become host dependent
|
||||
-OPT_FLAG = -O
|
||||
+#OPT_FLAG = -O
|
||||
CDEBUG = @CDEBUG@
|
||||
USER_OBJECTS = @USER_OBJECTS@
|
||||
|
||||
@@ -90,7 +90,7 @@
|
||||
# Where to put the system-wide image file
|
||||
libdir = $(prefix)/lib
|
||||
smlibdir = $(libdir)/smalltalk
|
||||
-stdir = $(prefix)/smalltalk
|
||||
+stdir = $(libdir)/smalltalk
|
||||
|
||||
## Where to put the manual pages.
|
||||
#mandir = $(prefix)/man
|
||||
@@ -160,12 +160,12 @@
|
||||
Makefile.defs.in Makefile.rules \
|
||||
blox/Makefile.body \
|
||||
stix/Makefile.body tcp/Makefile.body test/Makefile.body \
|
||||
- cxtnsn/Makefile.body examples/Makefile.body contrib/Makefile.body \
|
||||
+ examples/Makefile.body contrib/Makefile.body \
|
||||
info/Makefile.body
|
||||
|
||||
|
||||
# Subdirectories to run make in for the primary targets.
|
||||
-SUBDIRS = lib stix blox info examples contrib cxtnsn test tcp
|
||||
+SUBDIRS = lib stix blox info examples contrib test tcp
|
||||
|
||||
# Only make TAGS/tags files in these directories, in this order
|
||||
###TSUBDIRS= src lib
|
||||
@@ -197,7 +197,7 @@
|
||||
$(RM) gst
|
||||
$(CC) $(LDFLAGS) $(LDPATH) $(BINDING) -o $@ $(CFLAGS) $(CDEBUG) \
|
||||
$(OBJECTS) lib/libgst.a $(LIBS)
|
||||
- $(COMPLETE_MAKE)
|
||||
+# $(COMPLETE_MAKE)
|
||||
|
||||
# A hack to force this directory to be reevaluated.
|
||||
libgst.a:
|
||||
@@ -219,8 +219,10 @@
|
||||
# $(RM) junk.c xmakefile
|
||||
|
||||
installdirs:
|
||||
- $(SHELL) $(srcdir)/mkinstalldirs $(bindir) $(smlibdir) $(infodir) \
|
||||
- $(stdir)
|
||||
+ if [ ! -d $(smlibdir) ]; then \
|
||||
+ $(SHELL) $(srcdir)/mkinstalldirs $(bindir) $(smlibdir) $(infodir) \
|
||||
+ $(stdir); \
|
||||
+ fi
|
||||
|
||||
install:: installdirs all
|
||||
$(INSTALL_PROGRAM) gst $(bindir)/$(binprefix)gst
|
||||
|
@ -1,84 +1,126 @@
|
||||
lib/smalltalk/Arc.st
|
||||
lib/smalltalk/Array.st
|
||||
lib/smalltalk/ArrayedCollection.st
|
||||
lib/smalltalk/ArrayColl.st
|
||||
lib/smalltalk/Association.st
|
||||
lib/smalltalk/Atom.st
|
||||
lib/smalltalk/Autoload.st
|
||||
lib/smalltalk/Bag.st
|
||||
lib/smalltalk/Behavior.st
|
||||
lib/smalltalk/BlockContext.st
|
||||
lib/smalltalk/BlkContext.st
|
||||
lib/smalltalk/Boolean.st
|
||||
lib/smalltalk/Browser.st
|
||||
lib/smalltalk/BypassStream.st
|
||||
lib/smalltalk/ByteArray.st
|
||||
lib/smalltalk/ByteMemory.st
|
||||
lib/smalltalk/CDeclNode.st
|
||||
lib/smalltalk/CExpressionNode.st
|
||||
lib/smalltalk/CFuncs.st
|
||||
lib/smalltalk/CObject.st
|
||||
lib/smalltalk/CPP.st
|
||||
lib/smalltalk/CPStrConc.st
|
||||
lib/smalltalk/CPStrUnq.st
|
||||
lib/smalltalk/CParseType.st
|
||||
lib/smalltalk/CStruct.st
|
||||
lib/smalltalk/CSymbol.st
|
||||
lib/smalltalk/CSymbolTable.st
|
||||
lib/smalltalk/CTok.st
|
||||
lib/smalltalk/CToken.st
|
||||
lib/smalltalk/CTreeBuilder.st
|
||||
lib/smalltalk/CType.st
|
||||
lib/smalltalk/CTypeParser.st
|
||||
lib/smalltalk/Character.st
|
||||
lib/smalltalk/Class.st
|
||||
lib/smalltalk/ClassDescription.st
|
||||
lib/smalltalk/ClassDescr.st
|
||||
lib/smalltalk/Collection.st
|
||||
lib/smalltalk/CompiledMethod.st
|
||||
lib/smalltalk/CompildMeth.st
|
||||
lib/smalltalk/CompilerTokens.st
|
||||
lib/smalltalk/DLD.st
|
||||
lib/smalltalk/Date.st
|
||||
lib/smalltalk/Debugger.st
|
||||
lib/smalltalk/Delay.st
|
||||
lib/smalltalk/Dictionary.st
|
||||
lib/smalltalk/Drawable.st
|
||||
lib/smalltalk/ExpansionStream.st
|
||||
lib/smalltalk/ExpansionStreamStack.st
|
||||
lib/smalltalk/False.st
|
||||
lib/smalltalk/FileSegment.st
|
||||
lib/smalltalk/FileStream.st
|
||||
lib/smalltalk/Float.st
|
||||
lib/smalltalk/GC.st
|
||||
lib/smalltalk/IdentityDictionary.st
|
||||
lib/smalltalk/Fraction.st
|
||||
lib/smalltalk/Host.st
|
||||
lib/smalltalk/IOCtl.st
|
||||
lib/smalltalk/IdentDict.st
|
||||
lib/smalltalk/IndentedStream.st
|
||||
lib/smalltalk/Integer.st
|
||||
lib/smalltalk/Interval.st
|
||||
lib/smalltalk/LineStream.st
|
||||
lib/smalltalk/LineToTokenStream.st
|
||||
lib/smalltalk/LineTokenStream.st
|
||||
lib/smalltalk/Link.st
|
||||
lib/smalltalk/LinkedList.st
|
||||
lib/smalltalk/LookupKey.st
|
||||
lib/smalltalk/Magnitude.st
|
||||
lib/smalltalk/MappedCollection.st
|
||||
lib/smalltalk/MappedColl.st
|
||||
lib/smalltalk/Memory.st
|
||||
lib/smalltalk/Message.st
|
||||
lib/smalltalk/Metaclass.st
|
||||
lib/smalltalk/MethodContext.st
|
||||
lib/smalltalk/MethodInfo.st
|
||||
lib/smalltalk/MthContext.st
|
||||
lib/smalltalk/Number.st
|
||||
lib/smalltalk/Object.st
|
||||
lib/smalltalk/OrderedCollection.st
|
||||
lib/smalltalk/Pen.st
|
||||
lib/smalltalk/Pixmap.st
|
||||
lib/smalltalk/OrderColl.st
|
||||
lib/smalltalk/ParseNodes.st
|
||||
lib/smalltalk/Parser.st
|
||||
lib/smalltalk/Point.st
|
||||
lib/smalltalk/PositionableStream.st
|
||||
lib/smalltalk/PosStream.st
|
||||
lib/smalltalk/ProcSched.st
|
||||
lib/smalltalk/Process.st
|
||||
lib/smalltalk/ProcessorScheduler.st
|
||||
lib/smalltalk/PushBackStream.st
|
||||
lib/smalltalk/RParseNodes.st
|
||||
lib/smalltalk/RWStream.st
|
||||
lib/smalltalk/Random.st
|
||||
lib/smalltalk/ReadStream.st
|
||||
lib/smalltalk/ReadWriteStream.st
|
||||
lib/smalltalk/Rectangle.st
|
||||
lib/smalltalk/STCompLit.st
|
||||
lib/smalltalk/STCompiler.st
|
||||
lib/smalltalk/STSymTable.st
|
||||
lib/smalltalk/STVarDefn.st
|
||||
lib/smalltalk/Semaphore.st
|
||||
lib/smalltalk/SequenceableCollection.st
|
||||
lib/smalltalk/SeqCollect.st
|
||||
lib/smalltalk/Set.st
|
||||
lib/smalltalk/SharedQueue.st
|
||||
lib/smalltalk/SortedCollection.st
|
||||
lib/smalltalk/SortCollect.st
|
||||
lib/smalltalk/Stream.st
|
||||
lib/smalltalk/StreamStack.st
|
||||
lib/smalltalk/String.st
|
||||
lib/smalltalk/SymLink.st
|
||||
lib/smalltalk/Symbol.st
|
||||
lib/smalltalk/SystemDictionary.st
|
||||
lib/smalltalk/TextItem.st
|
||||
lib/smalltalk/SysDict.st
|
||||
lib/smalltalk/Time.st
|
||||
lib/smalltalk/Token.st
|
||||
lib/smalltalk/TokenStream.st
|
||||
lib/smalltalk/True.st
|
||||
lib/smalltalk/UndefinedObject.st
|
||||
lib/smalltalk/Window.st
|
||||
lib/smalltalk/UndefObject.st
|
||||
lib/smalltalk/UnixStream.st
|
||||
lib/smalltalk/Variable.st
|
||||
lib/smalltalk/WordMemory.st
|
||||
lib/smalltalk/WriteStream.st
|
||||
lib/smalltalk/X.st
|
||||
lib/smalltalk/XPacket.st
|
||||
lib/smalltalk/Xerr.st
|
||||
lib/smalltalk/Xevt.st
|
||||
lib/smalltalk/builtins.st
|
||||
lib/smalltalk/error.st
|
||||
lib/smalltalk/event.st
|
||||
lib/smalltalk/generr.st
|
||||
lib/smalltalk/genevt.st
|
||||
lib/smalltalk/changes.st
|
||||
lib/smalltalk/cpt.st
|
||||
lib/smalltalk/dev-t.st
|
||||
lib/smalltalk/dldtst.st
|
||||
lib/smalltalk/eval.st
|
||||
lib/smalltalk/fileout-ps.st
|
||||
lib/smalltalk/initialize.st
|
||||
lib/smalltalk/int.st
|
||||
lib/smalltalk/it.st
|
||||
lib/smalltalk/large-expr.st
|
||||
lib/smalltalk/mt.st
|
||||
lib/smalltalk/mt2.st
|
||||
lib/smalltalk/t.st
|
||||
bin/mst
|
||||
lib/smalltalk/tdl.st
|
||||
lib/smalltalk/testCPT.st
|
||||
lib/smalltalk/testXParse.st
|
||||
lib/smalltalk/testcompile.st
|
||||
lib/smalltalk/tok.st
|
||||
lib/smalltalk/tpars.st
|
||||
lib/smalltalk/tstCPT.st
|
||||
lib/smalltalk/tstdl2.st
|
||||
|
Loading…
Reference in New Issue
Block a user