- fix outdated dependencies, and address old api [1]
- while here address autoplist issue and sort python variables PR: 199108 [1] Submitted by: lantw44@gmail.com [1]
This commit is contained in:
parent
6f1a3799d4
commit
befaceeeff
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=383599
@ -2,7 +2,7 @@
|
||||
|
||||
PORTNAME= virt-manager
|
||||
PORTVERSION= 1.1.0
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= deskutils net-mgmt
|
||||
MASTER_SITES= http://virt-manager.org/download/sources/${PORTNAME}/ \
|
||||
LOCAL/jgh/deskutils/${PORTNAME}/
|
||||
@ -15,20 +15,20 @@ LICENSE= LGPL3
|
||||
LIB_DEPENDS= libvirt.so:${PORTSDIR}/devel/libvirt
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>=0.83.2:${PORTSDIR}/devel/py-dbus \
|
||||
${PYTHON_PKGNAMEPREFIX}libxml2>=2.7.8:${PORTSDIR}/textproc/py-libxml2 \
|
||||
${PYTHON_PKGNAMEPREFIX}vte>=0.26.2:${PORTSDIR}/x11-toolkits/py-vte \
|
||||
vte3>=0:${PORTSDIR}/x11-toolkits/vte3 \
|
||||
${PYTHON_PKGNAMEPREFIX}ipaddr>=0:${PORTSDIR}/devel/py-ipaddr \
|
||||
${PYTHON_PKGNAMEPREFIX}urlgrabber>=0:${PORTSDIR}/www/py-urlgrabber \
|
||||
${PYTHON_PKGNAMEPREFIX}libvirt>=0:${PORTSDIR}/devel/py-libvirt \
|
||||
gtk-vnc>=0.4.4:${PORTSDIR}/net/gtk-vnc \
|
||||
libvirt-glib>=0.1.9:${PORTSDIR}/devel/libvirt-glib \
|
||||
libosinfo>=0:${PORTSDIR}/devel/libosinfo \
|
||||
${PYTHON_PKGNAMEPREFIX}spice-gtk>=0.26:${PORTSDIR}/deskutils/py-spice-gtk
|
||||
spice-gtk>=0.26:${PORTSDIR}/deskutils/spice-gtk
|
||||
|
||||
PYDISTUTILS_INSTALLNOSINGLE= yes
|
||||
PYDISTUTILS_CONFIGURE_TARGET= configure
|
||||
PYDISTUTILS_CONFIGUREARGS= --prefix=${PREFIX}
|
||||
USES= python:2.7 gettext shebangfix
|
||||
USE_PYTHON= distutils autoplist
|
||||
USE_PYTHON= autoplist distutils
|
||||
|
||||
USE_GNOME= introspection:run intltool librsvg2 pygobject3
|
||||
|
||||
@ -41,4 +41,11 @@ SHEBANG_FILES= virt-manager \
|
||||
|
||||
GLIB_SCHEMAS= org.virt-manager.virt-manager.gschema.xml
|
||||
|
||||
#add workaround for two autoplist functions
|
||||
post-install:
|
||||
@${MKDIR} ${STAGEDIR}/${PREFIX}/share/glib-2.0/schemas/
|
||||
.for file in ${GLIB_SCHEMAS}
|
||||
${INSTALL_DATA} ${WRKSRC}/data/${file} ${STAGEDIR}/${PREFIX}/share/glib-2.0/schemas
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -15,8 +15,12 @@
|
||||
class my_install(install):
|
||||
"""
|
||||
Error if we weren't 'configure'd with the correct install prefix
|
||||
@@ -605,7 +597,7 @@ setup(
|
||||
["data/org.virt-manager.virt-manager.gschema.xml"]),
|
||||
@@ -601,11 +593,9 @@ setup(
|
||||
"virt-convert",
|
||||
"virt-xml",
|
||||
]),
|
||||
- ("share/glib-2.0/schemas",
|
||||
- ["data/org.virt-manager.virt-manager.gschema.xml"]),
|
||||
("share/virt-manager/ui", glob.glob("ui/*.ui")),
|
||||
|
||||
- ("share/man/man1", [
|
||||
@ -24,7 +28,7 @@
|
||||
"man/virt-manager.1",
|
||||
"man/virt-install.1",
|
||||
"man/virt-clone.1",
|
||||
@@ -627,7 +619,6 @@ setup(
|
||||
@@ -627,7 +617,6 @@ setup(
|
||||
|
||||
'sdist': my_sdist,
|
||||
'install': my_install,
|
||||
|
10
deskutils/virt-manager/files/patch-virtManager_serialcon.py
Normal file
10
deskutils/virt-manager/files/patch-virtManager_serialcon.py
Normal file
@ -0,0 +1,10 @@
|
||||
--- virtManager/serialcon.py.orig 2014-07-28 15:11:32 UTC
|
||||
+++ virtManager/serialcon.py
|
||||
@@ -326,7 +326,6 @@ class vmmSerialConsole(vmmGObject):
|
||||
self.terminal = Vte.Terminal()
|
||||
self.terminal.set_scrollback_lines(1000)
|
||||
self.terminal.set_audible_bell(False)
|
||||
- self.terminal.set_visible_bell(True)
|
||||
|
||||
self.terminal.connect("button-press-event", self.show_serial_rcpopup)
|
||||
self.terminal.connect("commit", self.console.send_data, self.terminal)
|
Loading…
Reference in New Issue
Block a user