Update to version 0.35.

This commit is contained in:
Dmitry Sivachenko 2004-08-30 07:53:36 +00:00
parent d518379496
commit bedd96759b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=117633
6 changed files with 70 additions and 53 deletions

View File

@ -118,6 +118,7 @@ IF_FREETDS= "@comment "
.if defined(WITH_GTK) && ${WITH_GTK:L} != no
LIB_DEPENDS+= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
CONFIGURE_ARGS+= --with-gtk-prefix="${X11BASE}"
IF_GTK= ""
.else
@ -143,10 +144,6 @@ post-patch:
-e 's,/usr/local[[:>:]],${PREFIX},g;' \
-e 's,[[:<:]]gtk-config[[:>:]],${GTK_CONFIG:T},g;' \
${WRKSRC}/configure
${REINPLACE_CMD} -E \
-e 's,\.so\.\$$\(SQLR_VERSION\),\.so\.$$(basename $$(SQLR_VERSION)),g;' \
${WRKSRC}/src/api/c/src/Makefile \
${WRKSRC}/src/api/c++/src/Makefile
${FIND} ${WRKSRC} -name Makefile | ${XARGS} ${REINPLACE_CMD} -E \
-e 's#-release \$$\(SQLR_VERSION\)##g;'

View File

@ -1,7 +1,7 @@
# $FreeBSD$
SQLRELAY_PORTNAME= sqlrelay
SQLRELAY_PORTVERSION= 0.34.3
SQLRELAY_PORTVERSION= 0.35
SQLRELAY_PORTDIR= ${PORTSDIR}/databases/${SQLRELAY_PORTNAME}
SQLRELAY_WRKSRC_CMD= cd ${SQLRELAY_PORTDIR} && ${MAKE} -V WRKSRC

View File

@ -1,2 +1,2 @@
MD5 (sqlrelay-0.34.3.tar.gz) = dcfae19e69a406ea308f76af299f76f2
SIZE (sqlrelay-0.34.3.tar.gz) = 1398753
MD5 (sqlrelay-0.35.tar.gz) = 78588e6ef2646c1b7e45f65d36b06381
SIZE (sqlrelay-0.35.tar.gz) = 1518758

View File

@ -0,0 +1,13 @@
--- Makefile.orig Thu Aug 5 18:46:10 2004
+++ Makefile Mon Aug 30 11:02:44 2004
@@ -27,8 +27,8 @@
$(MAKE) -C man install
$(MAKE) -C doc install
$(MKINSTALLDIRS) $(libdir)/pkgconfig
- $(INSTALL) -m 0644 sqlrelay-c.pc $(libdir)/pkgconfig/sqlrelay-c.pc
- $(INSTALL) -m 0644 sqlrelay-c++.pc $(libdir)/pkgconfig/sqlrelay-c++.pc
+ $(INSTALL) -m 0644 sqlrelay-c.pc $(prefix)/libdata/pkgconfig/sqlrelay-c.pc
+ $(INSTALL) -m 0644 sqlrelay-c++.pc $(prefix)/libdata/pkgconfig/sqlrelay-c++.pc
uninstall:
$(MAKE) -C src uninstall

View File

@ -1,6 +1,6 @@
--- configure.orig Mon Dec 22 02:27:22 2003
+++ configure Fri May 28 16:00:26 2004
@@ -19395,8 +19395,8 @@
--- configure.orig Thu Aug 5 10:05:11 2004
+++ configure Fri Aug 27 16:45:11 2004
@@ -19412,8 +19412,8 @@
HAVE_PTHREAD=""
@ -11,7 +11,29 @@
if ( test "$cross_compiling" = "yes" )
then
@@ -37573,13 +37573,7 @@
@@ -19447,8 +19447,8 @@
STATIC=""
HEADERSANDLIBSPATH=""
-eval "PTHREADINCLUDES=\"\""
-eval "PTHREADLIBS=\"\""
+#eval "PTHREADINCLUDES=\"\""
+#eval "PTHREADLIBS=\"\""
eval "PTHREADLIBPATH=\"\""
eval "PTHREADSTATIC=\"\""
if ( test -n "" )
@@ -20073,8 +20073,8 @@
INCLUDESTRING=`echo $INCLUDESTRING | sed -e "s|-I/usr/include$||g" -e "s|-I/usr/include ||g"`
LIBSTRING=`echo $LIBSTRING | sed -e "s|-L/usr/lib$||g" -e "s|-L/lib$||g" -e "s|-L/usr/lib ||g" -e "s|-L/lib ||g"`
-eval "PTHREADINCLUDES=\"$INCLUDESTRING\""
-eval "PTHREADLIBS=\"$LIBSTRING\""
+#eval "PTHREADINCLUDES=\"$INCLUDESTRING\""
+#eval "PTHREADLIBS=\"$LIBSTRING\""
eval "PTHREADLIBPATH=\"$LIBPATH\""
eval "PTHREADSTATIC=\"$STATIC\""
if ( test -n "" )
@@ -34699,13 +34699,7 @@
if ( test -n "$JAVAINCLUDES" )
then
@ -26,44 +48,7 @@
fi
fi
@@ -37958,14 +37952,14 @@
if ( test -n "$GTKPATH" )
then
-if ( test -r ""$GTKPATH/bin/gtk-config"" )
+if ( test -r ""$GTKPATH/bin/gtk12-config"" )
then
- eval "GTKCONFIG=\"$GTKPATH/bin/gtk-config\""
+ eval "GTKCONFIG=\"$GTKPATH/bin/gtk12-config\""
fi
else
- # Extract the first word of ""gtk-config"", so it can be a program name with args.
-set dummy "gtk-config"; ac_word=$2
+ # Extract the first word of ""gtk12-config"", so it can be a program name with args.
+set dummy "gtk12-config"; ac_word=$2
echo "$as_me:$LINENO: checking for $ac_word" >&5
echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6
if test "${ac_cv_prog_GTKCONFIG+set}" = set; then
@@ -37981,7 +37975,7 @@
test -z "$as_dir" && as_dir=.
for ac_exec_ext in '' $ac_executable_extensions; do
if $as_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
- ac_cv_prog_GTKCONFIG=""gtk-config""
+ ac_cv_prog_GTKCONFIG=""gtk12-config""
echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
break 2
fi
@@ -38003,7 +37997,7 @@
then
for i in "/usr/bin" "/usr/local/bin" "/usr/pkg/bin" "/usr/local/gtk/bin" "/usr/local/gtk+/bin" "/opt/sfw/bin"
do
- for j in "gtk-config" "gtk12-config" "gtk10-config"
+ for j in "gtk12-config" "gtk12-config" "gtk10-config"
do
if ( test -r ""$i/$j"" )
@@ -41269,7 +41263,7 @@
@@ -38362,7 +38356,7 @@
#define SQLR_VERSION "$SQLR_VERSION"
_ACEOF

View File

@ -39,6 +39,22 @@ include/sqlrelay/sqlrclient.h
include/sqlrelay/sqlrclientwrapper.h
@dirrm include/sqlrelay/private
@dirrm include/sqlrelay
lib/libmysql3sqlrelay.so.0
lib/libmysql3sqlrelay.so
lib/libmysql3sqlrelay.la
lib/libmysql3sqlrelay.a
lib/libmysql40sqlrelay.so.0
lib/libmysql40sqlrelay.so
lib/libmysql40sqlrelay.la
lib/libmysql40sqlrelay.a
lib/libmysql41sqlrelay.so.0
lib/libmysql41sqlrelay.so
lib/libmysql41sqlrelay.la
lib/libmysql41sqlrelay.a
lib/libmysql50sqlrelay.so.0
lib/libmysql50sqlrelay.so
lib/libmysql50sqlrelay.la
lib/libmysql50sqlrelay.a
lib/libsqlrclient.a
lib/libsqlrclient.la
lib/libsqlrclient.so
@ -63,6 +79,8 @@ lib/libsqlrutil.a
lib/libsqlrutil.la
lib/libsqlrutil.so
lib/libsqlrutil.so.0
libdata/pkgconfig/sqlrelay-c.pc
libdata/pkgconfig/sqlrelay-c++.pc
share/doc/sqlrelay/api/c++/sqlrclient.h.html
share/doc/sqlrelay/api/c/sqlrclientwrapper.h.html
share/doc/sqlrelay/api/java/allclasses-frame.html
@ -81,8 +99,8 @@ share/doc/sqlrelay/api/java/overview-tree.html
share/doc/sqlrelay/api/java/package-list
share/doc/sqlrelay/api/java/packages.html
share/doc/sqlrelay/api/java/stylesheet.css
share/doc/sqlrelay/api/perl/SQLRConnection.html
share/doc/sqlrelay/api/perl/SQLRCursor.html
share/doc/sqlrelay/api/perl/Connection.html
share/doc/sqlrelay/api/perl/Cursor.html
share/doc/sqlrelay/api/perl/SQLRelay.html
share/doc/sqlrelay/api/perl/perl.html
share/doc/sqlrelay/api/php/doc.html
@ -94,6 +112,9 @@ share/doc/sqlrelay/clientapis.html
share/doc/sqlrelay/configuring.html
share/doc/sqlrelay/connections.html
share/doc/sqlrelay/css/styles.css
share/doc/sqlrelay/dropin/mysql.html
share/doc/sqlrelay/dropin/postgresql.html
share/doc/sqlrelay/faq.html
share/doc/sqlrelay/gettingstarted/db2.html
share/doc/sqlrelay/gettingstarted/interbase.html
share/doc/sqlrelay/gettingstarted/lago.html
@ -104,8 +125,6 @@ share/doc/sqlrelay/gettingstarted/oracle.html
share/doc/sqlrelay/gettingstarted/oracle/linux/redhat/5/805.html
share/doc/sqlrelay/gettingstarted/oracle/linux/redhat/6/8i.html
share/doc/sqlrelay/gettingstarted/oracle/linux/redhat/7/8i.html
share/doc/sqlrelay/gettingstarted/oracle/linux/redhat/7/9i.html
share/doc/sqlrelay/gettingstarted/oracle/linux/redhat/9/9iR2.html
share/doc/sqlrelay/gettingstarted/oracle/linux/slackware/7/8i.html
share/doc/sqlrelay/gettingstarted/oracle/linux/slackware/8/8i.html
share/doc/sqlrelay/gettingstarted/oracle/linux/slackware/8/9i.html
@ -141,6 +160,8 @@ share/doc/sqlrelay/programming/zope/testzsqlmethod.gif
share/doc/sqlrelay/programming/zope/zsqlmethod.gif
share/doc/sqlrelay/programming/zope/zsqlmethodresultset.gif
share/doc/sqlrelay/running.html
share/doc/sqlrelay/tuning.html
share/doc/sqlrelay/windows.html
@dirrm sqlrelay/cache
@dirrm sqlrelay
@dirrm share/doc/sqlrelay/programming/zope
@ -158,6 +179,7 @@ share/doc/sqlrelay/running.html
@dirrm share/doc/sqlrelay/gettingstarted/oracle/linux
@dirrm share/doc/sqlrelay/gettingstarted/oracle
@dirrm share/doc/sqlrelay/gettingstarted
@dirrm share/doc/sqlrelay/dropin
@dirrm share/doc/sqlrelay/css
@dirrm share/doc/sqlrelay/api/ruby
@dirrm share/doc/sqlrelay/api/python