- update to 2.1.2, honour CC/CFLAGS and add LICENSE [1]

- while here [2]
  - use optionsNG for portdocs
  - use portsdocs and plist files in favor of pkg-plist file
  - remove unnecessary inclusion of bsd.port.pre.mk in favor of bsd.port.options.mk

PR:	ports/169141
Submitted by:	koobs.freebsd@gmail.com [1], jgh@ [2]
Approved by:	maintainer, matt@peterson.org
This commit is contained in:
Jason Helfman 2012-06-19 16:44:39 +00:00
parent fbc6ddc152
commit bed5423182
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=299645
4 changed files with 34 additions and 10 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= sortu
PORTVERSION= 2.1.0
PORTVERSION= 2.1.2
CATEGORIES= sysutils
MASTER_SITES= http://256.com/sources/sortu/ \
http://matt.peterson.org/FreeBSD/ports/
@ -15,17 +15,22 @@ EXTRACT_SUFX= .tgz
MAINTAINER= matt@peterson.org
COMMENT= Tool that combines sort and uniq functionality
LICENSE= ISCL
PORTDOCS= *
PLIST_FILES= bin/sortu
ALL_TARGET= sortu
.include <bsd.port.pre.mk>
.include <bsd.port.options.mk>
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/sortu ${PREFIX}/bin
post-install:
.if !defined(NOPORTDOCS)
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
SHA256 (sortu-2.1.0.tgz) = 009aee18702dcf70270d5363254411fab83691a92fcf84055f69e52c7c772a95
SIZE (sortu-2.1.0.tgz) = 56365
SHA256 (sortu-2.1.2.tgz) = eb42c4bc314996db27e0db7d7f04432ddf6ce2f34a316b1d3f2c4ba89c165ead
SIZE (sortu-2.1.2.tgz) = 54396

View File

@ -0,0 +1,22 @@
--- ./Makefile.orig 2012-06-16 16:54:07.000000000 +1000
+++ ./Makefile 2012-06-16 16:54:52.000000000 +1000
@@ -2,7 +2,7 @@
# $Id: Makefile,v 1.7 2011-11-15 18:55:19 gray Exp $
#
-CC = cc
+CC ?= cc
PROG = sortu
OBJS = sortu.o argv.o strsep.o table.o
@@ -10,8 +10,8 @@
PORTFLS = README.txt LICENSE.txt Makefile ChangeLog test_sortu.sh \
sortu.c strsep.[ch] argv.[ch] argv_loc.h table.[ch] table_loc.h
-CFLAGS = -g -Wall -O2 $(CCFLS)
-DESTDIR = /usr/local/sbin
+CFLAGS ?= -g -Wall -O2 $(CCFLS)
+DESTDIR ?= /usr/local/sbin
all : $(PROG)

View File

@ -1,3 +0,0 @@
bin/sortu
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%@dirrm %%DOCSDIR%%