Remove print/lyx15, print/lyx has been updated to the latest version

This commit is contained in:
Max Brazhnikov 2010-06-14 18:22:16 +00:00
parent 41852a73b2
commit beb83609c6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=256533
7 changed files with 1 additions and 1519 deletions

1
MOVED
View File

@ -4439,3 +4439,4 @@ emulators/linux_base-gentoo-stage1||2010-06-08|Expired: please use emulators/lin
emulators/linux_dist-gentoo-stage1||2010-06-08|Expired: please use emulators/linux_dist-gentoo-stage3
www/weave|www/firefox-sync|2010-06-09|Project was renamed
misc/freedialog||2010-06-10|Removed, has been in base for a decade
print/lyx15||2010-06-14|Removed, print/lyx has been updated to the latest version

View File

@ -1,97 +0,0 @@
# New ports collection makefile for: lyx
# Date created: Sa 12 Okt 1996 19:20:51 MET DST
# Whom: Andreas Klemm <andreas@klemm.gtn.com>
#
# $FreeBSD$
#
PORTNAME= lyx
PORTVERSION= 1.5.7
PORTREVISION= 4
CATEGORIES= print
MASTER_SITES= ftp://ftp.lyx.org/pub/lyx/stable/${PORTVERSION:R}.x/ \
ftp://ftp.planetmirror.com/pub/lyx/stable/${PORTVERSION:R}.x/ \
http://www-ftp.lip6.fr/ftp/pub/lyx/stable/${PORTVERSION:R}.x/ \
ftp://gd.tuwien.ac.at/publishing/tex/lyx/stable/${PORTVERSION:R}.x/ \
ftp://ftp.ntua.gr/pub/X11/LyX/stable/${PORTVERSION:R}.x/ \
http://sunsite.icm.edu.pl/pub/unix/editors/lyx/stable/${PORTVERSION:R}.x/ \
ftp://ftp.chg.ru/pub/X11/lyx/stable/${PORTVERSION:R}.x/ \
http://lyx.mirror.fr/stable/${PORTVERSION:R}.x/
MAINTAINER= ports@FreeBSD.org
COMMENT= Document processor interfaced with LaTeX (nearly WYSIWYG) (stable)
BUILD_DEPENDS= latex:${PORTSDIR}/print/teTeX-base
LIB_DEPENDS= boost_regex:${PORTSDIR}/devel/boost-libs
RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX-base \
${LOCALBASE}/share/texmf/tex/latex/prettyref/prettyref.sty:${PORTSDIR}/print/latex-prettyref \
${LOCALBASE}/lib/X11/fonts/texcm-ttf/cmex10.ttf:${PORTSDIR}/x11-fonts/texcm-ttf
OPTIONS= ASPELL "Utilize Aspell library" on \
AIKSAUR "Build Aiksaurus support (English thesaurus)" on \
NLS "Native language support" on
CONFLICTS= lyx-1.4.*
USE_BZIP2= yes
USE_QT_VER= 4
QT_COMPONENTS= gui corelib moc_build uic_build
USE_GNOME= gnometarget
USE_PERL5= yes
USE_PYTHON= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" LDFLAGS="${PTHREAD_LIBS}"
CONFIGURE_ARGS= --with-frontend=qt4 \
--without-included-boost \
--without-included-gettext \
--with-libiconv-prefix=${LOCALBASE} \
--with-extra-prefix=${LOCALBASE}
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
#ALL_TARGET= -j`${SYSCTL} -n hw.ncpu`
MAN1= lyx.1 tex2lyx.1 lyxclient.1
LATEST_LINK= lyx15
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_AIKSAUR)
LIB_DEPENDS+= Aiksaurus:${PORTSDIR}/textproc/aiksaurus
.else
CONFIGURE_ARGS+= --without-aiksaurus
.endif
.if defined(WITHOUT_ASPELL)
CONFIGURE_ARGS+= --without-aspell --without-pspell
.else
LIB_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
CONFIGURE_ARGS+= --with-pspell \
--with-pspell-lib="${LOCALBASE}/lib" \
--with-pspell-include="${LOCALBASE}/include"
.endif
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.else
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.endif
post-patch:
${REINPLACE_CMD} -e 's|boost/regex\.hpp|boost/cregex.hpp|' \
${WRKSRC}/src/support/filetools.cpp
check test:
# Running vendor's self-tests (currently known to fail):
${GMAKE} -C ${WRKSRC} check
post-install:
${LN} -sf ${DATADIR}/images/lyx.xpm ${PREFIX}/share/pixmaps/lyx.xpm
${MKDIR} ${PREFIX}/share/applications
${INSTALL_DATA} ${FILESDIR}/lyx.desktop \
${PREFIX}/share/applications
.include <bsd.port.post.mk>

View File

@ -1,3 +0,0 @@
MD5 (lyx-1.5.7.tar.bz2) = c6d5da09d0b49e41292843dfb6c12c07
SHA256 (lyx-1.5.7.tar.bz2) = 935cc3f7a099eba4e4a7296d79fe5102fb7ef2de20ab2b6164347fef8c70dba4
SIZE (lyx-1.5.7.tar.bz2) = 9454238

View File

@ -1,14 +0,0 @@
[Desktop Entry]
Version=1.0
Type=Application
Name=LyX 1.5
GenericName=Document Processor
Comment=Document Processor using LaTeX as backend
Exec=lyx %F
TryExec=lyx
Icon=lyx
StartupNotify=false
StartupWMClass=Lyx
Terminal=false
Categories=Office;WordProcessor;Qt;
MimeType=text/x-lyx;application/x-lyx;

View File

@ -1,54 +0,0 @@
--- src/support/fs_extras.cpp.orig 2007-05-29 02:27:45.000000000 +0400
+++ src/support/fs_extras.cpp 2009-03-23 17:40:47.000000000 +0300
@@ -97,10 +97,10 @@
int const infile = ::open(source.string().c_str(), O_RDONLY);
if (infile == -1) {
boost::throw_exception(
- filesystem_path_error(
+ basic_filesystem_error<path>(
"boost::filesystem::copy_file",
source, target,
- fs::lookup_errno(errno)));
+ boost::system::error_code(errno, boost::system::get_system_category())));
}
struct stat source_stat;
@@ -108,10 +108,10 @@
if (ret == -1) {
int err = errno;
::close(infile);
- boost::throw_exception(filesystem_path_error(
+ boost::throw_exception(basic_filesystem_error<path>(
"boost::filesystem::copy_file",
source, target,
- fs::lookup_errno(err)));
+ boost::system::error_code(err, boost::system::get_system_category())));
}
int const flags = O_WRONLY | O_CREAT | (noclobber ? O_EXCL : O_TRUNC);
@@ -121,10 +121,10 @@
int err = errno;
::close(infile);
boost::throw_exception(
- filesystem_path_error(
+ basic_filesystem_error<path>(
"boost::filesystem::copy_file",
source, target,
- fs::lookup_errno(err)));
+ boost::system::error_code(err, boost::system::get_system_category())));
}
std::size_t const buf_sz = 32768;
@@ -153,10 +153,10 @@
if (in == -1 || out == -1)
boost::throw_exception(
- filesystem_path_error(
+ basic_filesystem_error<path>(
"boost::filesystem::copy_file",
source, target,
- fs::lookup_errno(err)));
+ boost::system::error_code(err, boost::system::get_system_category())));
#endif
#ifdef BOOST_WINDOWS
if (::CopyFile(source.string().c_str(), target.string().c_str(), noclobber) == 0) {

View File

@ -1,13 +0,0 @@
LyX is a document processor interfaced with LaTeX, which gives both the
ease-of-use of a wordprocessor, and the flexibility and power of
LaTeX.
Quasi-WYSIWYG interface, many LaTeX styles and layouts automatically
generated. Speeds up learning LaTeX and makes complicated layouts
easy and intuitive. New features include spell-checking, international
character support, WYSIWYG graphics, tables, and equations.
Although LyX-1.5 is the most recent version, LyX-1.4.x remains the
default "lyx", because LyX-1.5 requries Qt4.
WWW: http://www.lyx.org/

File diff suppressed because it is too large Load Diff