Adding fhist version 1.1.

Utilities to maintain file history, do file comparisions and merges.

PR:		6445
Submitted by:	jkoshy
This commit is contained in:
Steve Price 2000-01-01 00:20:17 +00:00
parent 3de591d176
commit bea9d0332c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=24329
8 changed files with 115 additions and 0 deletions

View File

@ -43,6 +43,7 @@
SUBDIR += elftoaout
SUBDIR += f77flow
SUBDIR += fastcrc
SUBDIR += fhist
SUBDIR += flick
SUBDIR += fortran-utils
SUBDIR += fpp

29
devel/fhist/Makefile Normal file
View File

@ -0,0 +1,29 @@
# New ports collection makefile for: fhist
# Version required: 1.1
# Date created: Apr 23 1998
# Whom: <koshy@india.hp.com>
#
# $FreeBSD$
#
DISTNAME= fhist.1.1
PKGNAME= fhist-1.1
CATEGORIES= devel
MASTER_SITES= ftp://archie.au/unix/Aegis/ \
http://www.canb.auug.org.au/~millerp/ \
ftp://ftp.agso.gov.au/pub/Aegis/ \
ftp://ftp.u-aizu.ac.jp/pub/misc/tools/Aegis/ \
http://gd.tuwien.ac.at/softeng/Aegis/
MAINTAINER= koshy@india.hp.com
MAN1= fcomp.1 fhist.1 fmerge.1
GNU_CONFIGURE= yes
post-install:
.for file in fhist fcomp fmerge
strip ${PREFIX}/bin/${file}
.endfor
.include <bsd.port.mk>

1
devel/fhist/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (fhist.1.1.tar.gz) = 4ff344982859003078e853f387a5493b

View File

@ -0,0 +1,24 @@
--- common/compare.c-- Fri Oct 7 18:05:04 1994
+++ common/compare.c Thu Apr 23 12:53:41 1998
@@ -326,10 +326,10 @@
}
-static int isblank _((char *s));
+static int isblank_ _((char *s));
static int
-isblank(s)
+isblank_(s)
char *s;
{
while (*s)
@@ -387,7 +387,7 @@
((linenumber % READBLABINTERVAL) == 0)
)
error("[%ld lines]", linenumber);
- if (fc.blankflag && isblank(cp))
+ if (fc.blankflag && isblank_(cp))
continue;
if (linecount >= linesavail)
{

View File

@ -0,0 +1,38 @@
--- fhist/breaks.c~ Fri Oct 7 18:05:04 1994
+++ fhist/breaks.c Wed Apr 29 09:25:29 1998
@@ -23,13 +23,34 @@
* MANIFEST: Unix-specific routines to implement special actions.
*/
+#ifdef HAVE_SYS_PARAM_H
+#include <sys/param.h>
+#endif
+
#include <signal.h>
#include <breaks.h>
-#if defined(sun) || defined(__sun__)
+#if defined(sun) || defined(__sun__)
#define sighold(n)
#define sigrelse(n)
+#elif (defined(BSD) && (BSD > 199306))
+/* POSIX handling, assumed present from 4.4 days */
+/* Will this be valid for {Open,Net}BSD too? */
+#define sighold(n) \
+ do { \
+ sigset_t set; \
+ (void) sigemptyset(&set); \
+ (void) sigaddset(&set, (n)); \
+ (void) sigprocmask(SIG_BLOCK, &set, (void *)0); \
+ } while(0)
+#define sigrelse(n) \
+ do { \
+ sigset_t set; \
+ (void) sigemptyset(&set); \
+ (void) sigaddset(&set, (n)); \
+ (void) sigprocmask(SIG_UNBLOCK, &set, (void *)0); \
+ } while (0)
#endif

1
devel/fhist/pkg-comment Normal file
View File

@ -0,0 +1 @@
Utilities to maintain file history, do file comparisions and merges

18
devel/fhist/pkg-descr Normal file
View File

@ -0,0 +1,18 @@
This package contains three source control utilities from Peter Miller
<millerp@canb.auug.org.au>:
fhist: Keeps track of versions of a file.
fcomp: Compares two versions of a file.
fmerge: Merges together edits from two descendants of a file.
This program is based on the algorithm in ``An O(ND) Difference
Algorithm and Its Variations'', Eugene W. Myers, TR 85-6, 10-April-1985,
Department of Computer Science, The University of Arizona, Tuscon,
Arizona 85721.
See also: ``A File Comparison Program, Webb Miller and Eugene W.
Myers'', Software Practice and Experience, Volume 15, No. 11,
November 1985.
- Koshy
<jkoshy@acm.org>

3
devel/fhist/pkg-plist Normal file
View File

@ -0,0 +1,3 @@
bin/fcomp
bin/fhist
bin/fmerge