gitea: Update to 1.12.2
This release fixes a large number of bugs and introduces many new features. Release notes: - https://blog.gitea.io/2020/06/gitea-1.12.0-and-1.12.1-are-released/ - https://blog.gitea.io/2020/07/gitea-1.12.2-is-released/ Additional changes to the port: - Use PORTDATA to avoid enumerating the extensive DATADIR - Add option to rc file for custom path [1] - Turn the BINDATA option on by default PR: 247613, 247989 [1] Submitted by: maintainer, mikeg bsd-box net [1] Approved by: maintainer [1]
This commit is contained in:
parent
890fcdd7d2
commit
bea827cf4c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=542495
@ -2,11 +2,10 @@
|
||||
|
||||
PORTNAME= gitea
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 1.11.8
|
||||
DISTVERSION= 1.12.2
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= https://github.com/go-gitea/gitea/releases/download/${DISTVERSIONPREFIX}${DISTVERSION}/
|
||||
DISTNAME= gitea-src-${DISTVERSION}
|
||||
NO_WRKSUBDIR= yes
|
||||
|
||||
MAINTAINER= stb@lassitu.de
|
||||
COMMENT= Compact self-hosted Git service
|
||||
@ -18,6 +17,8 @@ RUN_DEPENDS= git:devel/git
|
||||
|
||||
USES= gmake go:no_targets
|
||||
USE_RC_SUBR= gitea
|
||||
NO_WRKSUBDIR= yes
|
||||
PORTDATA= *
|
||||
|
||||
SUB_FILES+= app.ini.sample
|
||||
SUB_LIST+= GITUSER=${USERS}
|
||||
@ -49,9 +50,6 @@ DAEMONARGS= -f
|
||||
SUB_LIST+= DAEMONARGS="${DAEMONARGS}"
|
||||
|
||||
SSP_UNSAFE= true
|
||||
# use sane defaults for path, overriden with actual PREFIX in start script
|
||||
EXTRA_LDFLAGS= -X code.gitea.io/gitea/modules/setting.CustomPath=${PREFIX}/etc/gitea
|
||||
EXTRA_LDFLAGS+= -X code.gitea.io/gitea/modules/setting.AppWorkPath=${PREFIX}/share/gitea
|
||||
# Default LDFLAGS are incompatible with build
|
||||
MAKE_ENV= LDFLAGS="${LDFLAGS} ${EXTRA_LDFLAGS}"
|
||||
MAKE_ARGS= GOPATH=${WRKDIR} TAGS="${GO_TAGS}"
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1593337278
|
||||
SHA256 (gitea-src-1.11.8.tar.gz) = f4f965bd8f7da9320b6693c249eab07ff8baf5ef81649fd9025133f91391bab8
|
||||
SIZE (gitea-src-1.11.8.tar.gz) = 68927493
|
||||
TIMESTAMP = 1595065693
|
||||
SHA256 (gitea-src-1.12.2.tar.gz) = 695dae81327bdfaa4adaa9d3dc9d2bdcb78d54ac73abac3a630750465858ff8b
|
||||
SIZE (gitea-src-1.12.2.tar.gz) = 135139394
|
||||
|
@ -22,6 +22,7 @@ load_rc_config $name
|
||||
: ${gitea_facility:="daemon"}
|
||||
: ${gitea_priority:="debug"}
|
||||
: ${gitea_shared:="%%PREFIX%%/share/${name}"}
|
||||
: ${gitea_custom:="%%PREFIX%%/etc/${name}"}
|
||||
|
||||
command="%%PREFIX%%/sbin/${name} web"
|
||||
procname="%%PREFIX%%/sbin/${name}"
|
||||
@ -36,7 +37,7 @@ gitea_start() {
|
||||
-u ${gitea_user} -p ${pidfile} \
|
||||
/usr/bin/env -i \
|
||||
"GITEA_WORK_DIR=${gitea_shared}" \
|
||||
"GITEA_CUSTOM=%%PREFIX%%/etc/${name}" \
|
||||
"GITEA_CUSTOM=${gitea_custom}" \
|
||||
"HOME=${githome}" \
|
||||
"PATH=%%PREFIX%%/bin:${PATH}" \
|
||||
"USER=${gitea_user}" \
|
||||
|
@ -1,38 +0,0 @@
|
||||
# This patch fixes a bug where attempting to view branches with a / in the name
|
||||
# would return an HTTP 500 Internal Server Error. The underlying issue ended up
|
||||
# being that go-git implicitly relied on read() of a dirfd to succeed, so for a
|
||||
# branch named "stable/11" it would stop and assume "stable" was the ref, but it
|
||||
# was really just a directory.
|
||||
|
||||
# This patch was accepted upstream here:
|
||||
# https://github.com/go-git/go-git/pull/39
|
||||
# go-gitea is expected to merge it when go-git creates a new release for them to
|
||||
# import, and this patch can silently go away as soon as it conflicts.
|
||||
|
||||
--- vendor/github.com/go-git/go-git/v5/storage/filesystem/dotgit/dotgit.go.orig 2020-04-01 17:02:04 UTC
|
||||
+++ vendor/github.com/go-git/go-git/v5/storage/filesystem/dotgit/dotgit.go
|
||||
@@ -57,6 +57,9 @@ var (
|
||||
// targeting a non-existing object. This usually means the repository
|
||||
// is corrupt.
|
||||
ErrSymRefTargetNotFound = errors.New("symbolic reference target not found")
|
||||
+ // ErrIsDir is returned when a reference file is attempting to be read,
|
||||
+ // but the path specified is a directory.
|
||||
+ ErrIsDir = errors.New("reference path is a directory")
|
||||
)
|
||||
|
||||
// Options holds configuration for the storage.
|
||||
@@ -926,6 +929,14 @@ func (d *DotGit) addRefFromHEAD(refs *[]*plumbing.Refe
|
||||
|
||||
func (d *DotGit) readReferenceFile(path, name string) (ref *plumbing.Reference, err error) {
|
||||
path = d.fs.Join(path, d.fs.Join(strings.Split(name, "/")...))
|
||||
+ st, err := d.fs.Stat(path)
|
||||
+ if err != nil {
|
||||
+ return nil, err
|
||||
+ }
|
||||
+ if st.IsDir() {
|
||||
+ return nil, ErrIsDir
|
||||
+ }
|
||||
+
|
||||
f, err := d.fs.Open(path)
|
||||
if err != nil {
|
||||
return nil, err
|
@ -1,5 +1,5 @@
|
||||
[
|
||||
{ type: install
|
||||
{ type: upgrade
|
||||
maximum_version: 1.7.6
|
||||
message: <<EOM
|
||||
When upgrading from Gitea 1.7 or earlier, Gitea requires the addition of
|
||||
|
2686
www/gitea/pkg-plist
2686
www/gitea/pkg-plist
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user