www/edbrowse: Update 3.5.1 -> 3.7.3
Port changes: * alfix86@gmail.com takes maintainership * Change to DISTVERSION * Change MASTER_SITES to GitHub * Change from make to cmake * Add USES=perl5 and USE_PERL5=build * Add to and update LIB_DEPENDS * Add patches for the pull request fixing missing/wrong include statements * Replace pkg-plist with PLIST_FILES * Add PORTDOCS=* PR: 227517 Submitted by: Alfonso S. Siciliano <alfix86@gmail.com>
This commit is contained in:
parent
4314307085
commit
be9c76a068
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=467337
@ -1,44 +1,48 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= edbrowse
|
||||
PORTVERSION= 3.5.1
|
||||
PORTREVISION= 4
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 3.7.3
|
||||
CATEGORIES= www editors
|
||||
MASTER_SITES= http://the-brannons.com/edbrowse/ \
|
||||
http://rithmomachia.org/edbrowse/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
|
||||
PATCHFILES= 885fbc5f18ae61f9af9faa3e9d25c67a65148f6a.patch:-p1
|
||||
|
||||
MAINTAINER= alfix86@gmail.com
|
||||
COMMENT= Line-oriented Web browser and text editor
|
||||
|
||||
LICENSE= GPLv2
|
||||
|
||||
BUILD_DEPENDS= ${UNZIP_CMD}:archivers/unzip
|
||||
LIB_DEPENDS= libpcre.so:devel/pcre \
|
||||
libmozjs-24.so:lang/spidermonkey24 \
|
||||
libcurl.so:ftp/curl
|
||||
|
||||
BROKEN_powerpc64= fails to link: html.o: undefined reference to std::__cxx11::basic_string
|
||||
|
||||
USES= compiler:c11 readline zip ssl
|
||||
LIB_DEPENDS= libpcre.so:devel/pcre \
|
||||
libcurl.so:ftp/curl \
|
||||
libtidy.so:www/tidy-lib \
|
||||
libtidy5.so:www/tidy-html5 \
|
||||
libduktape.so:lang/duktape-lib
|
||||
|
||||
USES= cmake:outsource perl5 readline
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= CMB
|
||||
USE_PERL5= build
|
||||
|
||||
PLIST_FILES= bin/${PORTNAME} \
|
||||
man/man1/${PORTNAME}.1.gz
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
WRKBASE= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
WRKSRC= ${WRKBASE}/src
|
||||
PORTDOCS= *
|
||||
|
||||
MAKEFILE= makefile.bsd
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/edbrowse ${STAGEDIR}${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKBASE}/doc/man-edbrowse-debian.1 ${STAGEDIR}${MAN1PREFIX}/man/man1/edbrowse.1
|
||||
post-install:
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/man-edbrowse-debian.1 ${STAGEDIR}${MAN1PREFIX}/man/man1/${PORTNAME}.1
|
||||
|
||||
post-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKBASE}/CHANGES ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKBASE}/COPYING ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKBASE}/README ${STAGEDIR}${DOCSDIR}
|
||||
(cd ${WRKBASE}/doc && \
|
||||
${INSTALL_DATA} ${WRKSRC}/CHANGES ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/COPYING ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
|
||||
cd ${WRKSRC}/doc && \
|
||||
${FIND} . \( -name setup.ebrc -or -name "man-edbrowse*" \) -delete && \
|
||||
${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
|
||||
${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,5 @@
|
||||
SHA256 (edbrowse-3.5.1.zip) = e379cffb1098cfedf56ceedaaa7e20064551a0737ad6cd8ad5124fdfb18d9a5f
|
||||
SIZE (edbrowse-3.5.1.zip) = 745277
|
||||
TIMESTAMP = 1523728031
|
||||
SHA256 (CMB-edbrowse-v3.7.3_GH0.tar.gz) = ae7717c4c30297a01185ae2705fd55a7cd5f5484db05d5dfc02b7932b5766498
|
||||
SIZE (CMB-edbrowse-v3.7.3_GH0.tar.gz) = 707515
|
||||
SHA256 (885fbc5f18ae61f9af9faa3e9d25c67a65148f6a.patch) = b15a2931dccd85643450b50915ba877d24bec3b078daca2e4a41c23aaa660a93
|
||||
SIZE (885fbc5f18ae61f9af9faa3e9d25c67a65148f6a.patch) = 880
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- ../doc/man-edbrowse-debian.1.orig 2013-12-24 02:21:14.000000000 +0100
|
||||
+++ ../doc/man-edbrowse-debian.1 2014-01-08 08:11:24.295380172 +0100
|
||||
@@ -30,22 +30,17 @@
|
||||
--- doc/man-edbrowse-debian.1.orig 2018-04-14 14:29:56 UTC
|
||||
+++ doc/man-edbrowse-debian.1
|
||||
@@ -30,22 +30,17 @@ edbrowse \- text editor and web browser
|
||||
.I " ..."
|
||||
.LP
|
||||
.SH DESCRIPTION
|
||||
@ -26,23 +26,23 @@
|
||||
.PP
|
||||
If
|
||||
.BR edbrowse
|
||||
@@ -70,9 +65,9 @@
|
||||
@@ -70,9 +65,9 @@ for further details regarding the editing commands. Ex
|
||||
browsing functions can be found in the HTML documentation.
|
||||
.PP
|
||||
.SH EXAMPLES
|
||||
-To read the HTML documentation on a Debian system you can do
|
||||
+To read the HTML documentation you can do:
|
||||
.IP
|
||||
-.BR "edbrowse file:///usr/share/doc/edbrowse/edbdoc.html"
|
||||
-.BR "edbrowse file:///usr/share/doc/edbrowse/usersguide.html"
|
||||
+.BR "edbrowse /usr/local/share/doc/edbrowse/usersguide.html"
|
||||
.PP
|
||||
To read (say) 20 lines of the buffer at a time starting from
|
||||
the top use the command
|
||||
@@ -155,7 +150,7 @@
|
||||
@@ -155,7 +150,7 @@ configuration options and for details of the use of ed
|
||||
.IR pcrepattern (3).
|
||||
.PP
|
||||
The
|
||||
-.URL "/usr/share/doc/edbrowse/edbdoc.html" "HTML documentation" " "
|
||||
-.URL "/usr/share/doc/edbrowse/usersguide.html" "HTML documentation" " "
|
||||
+.URL "/usr/local/share/doc/edbrowse/usersguide.html" "HTML documentation" " "
|
||||
provides greater detail about the program.
|
||||
.PP
|
@ -1,25 +0,0 @@
|
||||
--- makefile.bsd.orig 2014-09-24 06:50:37.000000000 +0200
|
||||
+++ makefile.bsd 2014-11-15 21:16:45.051156527 +0100
|
||||
@@ -1,10 +1,11 @@
|
||||
# This is the makefile for edbrowse under BSD Unix.
|
||||
|
||||
# Flags for gcc compilation.
|
||||
-JS_CXXFLAGS =-I/usr/include/mozjs-24
|
||||
+JS_CXXFLAGS = -I${LOCALBASE}/include/mozjs-24
|
||||
|
||||
# we need to only use the js flags when building with c++, so use CXXFLAGS
|
||||
-CXXFLAGS += $(JS_CXXFLAGS)
|
||||
+CFLAGS += -I${LOCALBASE}/include
|
||||
+CXXFLAGS += $(CFLAGS) $(JS_CXXFLAGS)
|
||||
|
||||
# Tell the dynamic linker to look in the pkg area.
|
||||
LFLAGS = -s -Wl,--rpath -Wl,/usr/pkg/lib
|
||||
@@ -14,7 +15,7 @@
|
||||
JSLIB = -lmozjs-24
|
||||
|
||||
# Libraries for edbrowse.
|
||||
-LDLIBS = -lpcre -lm -lssl $(JSLIB) -lcurl -lreadline -lncurses -lcrypto -lstdc++
|
||||
+LIBS = -L${LOCALBASE}/lib -lpcre -lm -lssl $(JSLIB) -lcurl -lreadline -lncurses -lcrypto -lstdc++
|
||||
|
||||
# Make the dynamically linked executable program by default.
|
||||
# Edbrowse executable.
|
@ -1,12 +0,0 @@
|
||||
bin/edbrowse
|
||||
man/man1/edbrowse.1.gz
|
||||
%%PORTDOCS%%%%DOCSDIR%%/CHANGES
|
||||
%%PORTDOCS%%%%DOCSDIR%%/COPYING
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%%%DOCSDIR%%/philosophy.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/philosophy_fr.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/sample.ebrc
|
||||
%%PORTDOCS%%%%DOCSDIR%%/sample_fr.ebrc
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ssl-certs
|
||||
%%PORTDOCS%%%%DOCSDIR%%/usersguide.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/usersguide_fr.html
|
Loading…
Reference in New Issue
Block a user