Update to 2.2.

PR:		ports/53042
Submitted by:	Yoshihiko Sarumaru <mistral@imasy.or.jp>
This commit is contained in:
Norikatsu Shigemura 2003-06-08 12:16:52 +00:00
parent 1f6e6e79fe
commit be9289b42c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=82523
6 changed files with 24 additions and 57 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= stone
PORTVERSION= 2.1d
PORTVERSION= 2.2
CATEGORIES= net
MASTER_SITES= http://www.gcd.org/sengoku/stone/
@ -16,18 +16,31 @@ COMMENT= Stone is a TCP/IP packet repeater in the application layer
MAN1= ${PORTNAME}.1
MANLANG= "" ja
.include <bsd.port.pre.mk>
USE_REINPLACE= yes
pre-patch:
.if exists(/usr/bin/openssl)
.if exists(${PREFIX}/lib/libssl.so)
ALL_TARGET= bsd-ssl
EXTRA_PATCHES= ${FILESDIR}/base.patch
.elif exists(${PREFIX}/bin/openssl)
MAKE_ARGS= -e SSL_FLAGS="-DUSE_SSL -I${PREFIX}/include" SSL_LIBS="-L${PREFIX}/lib -lssl -lcrypto"
.elif exists(/usr/lib/libssl.so)
ALL_TARGET= bsd-ssl
EXTRA_PATCHES= ${FILESDIR}/ports.patch
MAKE_ARGS= -e SSL_FLAGS="-DUSE_SSL" SSL_LIBS="-lssl -lcrypto"
.else
ALL_TARGET= bsd-pop
@${ECHO} "You can build stone with SSL support by installing OpenSSL."
MAKE_ARGS= -e POP_LIBS="-lmd"
NEED_GLOBAL_H= yes
.endif
pre-everything::
.if ${ALL_TARGET} != bsd-ssl
@${ECHO_CMD} "You can build stone with SSL support by installing OpenSSL."
.endif
pre-patch:
${REINPLACE_CMD} -e "s/-D_THREAD_SAFE/${PTHREAD_CFLAGS}/g;s/-pthread/${PTHREAD_LIBS}/g" ${WRKSRC}/Makefile
pre-build:
.if defined(NEED_GLOBAL_H)
${TOUCH} ${WRKSRC}/global.h
.endif
do-install:
@ -35,4 +48,5 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/stone.1 ${PREFIX}/man/man1/stone.1
${INSTALL_MAN} ${WRKSRC}/stone.1.ja ${PREFIX}/man/ja/man1/stone.1
.include <bsd.port.post.mk>
#.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (stone-2.1d.tar.gz) = cc1bb4518fde5a5b843933c239248e97
MD5 (stone-2.2.tar.gz) = 70ae17e2d9a5d9310177468475554c23

View File

@ -1,13 +0,0 @@
--- Makefile.orig Thu Apr 26 15:25:03 2001
+++ Makefile Thu Apr 26 15:23:26 2001
@@ -15,8 +15,8 @@
# -DOS2 OS/2 with EMX
# -DWINDOWS Windows95/98/NT
-SSL_FLAGS= -DUSE_SSL -I/usr/local/ssl/include
-SSL_LIBS= -L/usr/local/ssl/lib -lssl -lcrypto
+SSL_FLAGS= -DUSE_SSL
+SSL_LIBS= -lssl -lcrypto
POP_FLAGS= -DUSE_POP
POP_LIBS= -lmd

View File

@ -1,11 +0,0 @@
--- Makefile.orig Thu Apr 26 15:28:17 2001
+++ Makefile Thu Apr 26 15:28:05 2001
@@ -19,7 +19,7 @@
SSL_LIBS= -L/usr/local/ssl/lib -lssl -lcrypto
POP_FLAGS= -DUSE_POP
-POP_LIBS= md5c.o
+POP_LIBS= -lmd
all:
@echo "run make with one of the following arguments"

View File

@ -1,10 +0,0 @@
--- stone.c.orig Thu Jun 14 22:00:00 2001
+++ stone.c Tue Jun 19 15:36:19 2001
@@ -249,7 +249,6 @@
char *cipher_list = NULL;
#else
#ifdef USE_POP
-#include "global.h"
#include "md5.h"
#endif
#endif

View File

@ -1,13 +0,0 @@
--- Makefile.orig Thu Apr 26 15:25:03 2001
+++ Makefile Thu Apr 26 15:27:36 2001
@@ -15,8 +15,8 @@
# -DOS2 OS/2 with EMX
# -DWINDOWS Windows95/98/NT
-SSL_FLAGS= -DUSE_SSL -I/usr/local/ssl/include
-SSL_LIBS= -L/usr/local/ssl/lib -lssl -lcrypto
+SSL_FLAGS= -DUSE_SSL -I$(PREFIX)/include
+SSL_LIBS= -L$(PREFIX)/lib -lssl -lcrypto
POP_FLAGS= -DUSE_POP
POP_LIBS= -lmd