Update to 2.5.5

PR:		ports/86266
Submitted by:	KATO Tsuguru <tkato432@yahoo.com>
Approved by:	pav (mentor)
This commit is contained in:
Marcus Alves Grando 2005-09-17 20:34:23 +00:00
parent 19531ff7ba
commit be8c1fe942
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=143028
6 changed files with 56 additions and 5 deletions

View File

@ -7,7 +7,7 @@
#
PORTNAME= downloader
PORTVERSION= 2.5.4
PORTVERSION= 2.5.5
CATEGORIES= ftp
MASTER_SITES= http://www.krasu.ru/soft/chuchelo/files/ \
ftp://ftp.chg.ru/pub/X11/applications/Xdownloader/
@ -47,8 +47,17 @@ post-patch:
s|-lpthread||g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's| DOC||g ; \
s| share||g' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|MUTEX_TYPE_FAST|PTHREAD_MUTEX_NORMAL|g' \
${WRKSRC}/main/signal.cc
.if ${OSVERSION} < 500000
.for file in main/addr.cc main/dlist.cc main/ftpd.cc main/face/mywidget.cc
@${REINPLACE_CMD} -e 's|pass\.clear()|pass = ""|g ; \
s|user\.clear()|user = ""|g ; \
s|host\.clear()|host = ""|g ; \
s|file\.clear()|file = ""|g ; \
s|params\.clear()|params = ""|g ; \
s|tag\.clear()|tag = ""|g ; \
s|path\.clear()|path = ""|g' ${WRKSRC}/${file}
.endfor
.endif
post-install:
${INSTALL_MAN} ${WRKSRC}/DOC/nt.1 ${MANPREFIX}/man/man1

View File

@ -1,2 +1,2 @@
MD5 (d4x-2.5.4.tar.bz2) = c797a933a8de1503b069b6d2499da727
SIZE (d4x-2.5.4.tar.bz2) = 1549811
MD5 (d4x-2.5.5.tar.bz2) = ee3c7dc4618b6ead77a22685195fcf24
SIZE (d4x-2.5.5.tar.bz2) = 1556952

View File

@ -0,0 +1,10 @@
--- main/base64.cc.orig Fri Sep 16 13:32:16 2005
+++ main/base64.cc Fri Sep 16 23:03:23 2005
@@ -13,6 +13,7 @@
#include "base64.h"
#include <string.h>
#include <stdio.h>
+#include <inttypes.h>
char Table64[64]={ 'A','B','C','D','E','F','G','H',
'I','J','K','L','M','N','O','P',

View File

@ -0,0 +1,11 @@
--- main/cookie.cc.orig Tue Sep 13 19:59:44 2005
+++ main/cookie.cc Fri Sep 16 23:10:02 2005
@@ -109,7 +109,7 @@
};
void tCookie::set_time(const std::string &what){
- time_of_life=atoll(what.c_str());
+ time_of_life=strtoll(what.c_str(), (char **)NULL, 10);
};
void tCookie::init(char *a,char *b,char *c,char *d){

View File

@ -0,0 +1,11 @@
--- main/signal.cc.bak Fri Jul 2 00:41:31 2004
+++ main/signal.cc Fri Sep 16 22:58:09 2005
@@ -120,7 +120,7 @@
pthread_mutexattr_t ma;
pthread_mutexattr_init(&ma);
#if !defined (__sparc__) && !defined(__mips__)
- pthread_mutexattr_settype(&ma,MUTEX_TYPE_FAST);
+ pthread_mutexattr_settype(&ma,PTHREAD_MUTEX_NORMAL);
#elif defined(__mips__)
pthread_mutexattr_settype(&ma,MUTEX_TYPE_NORMAL);
#endif

View File

@ -0,0 +1,10 @@
--- main/sm.cc.orig Thu Sep 15 14:31:21 2005
+++ main/sm.cc Fri Sep 16 23:11:53 2005
@@ -10,6 +10,7 @@
*/
#include "sm.h"
+#include <algorithm>
#include <functional>
using namespace d4x;