Update to 3.14.1

This commit is contained in:
Max Brazhnikov 2014-01-23 08:39:00 +00:00
parent 12cffea301
commit be88475b80
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=340808
5 changed files with 71 additions and 40 deletions

View File

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= hplip
PORTVERSION= 3.13.6
PORTREVISION= 1
PORTVERSION= 3.14.1
CATEGORIES= print
MASTER_SITES= SF
@ -25,7 +24,7 @@ CONFLICTS_INSTALL= hpijs-[0-9]*
USE_GHOSTSCRIPT_RUN= yes
USE_PYTHON= yes
USE_GNOME= pygobject
USES= pkgconfig dos2unix
USES= dos2unix pkgconfig shebangfix
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-foomatic-ppd-install \
@ -38,6 +37,7 @@ CONFIGURE_ARGS= --enable-foomatic-ppd-install \
--with-hpppddir=${PREFIX}/share/ppd/HP \
--with-mimedir=${PREFIX}/etc/cups \
--with-docdir=${DOCSDIR} \
--with-htmldir=${DOCSDIR} \
--with-drvdir=${PREFIX}/libexec/cups/driver \
--enable-libusb01_build
CPPFLAGS+= -I${LOCALBASE}/include
@ -47,33 +47,41 @@ USE_LDCONFIG= yes
SUB_FILES= pkg-message
DOS2UNIX_REGEX=.+\.(c|cpp|h|py)$
SHEBANG_FILES= prnt/hpijs/foomatic-rip-hplip
FILES4FIX= Makefile.in \
base/codes.py \
base/g.py \
base/password.py \
base/pkit.py \
base/status.py \
base/queues.py \
base/services.py \
base/utils.py \
check.py \
fax/backend/hpfax.py \
fax/coverpages.py \
fax/filters/pstotiff \
hplip.list.in \
installer/core_install.py \
installer/dcheck.py \
installer/distros.dat \
installer/pluginhandler.py \
io/hpmud/hp-mkuri.c \
logcapture.py \
prnt/cups.py \
prnt/filters/hpps \
prnt/hpcups/HPCupsFilter.cpp \
prnt/hpcups/Utils.cpp \
prnt/hpijs/foomatic-rip-hplip \
prnt/hpijs/globals.cpp \
prnt/hpijs/hpcupsfax.cpp \
prnt/hpijs/hpijs.cpp \
setup.py \
ui/devmgr4.py \
ui/setupform.py \
ui4/devmgr5.py
PYTHON_SITELIBDIR_REL= ${PYTHONPREFIX_SITELIBDIR:S;${PREFIX}/;;}
STRIP_FILES= lib/libhpip.so.0 \
lib/libhpmud.so.0 \
${PYTHON_SITELIBDIR_REL}/pcardext.so \
${PYTHON_SITELIBDIR_REL}/hpmudext.so \
${PYTHON_SITELIBDIR_REL}/cupsext.so
OPTIONS_DEFINE= QT FAX SNMP SCAN XSANE DOCS
OPTIONS_DEFAULT= QT
OPTIONS_SUB= yes # QT FAX SCAN
@ -107,6 +115,9 @@ DOCS_CONFIGURE_ENABLE= doc-build
. if ${PORT_OPTIONS:MXSANE}
RUN_DEPENDS+= xsane:${PORTSDIR}/graphics/xsane
. endif
STRIP_FILES+= ${PYTHON_SITELIBDIR_REL}/scanext.so \
lib/sane/libsane-hpaio.so.1
.endif
post-patch:
@ -125,6 +136,7 @@ post-patch:
${WRKSRC}/Makefile.in
${REINPLACE_CMD} -e 's,/etc/hp,${PREFIX}&,g' \
-e 's,/etc/cups,${LOCALBASE}&,g' \
-e 's,/etc/foomatic,${LOCALBASE}&,g' \
-e 's,/etc/init.d,${LOCALBASE}/etc/rc.d,g' \
-e 's,/etc/sane.d,${LOCALBASE}&,g' \
-e 's,/usr/share,${LOCALBASE}/share,g' \
@ -134,7 +146,8 @@ post-patch:
${WRKSRC}/installer/core_install.py
${FIND} ${WRKSRC} -name '*.py' | ${XARGS} ${SED} -i '' \
-e 's,^#!/usr/bin/python,#!${PYTHON_CMD},' \
-e 's,^#!/usr/bin/env python,#!${PYTHON_CMD},'
-e 's,^#!/usr/bin/env python,#!${PYTHON_CMD},' \
-e 's,^#!/bin/env python,#!${PYTHON_CMD},'
.if !${PORT_OPTIONS:MDOCS}
${REINPLACE_CMD} -e '/[[:space:]]install-docDATA/ s|install-docDATA||' \
${WRKSRC}/Makefile.in
@ -147,5 +160,6 @@ post-install:
.endif
${MKDIR} ${STAGEDIR}${PREFIX}/etc/hp
${INSTALL_DATA} ${WRKSRC}/hplip.conf ${STAGEDIR}${PREFIX}/etc/hp/hplip.conf.sample
${STRIP_CMD} ${STRIP_FILES:S,^,${STAGEDIR}${PREFIX}/,}
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
SHA256 (hplip-3.13.6.tar.gz) = 86f4fd0accf25ce6d89aa415b3a987e7db410bf529e68b4138f90b1e9055f6c7
SIZE (hplip-3.13.6.tar.gz) = 20785825
SHA256 (hplip-3.14.1.tar.gz) = 5c1e79d4426c00c3eb7ec9b689c430ea3d132e23849c08ae3dc58cd8d3d0eb14
SIZE (hplip-3.14.1.tar.gz) = 21116532

View File

@ -1,22 +1,19 @@
diff -ru hplip-3.11.12.DIST/Makefile.in hplip-3.11.12/Makefile.in
--- Makefile.in 2011-12-09 12:23:55.000000000 +0100
+++ Makefile.in 2011-12-30 16:28:26.255313535 +0100
@@ -503,7 +503,7 @@
--- ./Makefile.in.orig 2014-01-08 09:33:45.000000000 +0000
+++ ./Makefile.in 2014-01-22 20:28:18.950635134 +0000
@@ -511,7 +511,7 @@
@HPIJS_INSTALL_TRUE@@HPLIP_BUILD_TRUE@ $(am__DEPENDENCIES_1)
hpijs_LINK = $(LIBTOOL) --tag=CXX $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
--mode=link $(CXXLD) $(hpijs_CXXFLAGS) $(CXXFLAGS) \
- $(AM_LDFLAGS) $(LDFLAGS) -o $@
+ $(AM_LDFLAGS) $(LDFLAGS) -Wl,--export-dynamic -o $@
am__hplipjs_SOURCES_DIST = prnt/filters/hplipjs.c
@FULL_BUILD_TRUE@@HPLIP_BUILD_TRUE@am_hplipjs_OBJECTS = \
@FULL_BUILD_TRUE@@HPLIP_BUILD_TRUE@ hplipjs.$(OBJEXT)
Only in hplip-3.11.12: dd
diff -ru hplip-3.11.12.DIST/prnt/hpijs/hpijs.cpp hplip-3.11.12/prnt/hpijs/hpijs.cpp
--- prnt/hpijs/hpijs.cpp 2011-12-09 12:18:33.000000000 +0100
+++ prnt/hpijs/hpijs.cpp 2011-12-30 16:27:10.976752128 +0100
@@ -43,6 +43,9 @@
#include "hpijs.h"
am__hppgsz_SOURCES_DIST = prnt/hpijs/PrinterProperties.cpp \
prnt/hpijs/PrinterProperties.h prnt/hpijs/bug.h
@FULL_BUILD_TRUE@@HPLIP_BUILD_TRUE@am_hppgsz_OBJECTS = hppgsz-PrinterProperties.$(OBJEXT)
--- ./prnt/hpijs/hpijs.cpp.orig 2014-01-08 09:28:31.000000000 +0000
+++ ./prnt/hpijs/hpijs.cpp 2014-01-22 20:27:15.921633756 +0000
@@ -44,6 +44,9 @@
#include "services.h"
#include "utils.h"
+#undef stderr;
+FILE *stderr;
@ -24,12 +21,11 @@ diff -ru hplip-3.11.12.DIST/prnt/hpijs/hpijs.cpp hplip-3.11.12/prnt/hpijs/hpijs.
extern void SendDbusMessage (const char *dev, const char *printer, int code,
const char *username, const int jobid, const char *title);
@@ -586,6 +589,7 @@
int status = EXIT_FAILURE;
@@ -590,6 +593,7 @@
int ret, n, i, kn=0, width, k_width;
char user_name[32]={0,};
+ stderr = __stderrp;
openlog("hpijs", LOG_PID, LOG_DAEMON);
if (argc > 1)

View File

@ -4,8 +4,8 @@
#include "ErnieFilter.h"
-#if defined(__APPLE__) || defined(__linux)
+#if defined(__APPLE__) || defined(__linux) || (__FreeBSD__)
-#if defined(__APPLE__) || defined(__linux) || defined(__GLIBC__) || defined(__NetBSD__)
+#if defined(__APPLE__) || defined(__linux) || defined(__GLIBC__) || defined(__NetBSD__) || (__FreeBSD__)
#include <math.h>
#endif

View File

@ -16,7 +16,6 @@ bin/hp-linefeedcal
bin/hp-logcapture
bin/hp-makecopies
bin/hp-makeuri
bin/hp-mkuri
bin/hp-pkservice
bin/hp-plugin
bin/hp-pqdiag
@ -63,10 +62,8 @@ libexec/cups/backend/hp
%%FAX%%libexec/cups/backend/hpfax
libexec/cups/driver/hpcups.drv
libexec/cups/filter/foomatic-rip-hplip
libexec/cups/filter/hpcac
libexec/cups/filter/hpcups
%%FAX%%libexec/cups/filter/hpcupsfax
libexec/cups/filter/hplipjs
libexec/cups/filter/hpps
libexec/cups/filter/pstotiff
%%QT%%share/applications/hplip.desktop
@ -108,6 +105,7 @@ libexec/cups/filter/pstotiff
%%DATADIR%%/align.py
%%DATADIR%%/base/LedmWifi.py
%%DATADIR%%/base/__init__.py
%%DATADIR%%/base/avahi.py
%%DATADIR%%/base/codes.py
%%DATADIR%%/base/device.py
%%DATADIR%%/base/dime.py
@ -135,6 +133,7 @@ libexec/cups/filter/pstotiff
%%DATADIR%%/base/strings.py
%%DATADIR%%/base/tui.py
%%DATADIR%%/base/utils.py
%%DATADIR%%/base/validation.py
%%DATADIR%%/base/vcard.py
%%DATADIR%%/base/wifi.py
%%DATADIR%%/check-plugin.py
@ -779,6 +778,11 @@ share/ppd/HP/hp-color_laserjet_cp5520_series-hpijs-pcl3.ppd.gz
share/ppd/HP/hp-color_laserjet_cp5520_series-ps.ppd.gz
share/ppd/HP/hp-color_laserjet_cp6015-hpijs-pcl3.ppd.gz
share/ppd/HP/hp-color_laserjet_cp6015-ps.ppd.gz
share/ppd/HP/hp-color_laserjet_flow_mfp_m880-ps.ppd.gz
share/ppd/HP/hp-color_laserjet_m750-ps.ppd.gz
share/ppd/HP/hp-color_laserjet_m855-ps.ppd.gz
share/ppd/HP/hp-color_laserjet_pro_mfp_m176n-hpijs.ppd.gz
share/ppd/HP/hp-color_laserjet_pro_mfp_m177fw-hpijs.ppd.gz
share/ppd/HP/hp-cp1160-hpijs.ppd.gz
share/ppd/HP/hp-designjet_4000ps.ppd.gz
share/ppd/HP/hp-designjet_4020ps-ps.ppd.gz
@ -794,6 +798,7 @@ share/ppd/HP/hp-designjet_t1200_postscript-ps.ppd.gz
share/ppd/HP/hp-designjet_t1300_postscript-ps.ppd.gz
share/ppd/HP/hp-designjet_t1500-postscript.ppd.gz
share/ppd/HP/hp-designjet_t2300_postscript-ps.ppd.gz
share/ppd/HP/hp-designjet_t2500-postscript.ppd.gz
share/ppd/HP/hp-designjet_t7100ps-ps.ppd.gz
share/ppd/HP/hp-designjet_t7100ps_monochrome-ps.ppd.gz
share/ppd/HP/hp-designjet_t770_postscript-ps.ppd.gz
@ -802,11 +807,13 @@ share/ppd/HP/hp-designjet_t790ps_24in-ps.ppd.gz
share/ppd/HP/hp-designjet_t790ps_44in-ps.ppd.gz
share/ppd/HP/hp-designjet_t920-postscript.ppd.gz
share/ppd/HP/hp-designjet_z5200_postscript-ps.ppd.gz
share/ppd/HP/hp-designjet_z5400-postscript.ppd.gz
share/ppd/HP/hp-designjet_z6100ps_42in_photo-ps.ppd.gz
share/ppd/HP/hp-designjet_z6100ps_60in_photo-ps.ppd.gz
share/ppd/HP/hp-designjet_z6200_42in_photo-ps.ppd.gz
share/ppd/HP/hp-designjet_z6200_60in_photo-ps.ppd.gz
share/ppd/HP/hp-deskjet_1000_j110_series-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_1010_series-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_1050_j410_series-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_1100-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_1120-hpijs.ppd.gz
@ -814,6 +821,7 @@ share/ppd/HP/hp-deskjet_1125-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_1200c-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_1220c-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_1280-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_1510_series-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_1600c-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_1600cm-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_1600cn-hpijs.ppd.gz
@ -822,6 +830,8 @@ share/ppd/HP/hp-deskjet_2020_series-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_2050_j510_series-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_2510_series-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_2520_series-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_2540_series-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_2640_series-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_3000_j310_series-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_3050_j610_series-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_3050a_j611_series-hpijs.ppd.gz
@ -834,6 +844,7 @@ share/ppd/HP/hp-deskjet_3450-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_3500-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_3510_series-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_3520_series-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_3540_series-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_3550-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_3600-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_3650-hpijs.ppd.gz
@ -851,6 +862,7 @@ share/ppd/HP/hp-deskjet_3920-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_3940-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_400-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_400l-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_4510_series-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_460-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_4610_series-hpijs.ppd.gz
share/ppd/HP/hp-deskjet_4620_series-hpijs.ppd.gz
@ -982,6 +994,7 @@ share/ppd/HP/hp-envy_100_d410_series-hpijs.ppd.gz
share/ppd/HP/hp-envy_110_series-hpijs.ppd.gz
share/ppd/HP/hp-envy_120_series-hpijs.ppd.gz
share/ppd/HP/hp-envy_4500_series-hpijs.ppd.gz
share/ppd/HP/hp-envy_5530_series-hpijs.ppd.gz
share/ppd/HP/hp-laserjet_1000-hpijs.ppd.gz
share/ppd/HP/hp-laserjet_1005_series-hpijs.ppd.gz
share/ppd/HP/hp-laserjet_100_color_mfp_m175-ps.ppd.gz
@ -1184,6 +1197,7 @@ share/ppd/HP/hp-laserjet_cp1520_series-ps.ppd.gz
share/ppd/HP/hp-laserjet_cp_1025-hpijs.ppd.gz
share/ppd/HP/hp-laserjet_cp_1025nw-hpijs.ppd.gz
share/ppd/HP/hp-laserjet_flow_mfp_m525-ps.ppd.gz
share/ppd/HP/hp-laserjet_flow_mfp_m830-ps.ppd.gz
share/ppd/HP/hp-laserjet_m1005-hpijs.ppd.gz
share/ppd/HP/hp-laserjet_m1120_mfp-hpijs.ppd.gz
share/ppd/HP/hp-laserjet_m1120n_mfp-hpijs.ppd.gz
@ -1212,6 +1226,7 @@ share/ppd/HP/hp-laserjet_m5025_mfp-ps.ppd.gz
share/ppd/HP/hp-laserjet_m5035_mfp-hpijs-pcl3.ppd.gz
share/ppd/HP/hp-laserjet_m5035_mfp-ps.ppd.gz
share/ppd/HP/hp-laserjet_m5039_mfp-hpijs-pcl3.ppd.gz
share/ppd/HP/hp-laserjet_m806-ps.ppd.gz
share/ppd/HP/hp-laserjet_m9040_mfp-hpijs-pcl3.ppd.gz
share/ppd/HP/hp-laserjet_m9040_mfp-ps.ppd.gz
share/ppd/HP/hp-laserjet_m9050_mfp-hpijs-pcl3.ppd.gz
@ -1267,6 +1282,9 @@ share/ppd/HP/hp-laserjet_p4515n-hpijs.ppd.gz
share/ppd/HP/hp-laserjet_p4515tn-hpijs.ppd.gz
share/ppd/HP/hp-laserjet_p4515x-hpijs.ppd.gz
share/ppd/HP/hp-laserjet_p4515xm-hpijs.ppd.gz
share/ppd/HP/hp-laserjet_pro_mfp_m127fn-hpijs.ppd.gz
share/ppd/HP/hp-laserjet_pro_mfp_m127fw-hpijs.ppd.gz
share/ppd/HP/hp-laserjet_pro_mfp_m435-ps.ppd.gz
share/ppd/HP/hp-laserjet_professional_m1132_mfp-hpijs.ppd.gz
share/ppd/HP/hp-laserjet_professional_m1136_mfp-hpijs.ppd.gz
share/ppd/HP/hp-laserjet_professional_m1137_mfp-hpijs.ppd.gz
@ -1310,6 +1328,7 @@ share/ppd/HP/hp-mopier_320-ps.ppd.gz
share/ppd/HP/hp-officejet-hpijs.ppd.gz
share/ppd/HP/hp-officejet_100_mobile_l411-hpijs.ppd.gz
share/ppd/HP/hp-officejet_150_mobile_l511-hpijs.ppd.gz
share/ppd/HP/hp-officejet_2620_series-hpijs.ppd.gz
share/ppd/HP/hp-officejet_4000_k210-hpijs.ppd.gz
share/ppd/HP/hp-officejet_4100_series-hpijs.ppd.gz
share/ppd/HP/hp-officejet_4105-hpijs.ppd.gz
@ -1324,6 +1343,7 @@ share/ppd/HP/hp-officejet_4500_g510n-z-hpijs.ppd.gz
share/ppd/HP/hp-officejet_4500_k710-hpijs.ppd.gz
share/ppd/HP/hp-officejet_4610_series-hpijs.ppd.gz
share/ppd/HP/hp-officejet_4620_series-hpijs.ppd.gz
share/ppd/HP/hp-officejet_4630_series-hpijs.ppd.gz
share/ppd/HP/hp-officejet_5100_series-hpijs.ppd.gz
share/ppd/HP/hp-officejet_5105-hpijs.ppd.gz
share/ppd/HP/hp-officejet_5110-hpijs.ppd.gz
@ -1351,6 +1371,7 @@ share/ppd/HP/hp-officejet_7200_series-hpijs.ppd.gz
share/ppd/HP/hp-officejet_7300_series-hpijs.ppd.gz
share/ppd/HP/hp-officejet_7400_series-hpijs.ppd.gz
share/ppd/HP/hp-officejet_7500_e910-hpijs.ppd.gz
share/ppd/HP/hp-officejet_7610_series-hpijs.ppd.gz
share/ppd/HP/hp-officejet_9100_series-hpijs-pcl3.ppd.gz
share/ppd/HP/hp-officejet_d_series-hpijs.ppd.gz
share/ppd/HP/hp-officejet_g55-hpijs.ppd.gz
@ -1569,11 +1590,11 @@ share/ppd/HP/hp-psc_950xi-hpijs.ppd.gz
@dirrm share/ppd
%%QT%%@dirrm %%DATADIR%%/ui4/plugins
%%QT%%@dirrm %%DATADIR%%/ui4
%%SCAN%%@dirrm %%DATADIR%%/scan
@dirrm %%DATADIR%%/prnt
%%SCAN%%@dirrmtry %%DATADIR%%/scan
@dirrmtry %%DATADIR%%/prnt
@dirrm %%DATADIR%%/pcard
@dirrm %%DATADIR%%/installer
%%FAX%%@dirrm %%DATADIR%%/fax
%%FAX%%@dirrmtry %%DATADIR%%/fax
@dirrm %%DATADIR%%/data/ps
@dirrm %%DATADIR%%/data/pcl
@dirrm %%DATADIR%%/data/models
@ -1588,10 +1609,10 @@ share/ppd/HP/hp-psc_950xi-hpijs.ppd.gz
%%QT%%@dirrm %%DATADIR%%/data/images/16x16
%%QT%%@dirrm %%DATADIR%%/data/images/128x128
%%QT%%@dirrm %%DATADIR%%/data/images
@dirrm %%DATADIR%%/data
@dirrmtry %%DATADIR%%/data
@dirrm %%DATADIR%%/copier
@dirrm %%DATADIR%%/base
@dirrm %%DATADIR%%
@dirrmtry %%DATADIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%/styles
%%PORTDOCS%%@dirrm %%DOCSDIR%%/images
%%PORTDOCS%%@dirrm %%DOCSDIR%%