Update to 1.2.0.

Submitted by:	KATO Tsuguru <tkato@prontomail.com>
PR:		34774

Also compile and install the aemenu and aepanel applets, using the
Athena widgets and (when it is available) GTK+.  These applets
provide a list of windows by title (vertically for aemenu, horizontally
for aepanel) and a menu from which programs may be run.
This commit is contained in:
Trevor Johnson 2002-03-16 21:50:52 +00:00
parent 73663a1324
commit be7bf1ed08
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=56225
4 changed files with 78 additions and 30 deletions

View File

@ -6,37 +6,97 @@
#
PORTNAME= aewm
PORTVERSION= 1.1.2
PORTVERSION= 1.2.0
CATEGORIES= x11-wm
MASTER_SITES= http://www.red-bean.com/~decklin/aewm/
MAINTAINER= trevor@FreeBSD.org
BINS= aewm
GTKCLIENTS= aemenu-gtk aepanel-gtk
XAWCLIENTS= set-gnome-pda \
aesession \
aemenu-xaw \
aepanel-xaw
DOCDIR= share/doc/${PORTNAME}
DOCS= Changelog README TODO
DOCS= ChangeLog README TODO DESIGN LICENSE
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" XROOT="${X11BASE}"
MAN1= aewm.1
PLIST= ${WRKDIR}/pkg-plist
USE_GMAKE= yes
USE_X_PREFIX= yes
WANT_GTK= yes
.include <bsd.port.pre.mk>
.if defined(HAVE_GTK)
USE_GTK=yes
.endif
.if !defined(HAVE_GTK)
ALL_TARGET= aewm
.endif
do-patch:
${PERL} -pi -e 's:/etc/X11/aewm/aewmrc:${PREFIX}/etc/aewmrc:g' \
${WRKSRC}/aewm.h
${PERL} -pi -e 's:\+make:\+gmake:g' ${WRKSRC}/Makefile
.if defined(HAVE_GTK)
${PERL} -pi -e 's:gtk-config:${GTK_CONFIG}:g' \
${WRKSRC}/clients/Makefile
${PERL} -pi -e 's:/etc/X11/aewm/clientsrc:${PREFIX}/etc/clientsrc:g' \
${WRKSRC}/clients/lib/aeclients.h
.endif
pre-install:
${ECHO_CMD} bin/aewm > ${PLIST}
${RM} -f ${PLIST}
.for i in aewm aemenu aepanel ${XAWCLIENTS}
${ECHO_CMD} bin/${i} >> ${PLIST}
.endfor
.if defined(HAVE_GTK)
.for i in ${GTKCLIENTS}
${ECHO_CMD} bin/${i} >> ${PLIST}
.endfor
.endif
${ECHO_CMD} share/examples/aewm/aewmrc.sample >> ${PLIST}
${ECHO_CMD} share/examples/aewm/clientsrc.sample >> ${PLIST}
${ECHO_CMD} etc/aewmrc >> ${PLIST}
${ECHO_CMD} etc/clientsrc >> ${PLIST}
.if !defined(NOPORTDOCS)
for i in ${DOCS}; \
do ${ECHO_CMD} ${DOCDIR}/$${i} >> ${PLIST}; \
done
.for i in ${DOCS}
${ECHO_CMD} ${DOCDIR}/${i} >> ${PLIST}
.endfor
${ECHO_CMD} @dirrm ${DOCDIR} >> ${PLIST}
.endif
${ECHO_CMD} @dirrm share/examples/aewm >> ${PLIST}
do-install:
${MKDIR} ${EXAMPLESDIR}
${INSTALL_PROGRAM} ${WRKSRC}/aewm ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/aewm.1x ${PREFIX}/man/man1/aewm.1
.for i in ${XAWCLIENTS}
${INSTALL_PROGRAM} ${WRKSRC}/clients/${i} ${PREFIX}/bin
.endfor
.if defined(HAVE_GTK)
.for i in ${GTKCLIENTS}
${INSTALL_PROGRAM} ${WRKSRC}/clients/${i} ${PREFIX}/bin
.endfor
.if defined(HAVE_GTK)
cd ${PREFIX}/bin && ${LN} -s aemenu-gtk aemenu && \
${LN} -s aepanel-gtk aepanel
.else
cd ${PREFIX}/bin && ${LN} -s aemenu-xaw aemenu && \
${LN} -s aepanel-xaw aepanel
.endif
${INSTALL_DATA} ${WRKSRC}/clients/clientsrc.sample ${EXAMPLESDIR}
.endif
${INSTALL_DATA} ${WRKSRC}/aewmrc.sample ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/aewmrc.sample ${PREFIX}/etc/aewmrc
${INSTALL_DATA} ${WRKSRC}/clients/clientsrc.sample \
${PREFIX}/etc/clientsrc
${INSTALL_MAN} ${WRKSRC}/aewm.1x ${MANPREFIX}/man/man1/aewm.1
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/${DOCDIR}
for i in ${DOCS}; \
do ${INSTALL_DATA} ${WRKSRC}/$${i} ${PREFIX}/${DOCDIR}; \
done
.for i in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/${DOCDIR}
.endfor
.endif
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -1 +1 @@
MD5 (aewm-1.1.2.tar.gz) = 3eca52e76888f768b96d17dcb84b57cc
MD5 (aewm-1.2.0.tar.gz) = 613a22ef5e4c00a4821641d0d92492b2

View File

@ -1,17 +0,0 @@
--- Makefile.orig Mon Jan 1 21:43:57 2001
+++ Makefile Sun Jan 7 13:40:03 2001
@@ -25,12 +25,11 @@
# This should be set to the location of the X installation you want to
# compile against.
-XROOT = /usr/X11R6
+XROOT = $(X11BASE)
# --------------------------------------------------------------------
-CC = gcc
-CFLAGS = -g -O2 -Wall
+CC ?= gcc
BINDIR = $(DESTDIR)$(XROOT)/bin
MANDIR = $(DESTDIR)$(XROOT)/man/man1

View File

@ -3,6 +3,11 @@ It provides titlebars, and allows raising, lowering, resizing, and
hiding (but not un-hiding) windows. Placement of new windows
depends on the position of the pointer. It is partly based on 9wm.
This port installs not only the window manager, but also the aemenu
and aepanel applets. These provide a list of windows by title
(vertically for aemenu, horizontally for aepanel) and a menu from
which programs may be run.
WWW: http://www.red-bean.com/~decklin/aewm/
Trevor Johnson