Upgrade to 1.8.0. Resolve conflict on -CURRENT by changing one of toast.c's

function names, long_to_time, to ch_to_time().  Tim will take care of it
later.

PR:		32992
Submitted by:	Timothy Jensen <toast@blackened.com>
This commit is contained in:
Will Andrews 2001-12-19 01:10:49 +00:00
parent 7312fbe973
commit be4f1e908a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=51764
5 changed files with 12 additions and 76 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= blackened
PORTVERSION= 1.7.1
PORTVERSION= 1.8.0
CATEGORIES= irc
MASTER_SITES= ftp://ftp.blackened.com/pub/irc/blackened/
@ -14,6 +14,10 @@ MAINTAINER= toast@blackened.com
GNU_CONFIGURE= yes
PLIST_SUB= VERSION=${PORTVERSION}
MAKE_ENV= prefix=${PREFIX}
CONFIGURE_ARGS= --prefix=${PREFIX}
INSTALL_TARGET= installeverything
pre-configure:
${PERL} -pi -e "s@long_to_time@ch_to_time@g" ${WRKSRC}/source/toast.c
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (blackened-1.7.1.tar.gz) = 049b1e538eb3bcc78c0a9083dfd014c4
MD5 (blackened-1.8.0.tar.gz) = 285a0a7bdd6c25dde753cdfc81b18e98

View File

@ -1,61 +0,0 @@
--- Makefile.in.orig Mon Jul 26 21:30:12 1999
+++ Makefile.in Thu Jul 29 02:56:55 1999
@@ -23,9 +23,9 @@
# disclean - remove all files geneated by compilation/installation.
prefix = @prefix@
-exec_prefix = @exec_prefix@
-bindir = @bindir@
-datadir = @datadir@
+exec_prefix = ${prefix}
+bindir = ${exec_prefix}/bin
+datadir = ${prefix}/share/blackened
VERSION = @VERSION@
@@ -34,12 +34,12 @@
INSTALL_IRC = $(bindir)/blackened-$(VERSION)
# Name of the symbolic link to be created.
-INSTALL_LINK = $(bindir)/@IRCLINK@
+INSTALL_LINK = $(bindir)/blackened
# Where the ircII library will be. Generally this is the place that
# you put the scripts, help pages and translation tables. It is
# very important that you set this correctly.
-IRCLIB = @IRCLIB@/$(VERSION)
+IRCLIB = $(datadir)/$(VERSION)
# Set this to the lex you want to use, and if they lex uses a library.
@@ -119,16 +119,16 @@
# Set the next line to the full path for installation of the ircserv program
# if you wish to use it.
-INSTALL_IRCSERV = $(bindir)/ircserv
+INSTALL_IRCSERV = $(bindir)/blackened-ircserv
# This little program is necessary to have an interactive shell
# in a window of ircII. The 'shell' script uses it, so also update
# the path in there, if you want to enable this.
-INSTALL_IRCFLUSH = $(bindir)/ircflush
+INSTALL_IRCFLUSH = $(bindir)/blackened-ircflush
# This program allows you to use screen/xterm's to put new irc windows
# on new screen/xterm windows.
-INSTALL_WSERV = $(bindir)/wserv
+INSTALL_WSERV = $(bindir)/blackened-wserv
## You shouldn't have to change anything below here
@@ -246,8 +246,8 @@
$(INSTALL_LIB) lib/help.blackened $(HELP_FILE)
installdirs:
-# umask 022; ./mkinstalldirs $(IRCLIB) $(bindir) $(TRANS_PATH) $(INSTALL_SCRIPT) $(HELP_DIR)
- umask 022; ./mkinstalldirs $(IRCLIB) $(bindir) $(TRANS_PATH) $(INSTALL_SCRIPT)
+# umask 022; ./mkinstalldirs $(IRCLIB) $(bindir) $(TRANS_PATH) $(INSTALL_SCRIPT) $(HELP_DIR) 2>&1
+ umask 022; ./mkinstalldirs $(IRCLIB) $(bindir) $(TRANS_PATH) $(INSTALL_SCRIPT) 2>&1
helpclean:
$(RM) lib/help.blackened

View File

@ -1,15 +1,7 @@
Blackened is an alternative IRC client made by Timothy
Jensen <toast@blackened.com> that offers a variety of new
features not found in other clients, such as:
o Personalized timestamps
o Message redirection
o $randread() function
o "Snazzy new look"
o Banlist formatting
o Additional bind keys, e.g. PAGE_UP and PAGE_DOWN
Blackened is an enhanced IRC client that offers a variety of features
not found in other clients, including commands designed for IRC
server operators and administrators. Normal users also benefit from
additional functionality.
WWW: http://www.blackened.com/blackened/
IRC: irc.blackened.com #blackened
- Will <andrews@technologist.com>

View File

@ -3,6 +3,7 @@ bin/blackened-%%VERSION%%
bin/blackened-ircserv
bin/blackened-wserv
bin/blackened-ircflush
man/man1/blackened.1
share/blackened/%%VERSION%%/translation/ASCII
share/blackened/%%VERSION%%/translation/CP437
share/blackened/%%VERSION%%/translation/CP850