Unbreak with XFCE 4.8

This commit is contained in:
Ade Lovett 2011-11-09 18:29:53 +00:00
parent 17b9b39d43
commit be46296477
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=285388
2 changed files with 17 additions and 2 deletions

View File

@ -18,8 +18,6 @@ COMMENT= Lightweight media player for Xfce4 based on the xine engine
LIB_DEPENDS= xine.1:${PORTSDIR}/multimedia/libxine
BROKEN= Does not work with Xfce 4.8
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
USE_BZIP2= yes
@ -61,5 +59,10 @@ CFLAGS+= -I${LOCALBASE}/include
post-patch:
@${REINPLACE_CMD} -e "s|xfmedia_remote_LDADD = |&@LIBXFCEGUI4_LIBS@|" \
${WRKSRC}/src/Makefile.in
@${REINPLACE_CMD} -e "s|exo-0.3|exo-1|" ${WRKSRC}/configure
.for file in mediamarks.c playlist.c settings-dialog.c xfmedia-playlist-queue.c
@${REINPLACE_CMD} -e "s|EXO_PANGO_ELLIPSIZE_END|PANGO_ELLIPSIZE_END|" \
${WRKSRC}/src/${file}
.endfor
.include <bsd.port.post.mk>

View File

@ -0,0 +1,12 @@
--- src/playlist-files.c.orig 2006-11-26 23:21:23.000000000 -0800
+++ src/playlist-files.c 2011-11-04 12:28:14.000000000 -0700
@@ -815,3 +815,3 @@
- md5sum = exo_str_get_md5_str(original_uri);
+ md5sum = g_compute_checksum_for_string(G_CHECKSUM_MD5, original_uri, -1);
@@ -843,3 +843,3 @@
- md5sum = exo_str_get_md5_str(original_uri);
+ md5sum = g_compute_checksum_for_string(G_CHECKSUM_MD5, original_uri, -1);