net-im/telegram-desktop: Update to 2.4.4

Update to 2.4.4. Noticeable changes:
* Add NDEBUG to CXXFLAGS. This disables DCHECKs and allows video calls to work.
* Change to cmake for rlottie and tg_owt. When they can be packaged properly,
  we may revert this patch and use separately packaged ports for them.

Changelog:
2.4.4 (23.10.20)

- Fix application quit on call end with main window hidden in tray.
- Update OpenAL library on Windows.
- Several crash fixes.

2.4.3 (07.10.20)

- Fix sending voice messages in scheduled messages section.
- Fix deleting profile / group / channel photos.
- Several crash fixes.

2.4.2 (02.10.20)

- Allow block, report and delete all message from user from "user joined"
  service message context menu.
- Fix admin badge display in groups.
- Fix loading and opening of comments in channels.

2.4.1 (01.10.20)

- Move by PageUp and PageDown in channel comments.
- Several layout bugfixes.
- Several crashfixes.

2.4 (30.09.20)

- Turn on "Remain Anonymous" in an admin's Permissions to let them post on behalf
  of the group and become invisible in the list of members.
- Comment on posts in channels that have a discussion group.
- Get notified about replies to your comments via the new Replies chat (if you
  are not a member of the discussion group).

PR:		250393
Submitted by:	Henry Hu (maintainer)
Reported by:	Volodymyr Kostyrko
This commit is contained in:
Mikael Urankar 2020-11-07 18:50:05 +00:00
parent 74ac6e1ff5
commit be2dc8afac
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=554414
7 changed files with 68 additions and 51 deletions

View File

@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= telegram-desktop
DISTVERSION= 2.3.2
PORTREVISION= 1
DISTVERSION= 2.4.4
CATEGORIES= net-im
MASTER_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/releases/download/v${DISTVERSION}/
DISTNAME= tdesktop-${DISTVERSION}-full
@ -50,7 +49,7 @@ NO_CCACHE= yes
USE_GITHUB= nodefault
GH_ACCOUNT= telegramdesktop
GH_PROJECT= tdesktop
GH_TUPLE= desktop-app:tg_owt:fc49a0e:tg_owt/tg_owt
GH_TUPLE= desktop-app:tg_owt:c73a471:tg_owt/tg_owt
USE_GNOME= glib20
USE_QT= core dbus gui imageformats network widgets buildtools_build \
qmake_build wayland
@ -67,6 +66,9 @@ CMAKE_ARGS= -DDESKTOP_APP_SPECIAL_TARGET="" -DTDESKTOP_LAUNCHER_BASENAME="telegr
-Ddisable_autoupdate=1 \
-DDESKTOP_APP_WEBRTC_LOCATION=${WRKSRC}/tg_owt/src
# Disable DCHECKs, otherwise video calls will crash.
CXXFLAGS+= -DNDEBUG
# Telegram asks each custom build to have its own API ID and hash.
TELEGRAM_API_ID= 601761
TELEGRAM_API_HASH= 20a3432aab43f24bb4460fceac5ba38d

View File

@ -1,5 +1,5 @@
TIMESTAMP = 1598842893
SHA256 (tdesktop-2.3.2-full.tar.gz) = 292631bcac4b30f778879ecd2cebf4c6f569ab5be01230c8e62b924b4211a259
SIZE (tdesktop-2.3.2-full.tar.gz) = 36402335
SHA256 (desktop-app-tg_owt-fc49a0e_GH0.tar.gz) = bb17463246eeacf9f7bc97b04d0ff60f5f207f69a19482094e3a1cc14b46f4e4
SIZE (desktop-app-tg_owt-fc49a0e_GH0.tar.gz) = 18379679
TIMESTAMP = 1603766669
SHA256 (tdesktop-2.4.4-full.tar.gz) = 88799708daedaf5c132752259945b4e1b5dcbb62385661e2cca7b8e5d58c9026
SIZE (tdesktop-2.4.4-full.tar.gz) = 36220573
SHA256 (desktop-app-tg_owt-c73a471_GH0.tar.gz) = d1886a3ba6966fef257f63a3dd39f53d01ff8db0177fcd6de1b64916cd4076e1
SIZE (desktop-app-tg_owt-c73a471_GH0.tar.gz) = 18383113

View File

@ -1,14 +1,14 @@
--- Telegram/lib_base/base/platform/linux/base_info_linux.cpp.orig 2020-08-10 11:25:13 UTC
--- Telegram/lib_base/base/platform/linux/base_info_linux.cpp.orig 2020-10-20 16:29:09 UTC
+++ Telegram/lib_base/base/platform/linux/base_info_linux.cpp
@@ -13,7 +13,6 @@
@@ -11,7 +11,6 @@
#include <QtCore/QVersionNumber>
#include <QtCore/QDate>
#include <QtGui/QGuiApplication>
-#include <gnu/libc-version.h>
namespace Platform {
namespace {
@@ -72,11 +71,9 @@ QString SystemVersionPretty() {
@@ -32,11 +31,9 @@ QString SystemVersionPretty() {
const auto value = result ? QString::fromLatin1(result) : QString();
const auto list = value.split(':', QString::SkipEmptyParts);
@ -22,7 +22,7 @@
}
QString SystemCountry() {
@@ -94,10 +91,6 @@ QString SystemLanguage() {
@@ -54,10 +51,6 @@ QString SystemLanguage() {
QDate WhenSystemBecomesOutdated() {
if (IsLinux32Bit()) {
return QDate(2020, 9, 1);
@ -33,7 +33,7 @@
}
return QDate();
}
@@ -118,14 +111,6 @@ QString AutoUpdateKey() {
@@ -78,14 +71,6 @@ QString AutoUpdateKey() {
} else {
Unexpected("Platform in AutoUpdateKey.");
}

View File

@ -0,0 +1,11 @@
--- cmake/external/rlottie/CMakeLists.txt.orig 2020-10-23 14:48:52 UTC
+++ cmake/external/rlottie/CMakeLists.txt
@@ -7,7 +7,7 @@
add_library(external_rlottie INTERFACE IMPORTED GLOBAL)
add_library(desktop-app::external_rlottie ALIAS external_rlottie)
-if (DESKTOP_APP_USE_PACKAGED)
+if (0) # DESKTOP_APP_USE_PACKAGED
find_package(rlottie QUIET)
if (rlottie_FOUND)

View File

@ -1,17 +1,32 @@
--- cmake/external/webrtc/CMakeLists.txt.orig 2020-08-20 13:59:10 UTC
--- cmake/external/webrtc/CMakeLists.txt.orig 2020-10-23 14:48:52 UTC
+++ cmake/external/webrtc/CMakeLists.txt
@@ -76,7 +76,7 @@ if (APPLE)
@@ -7,11 +7,11 @@
add_library(external_webrtc INTERFACE IMPORTED GLOBAL)
add_library(desktop-app::external_webrtc ALIAS external_webrtc)
-if (DESKTOP_APP_USE_PACKAGED)
+if (0) # DESKTOP_APP_USE_PACKAGED
find_package(tg_owt REQUIRED)
target_link_libraries(external_webrtc INTERFACE tg_owt::tg_owt)
else()
- set(webrtc_loc ${libs_loc}/tg_owt/src)
+ set(webrtc_loc ${DESKTOP_APP_WEBRTC_LOCATION})
set(webrtc_build_loc ${libs_loc}/tg_owt/out/$<CONFIG>)
target_compile_definitions(external_webrtc
@@ -75,7 +75,7 @@ else()
)
endif()
foreach (lib ${webrtc_libs})
- list(APPEND webrtc_libs_list "${webrtc_build_loc}/${lib}${webrtc_lib_suffix}")
+ list(APPEND webrtc_libs_list "${DESKTOP_APP_WEBRTC_LOCATION}/../out/$<CONFIG>/${lib}${webrtc_lib_suffix}")
endforeach()
if (WIN32)
@@ -98,5 +98,6 @@ else()
INTERFACE
${webrtc_libs_list}
desktop-app::external_openssl
+ jpeg
)
endif()
foreach (lib ${webrtc_libs})
- list(APPEND webrtc_libs_list "${webrtc_build_loc}/${lib}${webrtc_lib_suffix}")
+ list(APPEND webrtc_libs_list "${DESKTOP_APP_WEBRTC_LOCATION}/../out/$<CONFIG>/${lib}${webrtc_lib_suffix}")
endforeach()
if (WIN32)
@@ -99,4 +99,5 @@ target_link_libraries(external_webrtc
INTERFACE
${webrtc_libs_list}
desktop-app::external_openssl
+ jpeg
)

View File

@ -1,4 +1,4 @@
--- tg_owt/CMakeLists.txt.orig 2020-08-30 09:41:57 UTC
--- tg_owt/CMakeLists.txt.orig 2020-10-07 14:11:02 UTC
+++ tg_owt/CMakeLists.txt
@@ -38,7 +38,6 @@ include(cmake/libopenh264.cmake)
include(cmake/libpffft.cmake)
@ -8,19 +8,19 @@
include(cmake/libvpx.cmake)
include(cmake/libwebrtcbuild.cmake)
include(cmake/libyuv.cmake)
@@ -61,7 +60,6 @@ PRIVATE
tg_owt::libpffft
tg_owt::librnnoise
tg_owt::libsrtp
- tg_owt::libusrsctp
tg_owt::libvpx
tg_owt::libvpx_mmx
tg_owt::libvpx_sse2
@@ -1757,7 +1755,6 @@ TARGETS
@@ -62,7 +61,6 @@ if (is_x86 OR is_x64)
tg_owt::libpffft
tg_owt::librnnoise
tg_owt::libsrtp
- tg_owt::libusrsctp
tg_owt::libvpx
tg_owt::libvpx_mmx
tg_owt::libvpx_sse2
@@ -1839,7 +1837,6 @@ TARGETS
libpffft
librnnoise
libsrtp
- libusrsctp
libvpx
libvpx_mmx
libvpx_sse2
${vpx_export}
libwebrtcbuild

View File

@ -1,11 +0,0 @@
--- tg_owt/cmake/init_target.cmake.orig 2020-08-30 09:41:57 UTC
+++ tg_owt/cmake/init_target.cmake
@@ -10,7 +10,7 @@ function(init_target target_name) # init_target(my_tar
elseif (APPLE)
target_compile_features(${target_name} PUBLIC cxx_std_14)
else()
- target_compile_features(${target_name} PUBLIC cxx_std_20)
+ target_compile_features(${target_name} PUBLIC cxx_std_17)
endif()
if (CMAKE_CXX_COMPILER_ID STREQUAL "MSVC")
set_target_properties(${target_name} PROPERTIES