Import of jbigkit, which contains yet another graphics library.

Closes PR 2066.

Submitted by:	Mikhail Teterin <mi@aldan.ziplink.net>
This commit is contained in:
Thomas Gellekum 1996-12-23 07:12:29 +00:00
parent 976772a44c
commit be07477ea0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=5068
7 changed files with 122 additions and 0 deletions

31
graphics/jbigkit/Makefile Normal file
View File

@ -0,0 +1,31 @@
# New ports collection makefile for: jbig
# Version required: 0.9
# Date created: 19 November 1996
# Whom: mi
#
# $Id$
#
DISTNAME= jbigkit-0.9
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.informatik.uni-erlangen.de/pub/doc/ISO/JBIG/
MAINTAINER= mi@aldan.ziplink.net
# Yes, CCFLAGS, not CFLAGS! -mi
MAKE_FLAGS= CCFLAGS="${CFLAGS}" CC="${CC}"
WRKSRC= work/jbigkit
MAN1= jbgtopbm.1 pbmtojbg.1
MAN5= pbm.5
post-build:
cd $(WRKSRC); make test
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/jbig
${INSTALL_DATA} ${WRKSRC}/libjbig/jbig.doc ${PREFIX}/share/doc/jbig
.endif
/sbin/ldconfig -m ${PREFIX}/lib
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (jbigkit-0.9.tar.gz) = fbc972a96f3e4e9c90eea96020085e2c

View File

@ -0,0 +1,21 @@
--- Makefile.orig Tue Jan 9 16:26:33 1996
+++ Makefile Tue Dec 3 18:33:09 1996
@@ -30,3 +30,18 @@
distribution: clean
rm -f libjbig/libjbig.a
(cd ..; tar -c -v --exclude RCS -f jbigkit.tar jbigkit)
+
+install:
+ mkdir -p ${PREFIX}/bin
+ install -c -s -m 755 -o bin -g bin pbmtools/jbgtopbm ${PREFIX}/bin
+ install -c -s -m 755 -o bin -g bin pbmtools/pbmtojbg ${PREFIX}/bin
+ mkdir -p ${PREFIX}/man/man1
+ install -c -m 644 -o bin -g bin pbmtools/pbmtojbg.1 ${PREFIX}/man/man1
+ install -c -m 644 -o bin -g bin pbmtools/jbgtopbm.1 ${PREFIX}/man/man1
+ mkdir -p ${PREFIX}/man/man5
+ install -c -m 644 -o bin -g bin pbmtools/pbm.5 ${PREFIX}/man/man5
+ mkdir -p ${PREFIX}/include
+ install -c -m 644 -o bin -g bin libjbig/jbig.h ${PREFIX}/include
+ mkdir -p ${PREFIX}/lib
+ install -c -m 644 -o bin -g bin libjbig/libjbig.a ${PREFIX}/lib
+ install -c -m 644 -o bin -g bin libjbig/libjbig.so.0.9 ${PREFIX}/lib

View File

@ -0,0 +1,31 @@
--- libjbig/Makefile.orig Tue Jan 9 16:18:50 1996
+++ libjbig/Makefile Sat Dec 21 17:41:00 1996
@@ -7,7 +7,7 @@
# Options for the compiler: A high optimization level is suggested
CFLAGS = -O -Wall -ansi -pedantic
-all: libjbig.a tstcodec
+all: libjbig.a libjbig.so.0.9 tstcodec
tstcodec: tstcodec.c jbig.c jbig.h jbig_tab.o
$(CC) $(CFLAGS) -o tstcodec -DTEST_CODEC tstcodec.c jbig.c \
@@ -18,7 +18,19 @@
ar rc libjbig.a jbig.o jbig_tab.o
ranlib libjbig.a
+libjbig.so.0.9: jbig.so jbig_tab.so
+ rm -f ${.TARGET}
+ ld -Bshareable -o ${.TARGET} ${.ALLSRC}
+
jbig.o: jbig.c jbig.h
+
+.SUFFIXES: .c .so
+.c.so:
+ ${CC} -c -fpic -DPIC ${CFLAGS} ${.IMPSRC} -o ${.TARGET}
+
+jbig.so: jbig.c jbig.h
+
+jbig_tab.so: jbig_tab.c
test: tstcodec
./tstcodec

View File

@ -0,0 +1 @@
JBIG-KIT lossless image compression library

View File

@ -0,0 +1,26 @@
JBIG-KIT implements a highly effective data compression algorithm for
bi-level high-resolution images such as fax pages or scanned
documents.
JBIG-KIT provides a portable library of compression and decompression
functions with a documented interface that you can very easily include
into your image or document processing software. In addition, JBIG-KIT
provides ready-to-use compression and decompression programs with a
simple command line interface (similar to the converters found in Jef
Poskanzer's PBM graphics file conversion package).
JBIG-KIT implements the specification
International Standard ISO/IEC 11544:1993 and ITU-T Recommendation
T.82(1993), "Information technology - Coded representation of picture
and audio information - progressive bi-level image compression",
<http://www.itu.ch/itudoc/itu-t/rec/t/t82_23822.html>,
which is commonly referred to as the "JBIG standard". JBIG (Joint
Bi-level Image experts Group) is the committee which developed this
international standard for the lossless compression of images using
arithmetic coding. Like the well-known compression algorithms JPEG and
MPEG, also JBIG has been developed and published by the International
Organization for Standardization (ISO) and the International
Telecommunication Union (ITU) (see also <http://www.iso.ch/> and
<http://www.itu.ch/>).

View File

@ -0,0 +1,11 @@
include/jbig.h
bin/pbmtojbg
bin/jbgtopbm
man/man1/jbgtopbm.1.gz
man/man1/pbmtojbg.1.gz
man/man5/pbm.5.gz
lib/libjbig.a
@exec ranlib %D/%F
lib/libjbig.so.0.9
@exec ldconfig -m %B
share/doc/jbig/jbig.doc