astro/wmmoonclock: update to 1.29
While here: * Rework patch to comply with makepatch style * Add missing USES=pkgconfig PR: 245539 Submitted by: mbeis@xs4all.nl (maintainer)
This commit is contained in:
parent
5a7d8af2f2
commit
be01f7c0f6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=531763
@ -1,26 +1,24 @@
|
||||
# Created by: Kris Kennaway <kkennawa@physics.adelaide.edu.au>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= wmMoonClock
|
||||
PORTVERSION= 1.27
|
||||
PORTREVISION= 3
|
||||
PORTNAME= wmmoonclock
|
||||
PORTVERSION= 1.29
|
||||
CATEGORIES= astro windowmaker
|
||||
MASTER_SITES= http://www.cs.mun.ca/~gstarkes/wmaker/dockapps/files/
|
||||
MASTER_SITES= https://www.dockapps.net/download/
|
||||
|
||||
MAINTAINER= mbeis@xs4all.nl
|
||||
COMMENT= Displays the phase of the moon, plus orbital data
|
||||
|
||||
LICENSE= GPLv2
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}/Src
|
||||
|
||||
USES= gmake xorg
|
||||
USE_XORG= xpm
|
||||
GNU_CONFIGURE= yes
|
||||
USES= autoreconf:build pkgconfig xorg
|
||||
USE_XORG+= x11 xext xpm
|
||||
|
||||
PLIST_FILES= bin/wmmoonclock man/man1/wmmoonclock.1.gz
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/wmMoonClock ${STAGEDIR}${PREFIX}/bin/wmmoonclock
|
||||
${INSTALL_MAN} ${WRKSRC}/wmMoonClock.1 ${STAGEDIR}${PREFIX}/man/man1/wmmoonclock.1
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/wmmoonclock ${STAGEDIR}${PREFIX}/bin/wmmoonclock
|
||||
${INSTALL_MAN} ${WRKSRC}/src/wmMoonClock.1 ${STAGEDIR}${PREFIX}/man/man1/wmmoonclock.1
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,3 @@
|
||||
SHA256 (wmMoonClock-1.27.tar.gz) = 439d330a30ee1cb084e0512e894f5e1a2e9869745a2274fbd9a56832c1527c77
|
||||
SIZE (wmMoonClock-1.27.tar.gz) = 155197
|
||||
TIMESTAMP = 1586605073
|
||||
SHA256 (wmmoonclock-1.29.tar.gz) = beb9e108d90027df4bf2252b3669c153c858976c1099be3462d536073435203a
|
||||
SIZE (wmmoonclock-1.29.tar.gz) = 234991
|
||||
|
@ -1,16 +0,0 @@
|
||||
--- Makefile.orig 1999-03-23 02:20:32 UTC
|
||||
+++ Makefile
|
||||
@@ -1,8 +1,8 @@
|
||||
-CC = gcc
|
||||
-CFLAGS = -O2
|
||||
-INCDIR = -I/usr/X11R6/include/X11
|
||||
-DESTDIR= /usr/X11R6
|
||||
-LIBDIR = -L/usr/X11R6/lib
|
||||
+CC ?= gcc
|
||||
+CFLAGS ?= -O2
|
||||
+INCDIR = -I${LOCALBASE}/include
|
||||
+DESTDIR= ${PREFIX}
|
||||
+LIBDIR = -L${LOCALBASE}/lib
|
||||
|
||||
# for Linux
|
||||
LIBS = -lXpm -lX11 -lXext
|
12
astro/wmmoonclock/files/patch-src_wmMoonClock.c
Normal file
12
astro/wmmoonclock/files/patch-src_wmMoonClock.c
Normal file
@ -0,0 +1,12 @@
|
||||
--- src/wmMoonClock.c.orig 2017-08-14 22:31:05 UTC
|
||||
+++ src/wmMoonClock.c
|
||||
@@ -157,7 +157,8 @@ int main(int argc, char *argv[]) {
|
||||
struct tm *GMTTime, *LocalTime;
|
||||
XEvent event;
|
||||
int i, n, j, ImageNumber, Year, Month, DayOfMonth, digit;
|
||||
- long CurrentLocalTime, CurrentGMTTime, date;
|
||||
+ time_t CurrentLocalTime, CurrentGMTTime;
|
||||
+ long date;
|
||||
double UT, val, RA, DEC, UTRise, UTSet, LocalHour, hour24();
|
||||
int D, H, M, S, sgn, A, B, q;
|
||||
CTrans c;
|
@ -1,12 +0,0 @@
|
||||
--- wmMoonClock.c.orig 1999-06-07 14:27:18 UTC
|
||||
+++ wmMoonClock.c
|
||||
@@ -162,7 +162,8 @@ int main(int argc, char *argv[]) {
|
||||
int i, n, k, j, ImageNumber;
|
||||
int Year, Month, DayOfWeek, DayOfMonth;
|
||||
int Hours, Mins, Secs, OldSecs, digit, xoff, xsize;
|
||||
- long CurrentLocalTime, CurrentGMTTime, date;
|
||||
+ time_t CurrentLocalTime, CurrentGMTTime;
|
||||
+ long date;
|
||||
double UT, val, RA, DEC, UTRise, UTSet, LocalHour, hour24();
|
||||
int D, H, M, S, sgn, A, B, q;
|
||||
char str[10];
|
@ -5,4 +5,4 @@ image multiple times).
|
||||
|
||||
Probably most of the data is not that useful, but what the heck :)
|
||||
|
||||
WWW: http://www.cs.mun.ca/~gstarkes/wmaker/dockapps/time.html#wmmoonclock
|
||||
WWW: https://www.dockapps.net/wmmoonclock
|
||||
|
Loading…
Reference in New Issue
Block a user