TrustedPickle is a Python module that can save most any arbitrary Python object

in a signed pickle file. There are two big differences between this module and
the standard pickle module. First, TrustedPickle can pickle a module, but the
standard pickle module cannot. Second, TrustedPickle includes a signature that
can verify the data's origin before the data is unpickled.

WWW: http://trustedpickle.sourceforge.net/index.html

PR:		ports/96691
Submitted by:	Alexander Botero-Lowry <alex@foxybanana.com>
Approved by:	lawrance (mentor)
This commit is contained in:
Ion-Mihai Tetcu 2006-05-09 11:46:02 +00:00
parent 2294228d09
commit bdcd0201a6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=161798
5 changed files with 59 additions and 0 deletions

View File

@ -517,6 +517,7 @@
SUBDIR += py-pycrypto
SUBDIR += py-rijndael
SUBDIR += py-twofish
SUBDIR += py-trustedpickle
SUBDIR += py-twistedConch
SUBDIR += py-xmlsec
SUBDIR += qca-tls

View File

@ -0,0 +1,38 @@
# New ports collection makefile for: py-trustedpickle
# Date created: 02 May 2006
# Whom: Alexander Botero-Lowry <alex@foxybanana.com>
#
# $FreeBSD$
#
PORTNAME= trustedpickle
PORTVERSION= 0.02
CATEGORIES= security python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= TrustedPickle
EXTRACT_SUFX= .tgz
MAINTAINER= alex@foxybanana.com
COMMENT= TrustedPickle is a Python (de)Pickler with a way to verify the data
USE_PYTHON= yes
USE_DOS2UNIX= yes
PLIST_FILES= %%PYTHON_SITELIBDIR%%/TrustedPickle.py \
%%PYTHON_SITELIBDIR%%/TrustedPickle.pyc \
%%PYTHON_SITELIBDIR%%/TrustedPickle.pyo
WRKSRC= ${WRKDIR}/${PORTNAME}
do-build:
@cd ${WRKSRC} && ${PYTHON_CMD} -OOOO -c 'import TrustedPickle' && \
${PYTHON_CMD} -c 'import TrustedPickle'
do-install:
${INSTALL_DATA} ${WRKSRC}/TrustedPickle.py ${PYTHON_SITELIBDIR}
${INSTALL_DATA} ${WRKSRC}/TrustedPickle.pyc ${PYTHON_SITELIBDIR}
${INSTALL_DATA} ${WRKSRC}/TrustedPickle.pyo ${PYTHON_SITELIBDIR}
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
MD5 (TrustedPickle.tgz) = 578cd6d7c114e914d12e04ea540b9f67
SHA256 (TrustedPickle.tgz) = 06a99ddb6b245edc1e3d69a95b9b0ec5f666eefd39d6817dda5e2c19a167a29c
SIZE (TrustedPickle.tgz) = 21437

View File

@ -0,0 +1,10 @@
--- TrustedPickle.py.orig Tue May 2 14:20:14 2006
+++ TrustedPickle.py Tue May 2 14:20:24 2006
@@ -82,6 +82,7 @@
Low-level functions in this module you should not need to call:
Hash(): used in signing a string
+"""
import cPickle
import getpass

View File

@ -0,0 +1,7 @@
TrustedPickle is a Python module that can save most any arbitrary Python object
in a signed pickle file. There are two big differences between this module and
the standard pickle module. First, TrustedPickle can pickle a module, but the
standard pickle module cannot. Second, TrustedPickle includes a signature that
can verify the data's origin before the data is unpickled.
WWW: http://trustedpickle.sourceforge.net/index.html