A port for the PL/Python module that comes with Postgres

This commit is contained in:
Dima Dorfman 2004-11-06 14:41:04 +00:00
parent b0e5826e63
commit bda6b7e166
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=120962
5 changed files with 45 additions and 0 deletions

View File

@ -252,6 +252,7 @@
SUBDIR += postgresql-libpq++
SUBDIR += postgresql-libpqxx
SUBDIR += postgresql-odbc
SUBDIR += postgresql-plpython
SUBDIR += postgresql-plruby
SUBDIR += postgresql-pltcl
SUBDIR += postgresql-relay

View File

@ -0,0 +1,25 @@
# New ports collection makefile for: PostgreSQL PL/Python
# Date created: March 4, 2004
# Whom: Dima Dorfman <dd@FreeBSD.org>
#
# $FreeBSD$
#
CATEGORIES= databases python
PKGNAMESUFFIX= -plpython
MAINTAINER= dd@FreeBSD.org
COMMENT= A module for using Python to write SQL functions
POSTGRESQL_PORT?= databases/postgresql7
POSTGRESQL_SUBPORT=YES
.include "../../${POSTGRESQL_PORT}/Makefile"
RUN_DEPENDS= postgres:${PORTSDIR}/${POSTGRESQL_PORT}
USE_PYTHON= yes
MAKE_ARGS+= -C src/pl/plpython
CONFIGURE_ARGS= --with-python
.include <bsd.port.mk>

View File

@ -0,0 +1,11 @@
--- src/pl/plpython/Makefile~ Thu Mar 4 08:06:19 2004
+++ src/pl/plpython/Makefile Thu Mar 4 08:06:44 2004
@@ -8,7 +8,7 @@
# On some platforms we can only build PL/Python if libpython is a
# shared library. Since there is no official way to determine this,
# we see if there is a file that is named like a shared library.
-ifneq (,$(wildcard $(python_configdir)/libpython*$(DLSUFFIX)*))
+ifneq (,$(wildcard $(python_configdir)/../../libpython*$(DLSUFFIX)*))
shared_libpython = yes
endif

View File

@ -0,0 +1,6 @@
PL/Python allows one to write PostgeSQL stored functions and
procedures in Python (http://www.python.org/).
This software is part of the standard PostgreSQL distribution.
WWW: http://www.postgresql.org/

View File

@ -0,0 +1,2 @@
lib/postgresql/plpython.so
@unexec rmdir %D/lib/postgresql 2>/dev/null || true