A high quality tetrahedral mesher. It can be plugged in cad/gmsh.

PR:		ports/91604
Submitted by:	Pedro F. Giffuni <giffunip@asme.org>
This commit is contained in:
Pav Lucistnik 2006-01-15 01:43:25 +00:00
parent 2ff087e1a6
commit bd9cee8843
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=153525
6 changed files with 87 additions and 0 deletions

View File

@ -270,6 +270,7 @@
SUBDIR += surf
SUBDIR += tablix
SUBDIR += taucs
SUBDIR += tetgen
SUBDIR += tomsfastmath
SUBDIR += topaz
SUBDIR += triangle

39
math/tetgen/Makefile Normal file
View File

@ -0,0 +1,39 @@
# New ports collection makefile for: tetgen
# Date created: 16 December 2005
# Whom: Pedro F. Giffuni
#
# $FreeBSD$
#
PORTNAME= tetgen
PORTVERSION= 1.3.4
CATEGORIES= math
MASTER_SITES= http://www.wias-berlin.de/people/si/
DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= giffunip@asme.org
COMMENT= A Quality Tetrahedral Mesh Generator and Delaunay Triangulator
NO_CDROM= "Tetgen is for academic or personal use only"
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}
MAKEFILE= makefile
ALL_TARGET= tetgen tetlib
.if defined(MAINTAINER_MODE)
test: build
(cd ${INSTALL_WRKSRC} && ./tetgen -p example.poly )
.endif
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/tetgen ${PREFIX}/bin
@${INSTALL_DATA} ${WRKSRC}/tetgen.h ${PREFIX}/include
@${INSTALL_DATA} ${WRKSRC}/libtet.a ${PREFIX}/lib
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/manual.pdf ${DOCSDIR}
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/example.poly ${EXAMPLESDIR}
.endif
.include <bsd.port.mk>

3
math/tetgen/distinfo Normal file
View File

@ -0,0 +1,3 @@
MD5 (tetgen1.3.4.tar.gz) = bdc20002e8b871304f3c2889c881c71a
SHA256 (tetgen1.3.4.tar.gz) = 9e49464d52041241065c7d0defaede7ae8a06a13c9156f85837d652c03392245
SIZE (tetgen1.3.4.tar.gz) = 776750

View File

@ -0,0 +1,25 @@
--- makefile.orig Mon Jan 9 11:33:37 2006
+++ makefile Mon Jan 9 11:35:33 2006
@@ -6,7 +6,7 @@
# CC should be set to the name of your favorite C++ compiler.
-CC = g++
+CC = $(CXX)
# OPT is the level of optimiztion, default is -O. One should try -O2, -O3
# ... to find the best optimization level.
@@ -23,11 +23,11 @@
# down the speed of TetGen. They can be skipped by define the -DNDEBUG
# switch.
-CFLAGS =
+CFLAGS ?= $(CXXFLAGS)
# RM should be set to the name of your favorite rm (file deletion program).
-RM = /bin/rm
+RM ?= /bin/rm
# The action starts here.

12
math/tetgen/pkg-descr Normal file
View File

@ -0,0 +1,12 @@
TetGen is a program for generating tetrahedral meshes for arbitrary 3D
domains. The main purpose of TetGen is to create high-quality tetrahedral
meshes for solving partial differential equations using finite element
and finite volume methods. This program, based on Delaunay methods,
currently generates meshes including exact constrained Delaunay
tetrahedralizations and quality (conforming Delaunay) meshes. For a 3D
point set, it generates its exact Delaunay tetrahedralization and convex
hull as well. The program is written in ANSI C++. It is highly portable,
it should be very easy to compile and run on all major computer systems.
It can be also used as a library embedded into other applications.
WWW: http://tetgen.berlios.de/

7
math/tetgen/pkg-plist Normal file
View File

@ -0,0 +1,7 @@
bin/tetgen
include/tetgen.h
lib/libtet.a
%%PORTDOCS%%%%DOCSDIR%%/manual.pdf
%%PORTDOCS%%%%EXAMPLESDIR%%/example.poly
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%