- License

- Switch to options helpers
- Cosmetic fixes
- Update WWW
- Regenerate patches with `make makepatch`
This commit is contained in:
Dmitry Marakasov 2016-07-23 09:00:54 +00:00
parent abce22437e
commit bd9a350e91
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=418950
3 changed files with 16 additions and 9 deletions

View File

@ -12,8 +12,10 @@ DISTNAME= PyLTXML-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Python bindings to the LT XML toolkit
LICENSE= GPLv2 # only `GPL' is mentioned, assuming v2
BUILD_DEPENDS= ${LOCALBASE}/include/ltxml12/lt-safe.h:textproc/ltxml
RUN_DEPENDS:= ${BUILD_DEPENDS}
RUN_DEPENDS= ${LOCALBASE}/include/ltxml12/lt-safe.h:textproc/ltxml
USES= python
USE_PYTHON= distutils autoplist
@ -23,6 +25,7 @@ DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
PORTDOCS= 00README
PORTEXAMPLES= *
OPTIONS_DEFINE= DOCS EXAMPLES
.include <bsd.port.pre.mk>
@ -32,11 +35,15 @@ CFLAGS+= -fPIC
.endif
post-install:
${STRIP_CMD} \
@${STRIP_CMD} \
${STAGEDIR}${PYTHON}${PYTHON_SITELIBDIR}/PyLTXML/LTXMLinter.so
@${MKDIR} ${STAGEDIR}${DOCSDIR} ${STAGEDIR}${EXAMPLESDIR}
post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/example/* ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.post.mk>

View File

@ -1,6 +1,6 @@
--- ./setup.py.orig 2008-01-11 15:26:31.000000000 +0100
+++ ./setup.py 2014-03-24 17:33:02.100042933 +0100
@@ -6,9 +6,7 @@
--- setup.py.orig 2008-01-11 14:26:31 UTC
+++ setup.py
@@ -6,9 +6,7 @@ import sys
from distutils.core import setup, Extension
from distutils import sysconfig
@ -11,7 +11,7 @@
if sys.platform.find("win32",0,5)==0:
incldirs=['C:\\Program Files\\msys\\1.0\\include\\ltxml12','C:\\Program Files\\msys\\1.0\\include']
@@ -32,8 +30,6 @@
@@ -32,8 +30,6 @@ else:
libs=['ltapi12','ltstd12', 'z']
macros=[('FOR_LT', '1')] # ,('ALLOC_DEBUG', '1')
@ -20,7 +20,7 @@
if sys.platform.find("sunos",0,5)==0:
extra_link_args=['-mimpure-text']
extra_compile_args=['-mimpure-text']
@@ -65,5 +61,4 @@
@@ -65,5 +61,4 @@ setup(name='PyLTXML',
See 00README for details""",
platforms=[platform],
packages=['PyLTXML'],

View File

@ -1,3 +1,3 @@
Python bindings for the LT XML API and toolkit.
WWW: http://www.ltg.ed.ac.uk/software/xml/
WWW: https://www.ltg.ed.ac.uk/software/ltxml/